[package] update mg to 20090107 (#5470)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16800 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c7a331a2bf
commit
35edf09d18
@ -1,4 +1,4 @@
|
||||
#
|
||||
#
|
||||
# Copyright (C) 2008-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mg
|
||||
PKG_VERSION:=20070529
|
||||
PKG_VERSION:=20090107
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.xs4all.nl/~hanb/software/mg
|
||||
PKG_MD5SUM:=e1eaef5a61143c12a66e23deaa369e76
|
||||
PKG_SOURCE_URL:=http://www.han.dds.nl/software/mg
|
||||
PKG_MD5SUM:=f25a139da44c3a2f760ffec531bd996e
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -22,9 +22,10 @@ define Package/mg
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libncurses
|
||||
TITLE:=microscopic GNU Emacs-style editor
|
||||
URL:=http://www.xs4all.nl/~hanb/software/mg/
|
||||
URL:=http://www.han.dds.nl/software/mg/
|
||||
SUBMENU:=Editors
|
||||
endef
|
||||
|
||||
|
||||
define Package/mg/description
|
||||
This program is intended to be a small, fast, and portable
|
||||
editor for people who can't (or don't want to) run real
|
||||
@ -49,7 +50,7 @@ endef
|
||||
|
||||
define Package/mg/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,mg))
|
||||
|
@ -1,30 +0,0 @@
|
||||
--- mg-20070529.orig/sysdef.h 2006-08-01 16:34:08.000000000 -0700
|
||||
+++ mg-20070529/sysdef.h 2007-09-16 15:07:53.000000000 -0700
|
||||
@@ -20,9 +20,10 @@
|
||||
|
||||
/* necesarry to get asprintf & friends with glibc XXX doesn't work for some
|
||||
* mysterious reason! */
|
||||
-/* #ifdef __GLIBC__ */
|
||||
-/* # define _GNU_SOURCE */
|
||||
-/* #endif */
|
||||
+#ifdef __GLIBC__
|
||||
+# define _GNU_SOURCE
|
||||
+# define _USE_GNU
|
||||
+#endif
|
||||
#include <stdio.h>
|
||||
|
||||
#include <unistd.h>
|
||||
@@ -56,13 +57,6 @@
|
||||
extern size_t strlcat(char *, const char *, size_t);
|
||||
#endif
|
||||
|
||||
-/* Manpage says: #define _GNU_SOURCE, does that work? No! */
|
||||
-#ifdef __GLIBC__
|
||||
-extern int asprintf (char **, const char *, ...);
|
||||
-extern int vasprintf (char **, const char *, _G_va_list);
|
||||
-#endif
|
||||
-
|
||||
-
|
||||
/* not provided by glibc stdio.h */
|
||||
#ifdef HAVE_NOFGETLN
|
||||
extern char * fgetln(FILE *, size_t *);
|
Loading…
x
Reference in New Issue
Block a user