Add aprx (#3727)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11820 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
64b5f5f82d
commit
360d6786fc
44
net/aprx/Makefile
Normal file
44
net/aprx/Makefile
Normal file
@ -0,0 +1,44 @@
|
||||
#
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=aprx
|
||||
PKG_VERSION:=0.22
|
||||
PKG_RELEASE:=svn115
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE).tar.gz
|
||||
PKG_SOURCE_URL:=http://ham.zmailer.org/oh2mqk/aprx
|
||||
PKG_MD5SUM:=e376bb1c420858b5053584bae00d498d
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/aprx
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=APRS RX only I-gate
|
||||
URL:=http://ham.zmailer.org/oh2mqk/aprx/
|
||||
endef
|
||||
|
||||
define Package/aprx/description
|
||||
This daemon listens for traffic on the specified serial interfaces.
|
||||
It then forwards appropriate packets to APRS-IS servers.
|
||||
endef
|
||||
|
||||
define Package/aprx/install
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/aprx.conf $(1)/etc/
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/aprx $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/aprx-stat $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,aprx))
|
25
net/aprx/patches/100-Makefile_in.patch
Normal file
25
net/aprx/patches/100-Makefile_in.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -ruN aprx-0.22.svn115.orig/Makefile.in aprx-0.22.svn115/Makefile.in
|
||||
--- aprx-0.22.svn115.orig/Makefile.in 2008-07-06 17:28:27.000000000 -0400
|
||||
+++ aprx-0.22.svn115/Makefile.in 2008-07-06 17:29:42.000000000 -0400
|
||||
@@ -25,7 +25,7 @@
|
||||
CFLAGS= @CFLAGS@ $(DEFS)
|
||||
|
||||
# Linker and flags
|
||||
-LD= @LD@
|
||||
+LD= @CC@
|
||||
LDFLAGS= @LDFLAGS@
|
||||
|
||||
INSTALL= $(srcdir)/install-sh
|
||||
@@ -75,10 +75,10 @@
|
||||
all: $(PROGAPRX) $(PROGSTAT) man aprx.conf
|
||||
|
||||
$(PROGAPRX): $(OBJSAPRX) VERSION Makefile
|
||||
- $(LD) $(LDFLAGS) -o $@ $(OBJSAPRX) $(LIBS)
|
||||
+ $(CC) $(CFLAGS) -o $@ $(OBJSAPRX) $(LIBS)
|
||||
|
||||
$(PROGSTAT): $(OBJSSTAT) VERSION Makefile
|
||||
- $(LD) $(LDFLAGS) -o $@ $(OBJSSTAT) $(LIBS)
|
||||
+ $(CC) $(CFLAGS) -o $@ $(OBJSSTAT) $(LIBS)
|
||||
|
||||
.PHONY: man
|
||||
man: $(MAN)
|
Loading…
x
Reference in New Issue
Block a user