[packages] alsa-lib: update to 1.0.24.1

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26030 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
loswillios 2011-03-11 11:02:19 +00:00
parent 4522dc594d
commit 376a447d7d
2 changed files with 16 additions and 12 deletions

View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-lib
PKG_VERSION:=1.0.23
PKG_VERSION:=1.0.24.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
http://alsa.cybermirror.org/lib/
PKG_MD5SUM:=f48b50421d8a69d2d806d9c47e534f0d
PKG_MD5SUM:=7cc05f25e1d5b65da8fb3fdcd540f226
PKG_FIXUP:=libtool
PKG_INSTALL:=1

View File

@ -1,22 +1,26 @@
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -387,7 +387,7 @@ clean-libLTLIBRARIES:
Index: alsa-lib-1.0.24.1/src/Makefile.in
===================================================================
--- alsa-lib-1.0.24.1.orig/src/Makefile.in
+++ alsa-lib-1.0.24.1/src/Makefile.in
@@ -372,7 +372,7 @@ clean-libLTLIBRARIES:
rm -f "$${dir}/so_locations"; \
done
libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES)
- $(LINK) -rpath $(libdir) $(libasound_la_LDFLAGS) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
+ $(LINK) -rpath $(DESTDIR)$(libdir) $(libasound_la_LDFLAGS) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
- $(AM_V_CCLD)$(libasound_la_LINK) -rpath $(libdir) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
+ $(AM_V_CCLD)$(libasound_la_LINK) -rpath $(DESTDIR)$(libdir) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
mostlyclean-compile:
-rm -f *.$(OBJEXT)
--- a/src/pcm/scopes/Makefile.in
+++ b/src/pcm/scopes/Makefile.in
@@ -341,7 +341,7 @@ clean-pkglibLTLIBRARIES:
Index: alsa-lib-1.0.24.1/src/pcm/scopes/Makefile.in
===================================================================
--- alsa-lib-1.0.24.1.orig/src/pcm/scopes/Makefile.in
+++ alsa-lib-1.0.24.1/src/pcm/scopes/Makefile.in
@@ -300,7 +300,7 @@ clean-pkglibLTLIBRARIES:
rm -f "$${dir}/so_locations"; \
done
scope-level.la: $(scope_level_la_OBJECTS) $(scope_level_la_DEPENDENCIES)
- $(LINK) -rpath $(pkglibdir) $(scope_level_la_LDFLAGS) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)
+ $(LINK) -rpath $(DESTDIR)$(pkglibdir) $(scope_level_la_LDFLAGS) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)
- $(AM_V_CCLD)$(scope_level_la_LINK) -rpath $(pkglibdir) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)
+ $(AM_V_CCLD)$(scope_level_la_LINK) -rpath $(DESTDIR)$(pkglibdir) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)
mostlyclean-compile:
-rm -f *.$(OBJEXT)