liboil: moved to github

git-svn-id: svn://svn.openwrt.org/openwrt/packages@41750 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2014-07-19 12:09:24 +00:00
parent 3fede882d1
commit 38643c85e4
3 changed files with 0 additions and 106 deletions

View File

@ -1,65 +0,0 @@
#
# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=liboil
PKG_VERSION:=0.3.17
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
PKG_MD5SUM:=47dc734f82faeb2964d97771cfd2e701
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/liboil
SECTION:=libs
CATEGORY:=Libraries
TITLE:=simple functions optimized for various CPUs
URL:=http://liboil.freedesktop.org/wiki/
DEPENDS:=+librt
endef
define Package/liboil/description
Liboil is a library of simple functions that are optimized for various CPUs.
These functions are generally loops implementing simple algorithms, such as
converting an array of N integers to floating-point numbers or multiplying
and summing an array of N numbers. Such functions are candidates for significant
optimization using various techniques, especially by using extended instructions
provided by modern CPUs (Altivec, MMX, SSE, etc.).
endef
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
TARGET_CFLAGS += $(FPIC)
# XXX: VFP_CFLAGS is set to '-mfpu=vfp' on arm by configure, but that breaks
# final linking stages, so override it until we find why
MAKE_FLAGS += \
VFP_CFLAGS="" \
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/liboil-0.3/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/liboil-0.3.pc $(1)/usr/lib/pkgconfig/
endef
define Package/liboil/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,liboil))

View File

@ -1,22 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = liboil testsuite examples doc
+SUBDIRS = liboil
EXTRA_DIST = COPYING autogen.sh gtk-doc.make HACKING BUG-REPORTING
--- a/Makefile.in
+++ b/Makefile.in
@@ -278,7 +278,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = liboil testsuite examples doc
+SUBDIRS = liboil
EXTRA_DIST = COPYING autogen.sh gtk-doc.make HACKING BUG-REPORTING
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
pkgconfig_DATA = liboil-$(LIBOIL_MAJORMINOR).pc

View File

@ -1,19 +0,0 @@
--- a/liboil.pc.in
+++ b/liboil.pc.in
@@ -1,7 +1,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
libdir=@libdir@
-includedir=@includedir@/liboil-@LIBOIL_MAJORMINOR@
+includedir=@includedir@
toolsdir=${exec_prefix}/bin
@@ -9,6 +9,6 @@ Name: liboil-@LIBOIL_MAJORMINOR@
Description: Library of Optimized Inner Loops
Version: @VERSION@
Libs: -L${libdir} -loil-@LIBOIL_MAJORMINOR@ @LIBM@ @LIBRT@
-Cflags: -I${includedir}
+Cflags: -I${includedir}/liboil-@LIBOIL_MAJORMINOR@