tvheadend: fix compile on platforms with VFP
bundle.o was compiled with incompatible setting resulting in error at linking Solution: add CFLAGS to Makefile and fix it Error found on buildbot for target sunxi Error message: build.linux/tvheadend uses VFP register arguments, ./build.linux/bundle.o does not Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40699 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6eeaa1ef10
commit
3ad52c7b56
@ -72,7 +72,6 @@ define Package/tvheadend/install
|
||||
$(INSTALL_BIN) ./files/tvheadend.init $(1)/etc/init.d/tvheadend
|
||||
$(INSTALL_DIR) $(1)/lib/upgrade/keep.d
|
||||
$(INSTALL_DATA) ./files/tvheadend.upgrade $(1)/lib/upgrade/keep.d/tvheadend
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/build.linux/tvheadend $(1)/usr/bin/
|
||||
endef
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -282,7 +282,7 @@ include support/${OSENV}.mk
|
||||
# Bundle files
|
||||
$(BUILDDIR)/bundle.o: $(BUILDDIR)/bundle.c
|
||||
@mkdir -p $(dir $@)
|
||||
- $(CC) -I${CURDIR}/src -c -o $@ $<
|
||||
+ $(CC) $(CFLAGS) -I${CURDIR}/src -c -o $@ $<
|
||||
|
||||
$(BUILDDIR)/bundle.c:
|
||||
@mkdir -p $(dir $@)
|
Loading…
x
Reference in New Issue
Block a user