[packages] libpam update to 1.1.8

remove broken flag and refresh patches

Signed-off-by: Peter Wagner <tripolar@gmx.at>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@38489 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
tripolar 2013-10-21 22:25:49 +00:00
parent 2ac332d86b
commit 3b08077502
7 changed files with 22 additions and 38 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libpam
PKG_VERSION:=1.1.4
PKG_VERSION:=1.1.8
PKG_RELEASE:=1
PKG_SOURCE:=Linux-PAM-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://pkgs.fedoraproject.org/repo/pkgs/pam/Linux-PAM-1.1.4.tar.bz2/e9af5fb27bb22edb55d077e2888b3ebc/
PKG_MD5SUM:=e9af5fb27bb22edb55d077e2888b3ebc
PKG_SOURCE_URL:=http://www.linux-pam.org/library/
PKG_MD5SUM:=35b6091af95981b1b2cd60d813b5e4ee
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
@ -24,7 +24,6 @@ include $(INCLUDE_DIR)/package.mk
define Package/libpam
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=@BROKEN
TITLE:=free implementation of the following DCE-RFC from Sunsoft.
URL:=http://www.kernel.org/pub/linux/libs/pam
endef

View File

@ -5,16 +5,16 @@ Upstream-Status: Pending
Signed-off-by: Kang Kai <kai.kang@windriver.com>
--- a/xtests/Makefile.am
+++ b/xtests/Makefile.am
@@ -7,7 +7,7 @@
AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
-L$(top_builddir)/libpam_misc -lpam_misc
@@ -7,7 +7,7 @@ AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_src
LDADD = $(top_builddir)/libpam/libpam.la \
$(top_builddir)/libpam_misc/libpam_misc.la
-CLEANFILES = *~ $(XTESTS)
+CLEANFILES = *~
EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
@@ -51,3 +51,18 @@
@@ -51,3 +51,18 @@ EXTRA_PROGRAMS = $(XTESTS)
xtests: $(XTESTS) run-xtests.sh
"$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}

View File

@ -4,7 +4,7 @@ then we inform about it and not use it.
-Khem
--- a/modules/pam_group/pam_group.c
+++ b/modules/pam_group/pam_group.c
@@ -659,7 +659,11 @@ static int check_account(pam_handle_t *p
@@ -656,7 +656,11 @@ static int check_account(pam_handle_t *p
}
/* If buffer starts with @, we are using netgroups */
if (buffer[0] == '@')
@ -66,7 +66,7 @@ then we inform about it and not use it.
return PAM_AUTH_ERR;
}
@@ -361,14 +370,14 @@ evaluate(pam_handle_t *pamh, int debug,
@@ -387,14 +396,14 @@ evaluate(pam_handle_t *pamh, int debug,
const void *rhost;
if (pam_get_item(pamh, PAM_RHOST, &rhost) != PAM_SUCCESS)
rhost = NULL;

View File

@ -11,7 +11,7 @@
#ifdef HAVE_LIBAUDIT
--- a/modules/pam_unix/pam_unix_passwd.c
+++ b/modules/pam_unix/pam_unix_passwd.c
@@ -74,18 +74,18 @@
@@ -79,18 +79,18 @@
#include "passverify.h"
#include "bigcrypt.h"
@ -44,7 +44,7 @@
#include <rpcsvc/ypclnt.h>
#endif
@@ -285,7 +285,7 @@ int _unix_getpwnam(pam_handle_t *pamh, c
@@ -402,7 +402,7 @@ int _unix_getpwnam(pam_handle_t *pamh, c
}
}
@ -55,8 +55,8 @@
int len = 0, i;
--- a/modules/pam_unix/yppasswd_xdr.c
+++ b/modules/pam_unix/yppasswd_xdr.c
@@ -13,6 +13,10 @@
#include "config.h"
@@ -15,6 +15,10 @@
#ifdef HAVE_RPC_RPC_H
#include <rpc/rpc.h>
+#ifdef USE_NIS

View File

@ -1,36 +1,22 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,9 +5,9 @@
@@ -4,7 +4,7 @@
AUTOMAKE_OPTIONS = 1.9 gnu dist-bzip2 check-news
if STATIC_MODULES
-SUBDIRS = modules libpam libpamc libpam_misc tests po conf doc examples xtests
+SUBDIRS = modules libpam libpamc libpam_misc tests po conf examples xtests
else
-SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc examples xtests
+SUBDIRS = libpam tests libpamc libpam_misc modules po conf examples xtests
endif
CLEANFILES = *~
--- a/Makefile.in
+++ b/Makefile.in
@@ -74,7 +74,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
distclean-recursive maintainer-clean-recursive
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc \
+DIST_SUBDIRS = libpam tests libpamc libpam_misc modules po conf \
examples xtests
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
@@ -253,8 +253,8 @@ top_build_prefix = @top_build_prefix@
@@ -288,7 +288,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = 1.9 gnu dist-bzip2 check-news
-@STATIC_MODULES_FALSE@SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc examples xtests
-@STATIC_MODULES_TRUE@SUBDIRS = modules libpam libpamc libpam_misc tests po conf doc examples xtests
+@STATIC_MODULES_FALSE@SUBDIRS = libpam tests libpamc libpam_misc modules po conf examples xtests
+@STATIC_MODULES_TRUE@SUBDIRS = modules libpam libpamc libpam_misc tests po conf examples xtests
-SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc examples xtests
+SUBDIRS = libpam tests libpamc libpam_misc modules po conf examples xtests
CLEANFILES = *~
M4_FILES = m4/gettext.m4 m4/iconv.m4 m4/intlmacosx.m4 \
m4/japhar_grep_cflags.m4 m4/jh_path_xml_catalog.m4 \
EXTRA_DIST = pgp.keys.asc CHANGELOG ChangeLog-CVS Copyright Make.xml.rules
ACLOCAL_AMFLAGS = -I m4

View File

@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
@@ -26,12 +26,7 @@ dnl If we use /usr as prefix, use /etc f
@@ -28,12 +28,7 @@ dnl If we use /usr as prefix, use /etc f
fi
if test ${libdir} = '${exec_prefix}/lib'
then

View File

@ -1,6 +1,5 @@
--- a/modules/pam_unix/yppasswd_xdr.c
+++ b/modules/pam_unix/yppasswd_xdr.c
2011-10-01 13:46:21.599443197 +0300
@@ -21,6 +21,268 @@
#endif
#include "yppasswd.h"