Add yafc, closes #549
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4127 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fba1a49c26
commit
3d1db44950
50
net/yafc/Makefile
Normal file
50
net/yafc/Makefile
Normal file
@ -0,0 +1,50 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: Makefile 4112 2006-07-02 20:33:21Z nico $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=yafc
|
||||
PKG_VERSION:=1.1.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=832d074183a36ee15b47553ed5962fce
|
||||
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/yafc
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpcap
|
||||
TITLE:=Yafc is yet another ftp client.
|
||||
DESCRIPTION:=console-based FTP client
|
||||
URL:=http://yacf.sourceforge.net
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC=$(TARGET_CC)
|
||||
endef
|
||||
|
||||
define Package/yafc/install
|
||||
install -m0755 -d $(1)/usr/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,yafc))
|
20
net/yafc/patches/01-cross_compile.patch
Normal file
20
net/yafc/patches/01-cross_compile.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- yafc-1.1.1/configure 2005-10-06 08:26:31.000000000 +0200
|
||||
+++ yafc-1.1.1.new/configure 2006-07-11 13:40:21.000000000 +0200
|
||||
@@ -24640,7 +24640,7 @@
|
||||
|
||||
fi
|
||||
|
||||
-
|
||||
+cross_compiling=no
|
||||
echo "$as_me:$LINENO: checking for presence of POSIX-style sigsetjmp/siglongjmp" >&5
|
||||
echo $ECHO_N "checking for presence of POSIX-style sigsetjmp/siglongjmp... $ECHO_C" >&6
|
||||
if test "${bash_cv_func_sigsetjmp+set}" = set; then
|
||||
@@ -24659,7 +24659,7 @@
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
-
|
||||
+cross_compiling=yes
|
||||
#ifdef HAVE_UNISTD_H
|
||||
#include <unistd.h>
|
||||
#endif
|
Loading…
x
Reference in New Issue
Block a user