libexif: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41747 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e251254651
commit
3d6c9826db
@ -1,62 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libexif
|
||||
PKG_VERSION:=0.6.21
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/libexif
|
||||
PKG_MD5SUM:=27339b89850f28c8f1c237f233e05b27
|
||||
|
||||
PKG_LICENSE:=LGPLv2.1
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libexif
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=library for jpeg files with exif tags
|
||||
URL:=http://libexif.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/libexif/description
|
||||
libexif is a library for parsing, editing, and saving EXIF data. It is
|
||||
intended to replace lots of redundant implementations in command-line
|
||||
utilities and programs with GUIs.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libexif $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexif*.{a,so*} $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libexif.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/libexif/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexif*.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libexif))
|
@ -1,11 +0,0 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -289,7 +289,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-SUBDIRS = m4m po libexif test doc binary contrib
|
||||
+SUBDIRS = m4m po libexif test binary contrib
|
||||
EXTRA_DIST = @PACKAGE_TARNAME@.spec README-Win32.txt libexif.pc.in \
|
||||
libexif-uninstalled.pc.in
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
Loading…
x
Reference in New Issue
Block a user