libs/libpam: update libpam to version 1.1.2, refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22961 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
51e0d8b98d
commit
3fd525b482
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libpam
|
||||
PKG_VERSION:=0.99.6.3
|
||||
PKG_VERSION:=1.1.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=Linux-PAM-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=Linux-PAM-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/libs/pam/pre/library
|
||||
PKG_MD5SUM:=0f17f7105faa82a51dfbeb6b08a1ca29
|
||||
PKG_MD5SUM:=81173dfeffe69d726081f9c5667cd3e7
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
@ -37,6 +37,7 @@ endef
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); aclocal -I m4 && autoconf && automake)
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
|
@ -1,88 +1,67 @@
|
||||
diff -urN Linux-PAM-0.99.6.3/modules/pam_access/pam_access.c Linux-PAM-0.99.6.3.new/modules/pam_access/pam_access.c
|
||||
--- Linux-PAM-0.99.6.3/modules/pam_access/pam_access.c 2006-08-31 12:20:37.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/modules/pam_access/pam_access.c 2007-01-10 22:36:57.000000000 +0100
|
||||
@@ -41,7 +41,9 @@
|
||||
#include <errno.h>
|
||||
#include <ctype.h>
|
||||
#include <sys/utsname.h>
|
||||
+#ifdef USE_NIS
|
||||
#include <rpcsvc/ypclnt.h>
|
||||
+#endif
|
||||
--- a/modules/pam_access/pam_access.c
|
||||
+++ b/modules/pam_access/pam_access.c
|
||||
@@ -44,7 +44,7 @@
|
||||
#include <arpa/inet.h>
|
||||
#include <netdb.h>
|
||||
#include <sys/socket.h>
|
||||
diff -urN Linux-PAM-0.99.6.3/modules/pam_unix/pam_unix_passwd.c Linux-PAM-0.99.6.3.new/modules/pam_unix/pam_unix_passwd.c
|
||||
--- Linux-PAM-0.99.6.3/modules/pam_unix/pam_unix_passwd.c 2006-06-27 10:38:14.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/modules/pam_unix/pam_unix_passwd.c 2007-01-10 23:06:20.000000000 +0100
|
||||
@@ -54,8 +54,10 @@
|
||||
-#ifdef HAVE_RPCSVC_YPCLNT_H
|
||||
+#ifdef HAVE_RPCSVC_YPCLNT_H && USE_NIS
|
||||
#include <rpcsvc/ypclnt.h>
|
||||
#endif
|
||||
#ifdef HAVE_LIBAUDIT
|
||||
--- a/modules/pam_unix/pam_unix_passwd.c
|
||||
+++ b/modules/pam_unix/pam_unix_passwd.c
|
||||
@@ -55,10 +55,10 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/stat.h>
|
||||
#include <rpc/rpc.h>
|
||||
+#ifdef USE_NIS
|
||||
-#ifdef HAVE_RPCSVC_YP_PROT_H
|
||||
+#ifdef HAVE_RPCSVC_YP_PROT_H && USE_NIS
|
||||
#include <rpcsvc/yp_prot.h>
|
||||
#endif
|
||||
-#ifdef HAVE_RPCSVC_YPCLNT_H
|
||||
+#ifdef HAVE_RPCSVC_YPCLNT_H && USE_NIS
|
||||
#include <rpcsvc/ypclnt.h>
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
#include <signal.h>
|
||||
#include <errno.h>
|
||||
@@ -187,6 +189,7 @@
|
||||
@@ -104,7 +104,7 @@ extern int getrpcport(const char *host,
|
||||
|
||||
static char *getNISserver(pam_handle_t *pamh)
|
||||
static char *getNISserver(pam_handle_t *pamh, unsigned int ctrl)
|
||||
{
|
||||
+#ifdef USE_NIS
|
||||
-#if (defined(HAVE_YP_GET_DEFAULT_DOMAIN) || defined(HAVE_GETDOMAINNAME)) && defined(HAVE_YP_MASTER)
|
||||
+#if (defined(HAVE_YP_GET_DEFAULT_DOMAIN) || defined(HAVE_GETDOMAINNAME)) && defined(HAVE_YP_MASTER) && defined(USE_NIS)
|
||||
char *master;
|
||||
char *domainname;
|
||||
int port, err;
|
||||
@@ -213,6 +216,9 @@
|
||||
return NULL;
|
||||
}
|
||||
return master;
|
||||
+#else
|
||||
+ return NULL;
|
||||
+#endif
|
||||
}
|
||||
|
||||
#ifdef WITH_SELINUX
|
||||
diff -urN Linux-PAM-0.99.6.3/modules/pam_unix/support.c Linux-PAM-0.99.6.3.new/modules/pam_unix/support.c
|
||||
--- Linux-PAM-0.99.6.3/modules/pam_unix/support.c 2006-06-27 10:38:14.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/modules/pam_unix/support.c 2007-01-10 23:10:16.000000000 +0100
|
||||
@@ -19,7 +19,9 @@
|
||||
--- a/modules/pam_unix/support.c
|
||||
+++ b/modules/pam_unix/support.c
|
||||
@@ -19,7 +19,7 @@
|
||||
#include <ctype.h>
|
||||
#include <syslog.h>
|
||||
#include <sys/resource.h>
|
||||
+#ifdef USE_NIS
|
||||
-#ifdef HAVE_RPCSVC_YPCLNT_H
|
||||
+#ifdef HAVE_RPCSVC_YPCLNT_H && USE_NIS
|
||||
#include <rpcsvc/ypclnt.h>
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
#include <security/_pam_macros.h>
|
||||
#include <security/pam_modules.h>
|
||||
@@ -253,7 +255,7 @@
|
||||
fclose(passwd);
|
||||
@@ -285,7 +285,7 @@ int _unix_getpwnam(pam_handle_t *pamh, c
|
||||
}
|
||||
}
|
||||
-
|
||||
+#ifdef USE_NIS
|
||||
|
||||
-#if defined(HAVE_YP_GET_DEFAULT_DOMAIN) && defined (HAVE_YP_BIND) && defined (HAVE_YP_MATCH) && defined (HAVE_YP_UNBIND)
|
||||
+#if defined(HAVE_YP_GET_DEFAULT_DOMAIN) && defined (HAVE_YP_BIND) && defined (HAVE_YP_MATCH) && defined (HAVE_YP_UNBIND) && (USE_NIS)
|
||||
if (!matched && nis) {
|
||||
char *userinfo = NULL, *domain = NULL;
|
||||
int len = 0, i;
|
||||
@@ -272,6 +274,7 @@
|
||||
}
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
|
||||
if (matched && (ret != NULL)) {
|
||||
*ret = NULL;
|
||||
diff -urN Linux-PAM-0.99.6.3/modules/pam_unix/yppasswd_xdr.c Linux-PAM-0.99.6.3.new/modules/pam_unix/yppasswd_xdr.c
|
||||
--- Linux-PAM-0.99.6.3/modules/pam_unix/yppasswd_xdr.c 2005-07-20 11:46:19.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/modules/pam_unix/yppasswd_xdr.c 2007-01-10 23:12:04.000000000 +0100
|
||||
@@ -13,8 +13,10 @@
|
||||
--- a/modules/pam_unix/yppasswd_xdr.c
|
||||
+++ b/modules/pam_unix/yppasswd_xdr.c
|
||||
@@ -13,6 +13,10 @@
|
||||
#include "config.h"
|
||||
|
||||
#include <rpc/rpc.h>
|
||||
+#ifdef USE_NIS
|
||||
#include <rpcsvc/yp_prot.h>
|
||||
#include <rpcsvc/ypclnt.h>
|
||||
+#include <rpcsvc/yp_prot.h>
|
||||
+#include <rpcsvc/ypclnt.h>
|
||||
+#endif
|
||||
#include "yppasswd.h"
|
||||
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -urN Linux-PAM-0.99.6.3/conf/pam_conv1/pam_conv_l.c Linux-PAM-0.99.6.3.new/conf/pam_conv1/pam_conv_l.c
|
||||
--- Linux-PAM-0.99.6.3/conf/pam_conv1/pam_conv_l.c 2006-09-06 11:29:19.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/conf/pam_conv1/pam_conv_l.c 2007-01-10 23:19:05.000000000 +0100
|
||||
@@ -494,7 +494,9 @@
|
||||
--- a/conf/pam_conv1/pam_conv_l.c
|
||||
+++ b/conf/pam_conv1/pam_conv_l.c
|
||||
@@ -534,7 +534,9 @@ void yyset_lineno (int line_number );
|
||||
#ifdef __cplusplus
|
||||
extern "C" int yywrap (void );
|
||||
#else
|
||||
@ -12,10 +11,9 @@ diff -urN Linux-PAM-0.99.6.3/conf/pam_conv1/pam_conv_l.c Linux-PAM-0.99.6.3.new/
|
||||
#endif
|
||||
#endif
|
||||
|
||||
diff -urN Linux-PAM-0.99.6.3/doc/specs/parse_l.c Linux-PAM-0.99.6.3.new/doc/specs/parse_l.c
|
||||
--- Linux-PAM-0.99.6.3/doc/specs/parse_l.c 2006-09-06 11:29:19.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/doc/specs/parse_l.c 2007-01-10 23:21:55.000000000 +0100
|
||||
@@ -480,7 +480,9 @@
|
||||
--- a/doc/specs/parse_l.c
|
||||
+++ b/doc/specs/parse_l.c
|
||||
@@ -520,7 +520,9 @@ void yyset_lineno (int line_number );
|
||||
#ifdef __cplusplus
|
||||
extern "C" int yywrap (void );
|
||||
#else
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Linux-PAM-0.99.6.3/Makefile.am 2006-08-05 11:06:20.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/Makefile.am 2007-01-10 23:24:06.000000000 +0100
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -5,9 +5,9 @@
|
||||
AUTOMAKE_OPTIONS = 1.9 gnu dist-bzip2 check-news
|
||||
|
||||
@ -12,10 +12,10 @@
|
||||
endif
|
||||
|
||||
CLEANFILES = *~
|
||||
--- Linux-PAM-0.99.6.3/Makefile.in 2006-09-06 13:31:39.000000000 +0200
|
||||
+++ Linux-PAM-0.99.6.3.new/Makefile.in 2007-01-10 23:24:20.000000000 +0100
|
||||
@@ -72,7 +72,7 @@
|
||||
uninstall-recursive
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -74,7 +74,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
|
||||
distclean-recursive maintainer-clean-recursive
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
-DIST_SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc \
|
||||
@ -23,14 +23,14 @@
|
||||
examples xtests
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
distdir = $(PACKAGE)-$(VERSION)
|
||||
@@ -257,8 +257,8 @@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@@ -249,8 +249,8 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = 1.9 gnu dist-bzip2 check-news
|
||||
-@STATIC_MODULES_FALSE@SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc examples xtests
|
||||
-@STATIC_MODULES_TRUE@SUBDIRS = modules libpam libpamc libpam_misc tests po conf doc examples xtests
|
||||
+@STATIC_MODULES_FALSE@SUBDIRS = libpam tests libpamc libpam_misc modules po conf examples xtests
|
||||
+@STATIC_MODULES_TRUE@SUBDIRS = modules libpam libpamc libpam_misc tests po conf examples xtests
|
||||
CLEANFILES = *~
|
||||
M4_FILES = $(shell ls $(srcdir)/m4/*.m4)
|
||||
EXTRA_DIST = config.rpath mkinstalldirs pgp.keys.asc CHANGELOG \
|
||||
M4_FILES = m4/gettext.m4 m4/iconv.m4 m4/intlmacosx.m4 \
|
||||
m4/japhar_grep_cflags.m4 m4/jh_path_xml_catalog.m4 \
|
||||
|
16
libs/libpam/patches/004-fix_lib64.patch
Normal file
16
libs/libpam/patches/004-fix_lib64.patch
Normal file
@ -0,0 +1,16 @@
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -26,12 +26,7 @@ dnl If we use /usr as prefix, use /etc f
|
||||
fi
|
||||
if test ${libdir} = '${exec_prefix}/lib'
|
||||
then
|
||||
- case "`uname -m`" in
|
||||
- x86_64|ppc64|s390x|sparc64)
|
||||
- libdir="/lib64" ;;
|
||||
- *)
|
||||
- libdir="/lib" ;;
|
||||
- esac
|
||||
+ libdir="/lib"
|
||||
fi
|
||||
if test ${sbindir} = '${exec_prefix}/sbin'
|
||||
then
|
Loading…
x
Reference in New Issue
Block a user