[packages] coova-chilli: support mac password function in config script again (#6630)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19508 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-02-03 22:07:50 +00:00
parent 0f7020b9dd
commit 40039db602
2 changed files with 14 additions and 4 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007-2009 OpenWrt.org
# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=coova-chilli
PKG_VERSION:=1.2.1
PKG_RELEASE:=1
PKG_VERSION:=1.0.14
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ap.coova.org/chilli/
PKG_MD5SUM:=f4c0cdb903b6a830cd7c8a54db2334e8
PKG_MD5SUM:=88774ec55f9943d174ea7dd26e85fd8a
include $(INCLUDE_DIR)/package.mk

View File

@ -0,0 +1,10 @@
--- a/conf/functions.in
+++ b/conf/functions.in
@@ -153,6 +153,7 @@
if [ "x$HS_RADCONF" != "xon" -a "x$HS_RADCONF" != "xurl" ]; then
[ "$HS_PAP_OK" = "on" ] && addconfig2 "papalwaysok"
[ "$HS_MACAUTH" = "on" ] && addconfig2 "macauth"
+ [ "$HS_MACAUTH" = "on" -a -n "$HS_MACPASSWD" ] && addconfig2 "macpasswd $HS_MACPASSWD"
[ "$HS_MACREAUTH" = "on" ] && addconfig2 "macreauth"
[ "$HS_MACAUTHDENY" = "on" ] && addconfig2 "macauthdeny"
[ "$HS_WPAGUESTS" = "on" ] && addconfig2 "wpaguests"