[packages] bump radvd to 1.9.1
Radvd has been updated to 1.9.1 in June. There are some changes related to IPv6 functionality, but additionally the change concerns scrapping the built-in daemonization code and starting to use libdaemon for that. This patch updates radvd to 1.9.1 and adds the dependency for libdaemon. Signed-off-by: hannu.nyman@iki.fi git-svn-id: svn://svn.openwrt.org/openwrt/packages@32827 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e959d57f61
commit
40590b62fd
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=radvd
|
||||
PKG_VERSION:=1.8.5
|
||||
PKG_VERSION:=1.9.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
|
||||
http://download.sourcemage.org/mirror
|
||||
PKG_MD5SUM:=bdeca76d976282c306f3c454d6ff1f67
|
||||
PKG_MD5SUM:=e807ad7e9a76d46b6133df391385cd31
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
@ -25,7 +25,7 @@ define Package/radvd/Default
|
||||
CATEGORY:=IPv6
|
||||
TITLE:=IPv6 Routing Advertisement
|
||||
URL:=http://v6web.litech.org/radvd/
|
||||
DEPENDS:=+kmod-ipv6
|
||||
DEPENDS:=+kmod-ipv6 +libdaemon
|
||||
endef
|
||||
|
||||
define Package/radvd
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/netlink.c
|
||||
+++ b/netlink.c
|
||||
@@ -63,7 +63,7 @@ void process_netlink_msg(int sock)
|
||||
@@ -67,7 +67,7 @@ void process_netlink_msg(int sock)
|
||||
else {
|
||||
dlog(LOG_DEBUG, 3, "%s, ifindex %d, flags is *NOT* running", ifname, ifinfo->ifi_index);
|
||||
}
|
||||
@ -11,7 +11,7 @@
|
||||
|
||||
--- a/radvd.c
|
||||
+++ b/radvd.c
|
||||
@@ -456,7 +456,7 @@ void main_loop(void)
|
||||
@@ -443,7 +443,7 @@ void main_loop(void)
|
||||
if (sighup_received)
|
||||
{
|
||||
dlog(LOG_INFO, 3, "sig hup received.\n");
|
||||
@ -20,7 +20,7 @@
|
||||
sighup_received = 0;
|
||||
}
|
||||
|
||||
@@ -565,11 +565,11 @@ stop_adverts(void)
|
||||
@@ -552,11 +552,11 @@ stop_adverts(void)
|
||||
}
|
||||
}
|
||||
|
||||
@ -34,7 +34,7 @@
|
||||
|
||||
iface=IfaceList;
|
||||
while(iface)
|
||||
@@ -639,7 +639,7 @@ void reload_config(void)
|
||||
@@ -626,7 +626,7 @@ void reload_config(void)
|
||||
config_interface();
|
||||
kickoff_adverts();
|
||||
|
||||
@ -56,7 +56,7 @@
|
||||
/* timer.c */
|
||||
--- a/send.c
|
||||
+++ b/send.c
|
||||
@@ -153,7 +153,7 @@ send_ra(struct Interface *iface, struct
|
||||
@@ -154,7 +154,7 @@ send_ra(struct Interface *iface, struct
|
||||
* reload_config() will kick off new timers anyway. This avoids
|
||||
* timer list corruption.
|
||||
*/
|
||||
|
Loading…
x
Reference in New Issue
Block a user