[package] update shell-fm to 0.7 (#5820)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17638 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e4fa0d4329
commit
40e2d7b8e2
@ -8,14 +8,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shell-fm
|
||||
PKG_VERSION:=0.6
|
||||
PKG_VERSION:=0.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://github.com/jkramer/shell-fm.git
|
||||
PKG_SOURCE_VERSION:=df8bd30d280502c9ce62669e001d7de94d0dd5fe
|
||||
PKG_SOURCE_VERSION:=c274aa51b52185b289ac22f0cb95420a1c19868b
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -50,9 +50,9 @@ endef
|
||||
|
||||
define Package/shell-fm/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/shell-fm $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_DATA) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
|
||||
$(INSTALL_CONF) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/shell-fm.init $(1)/etc/init.d/shell-fm
|
||||
endef
|
||||
|
@ -7,4 +7,3 @@ a-color = 0;32 # dark green track artist names
|
||||
s-color = 1;37 # white station names
|
||||
bind = 0.0.0.0
|
||||
extern = madplay -q -
|
||||
extern-restart = 1
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- a/source/main.c
|
||||
+++ b/source/main.c
|
||||
@@ -44,6 +44,10 @@
|
||||
# endif
|
||||
#endif
|
||||
|
||||
+#ifndef WIFCONTINUED
|
||||
+#define WIFCONTINUED(wstat) (0)
|
||||
+#endif
|
||||
+
|
||||
unsigned flags = RTP;
|
||||
time_t changeTime = 0, pausetime = 0;
|
||||
char * nextstation = NULL;
|
Loading…
x
Reference in New Issue
Block a user