bridge-utils: fix a struct in6_addr reference
Bridge-utils uses kernel headers. Linux 3.8 has a header, include/uapi/linux/if_bridge.h that uses a struct in6_addr but doesn't define it. The trivial seeming fix of including the header that does define it causes more problems. The problem was discussed on mailing lists in January 2013. The final suggestion I found was here: http://www.redhat.com/archives/libvir-list/2013-January/msg01253.html This is intended to implement that suggestion. Signed-off-by: Russell Senior <russell@personaltelco.net> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@35999 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
27881759f5
commit
41cbbda301
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
# Copyright (C) 2006-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=bridge-utils
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_SOURCE_URL:=@SF/bridge
|
||||
PKG_VERSION:=1.5
|
||||
PKG_MD5SUM:=ec7b381160b340648dede58c31bb2238
|
||||
|
10
net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch
Normal file
10
net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/libbridge/libbridge.h
|
||||
+++ b/libbridge/libbridge.h
|
||||
@@ -20,6 +20,7 @@
|
||||
#define _LIBBRIDGE_H
|
||||
|
||||
#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <linux/if.h>
|
||||
#include <linux/if_bridge.h>
|
||||
|
Loading…
x
Reference in New Issue
Block a user