[packages] transmission: update to 2.00b1, add new options

git-svn-id: svn://svn.openwrt.org/openwrt/packages@21569 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
obsy 2010-05-25 19:53:25 +00:00
parent ae8cce06d6
commit 45a2de412c
5 changed files with 86 additions and 53 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=1.93
PKG_VERSION:=2.00b1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
PKG_MD5SUM:=f68358d03e46bec5704bbaa894990152
PKG_MD5SUM:=43540a46a4eeac88e53a67573feca21a
PKG_FIXUP:=libtool
PKG_INSTALL:=1

View File

@ -1,8 +1,62 @@
config transmission
option enable 0
option config_dir /tmp/transmission
option download_dir /tmp/transmission/done
option speed_limit_up 20
option speed_limit_up_enabled true
option config_dir '/tmp/transmission'
option alt_speed_down 50
option alt_speed_enabled false
option alt_speed_time_begin 540
option alt_speed_time_day 127
option alt_speed_time_enabled false
option alt_speed_time_end 1020
option alt_speed_up 50
option bind_address_ipv4 '0.0.0.0'
option bind_address_ipv6 '::'
option blocklist_enabled false
option dht_enabled true
option download_dir '/tmp/transmission/done'
option encryption 1
option incomplete_dir '/tmp/transmission/incomplete'
option incomplete_dir_enabled false
option lazy_bitfield_enabled true
option lpd_enabled false
option message_level 2
option open_file_limit 32
option peer_limit_global 240
option peer_limit_per_torrent 60
option peer_port 51413
option peer_port_random_high 65535
option peer_port_random_low 49152
option peer_port_random_on_start false
option peer_socket_tos 0
option pex_enabled true
option port_forwarding_enabled true
option preallocation 1
option proxy ""
option proxy_auth_enabled false
option proxy_auth_password ''
option proxy_auth_username ''
option proxy_enabled false
option proxy_port 80
option proxy_type 0
option ratio_limit 2.0000
option ratio_limit_enabled false
option rename_partial_files true
option rpc_authentication_required false
option rpc_bind_address '0.0.0.0'
option rpc_enabled true
option rpc_password ''
option rpc_port 9091
option rpc_username ''
option rpc_whitelist '127.0.0.1,192.168.1.*'
option rpc_whitelist_enabled true
option rpc_whitelist_enabled true
option script_torrent_done_enabled false
option script_torrent_done_filename ''
option speed_limit_down 100
option speed_limit_down_enabled false
option speed_limit_up 20
option speed_limit_up_enabled false
option start_added_torrents false
option trash_original_torrent_files false
option umask 18
option upload_slots_per_torrent 14
option watch_dir_enabled false
option watch_dir ''

View File

@ -41,7 +41,7 @@ start_service() {
# disabled?
config_get_bool enable "$s" enable 0
[ "$enable" == 0 ] && return 0
config_get config_dir "$s" config_dir ''
config_get config_dir "$s" config_dir '/tmp/transmission'
mkdir -p "$config_dir"
echo "{" > $config_dir/settings.json
@ -50,20 +50,21 @@ start_service() {
alt_speed_down alt_speed_enabled alt_speed_time_begin alt_speed_time_day \
alt_speed_time_enabled alt_speed_time_end alt_speed_up \
blocklist_enabled dht_enabled encryption \
incomplete_dir_enabled lazy_bitfield_enabled message_level \
incomplete_dir_enabled lazy_bitfield_enabled lpd_enabled message_level \
open_file_limit peer_limit_global peer_limit_per_torrent peer_port \
peer_port_random_high peer_port_random_low peer_port_random_on_start \
peer_socket_tos pex_enabled port_forwarding_enabled preallocation \
proxy_auth_enabled proxy_enabled proxy_port proxy_type ratio_limit \
ratio_limit_enabled rename_partial_files rpc_authentication_required \
rpc_enabled rpc_port rpc_whitelist_enabled speed_limit_down \
speed_limit_down_enabled speed_limit_up speed_limit_up_enabled umask \
upload_slots_per_torrent watch_dir_enabled
rpc_enabled rpc_port rpc_whitelist_enabled script_torrent_done_enabled \
speed_limit_down speed_limit_down_enabled speed_limit_up \
speed_limit_up_enabled start_added_torrents trash_original_torrent_files \
umask upload_slots_per_torrent watch_dir_enabled
append_params_quotes "$s" \
bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir proxy \
proxy_auth_password proxy_auth_username \
rpc_bind_address rpc_password rpc_username rpc_whitelist watch_dir
proxy_auth_password proxy_auth_username rpc_bind_address rpc_password \
rpc_username rpc_whitelist script_torrent_done_filename watch_dir
echo "\""invalid-key"\": false" >> $config_dir/settings.json
echo "}" >> $config_dir/settings.json

View File

@ -0,0 +1,17 @@
--- transmission/libtransmission/tr-lpd.c.orig 2010-05-23 03:49:23.000000000 +0200
+++ transmission/libtransmission/tr-lpd.c 2010-05-25 19:44:03.000000000 +0200
@@ -439,12 +439,13 @@
char hashString[lengthof( t->info.hashString )];
char query[lpd_maxDatagramLength + 1] = { };
+ size_t i;
if( t == NULL )
return FALSE;
/* make sure the hash string is normalized, just in case */
- for( size_t i = 0; i < sizeof hashString; i++ )
+ for( i = 0; i < sizeof hashString; i++ )
hashString[i] = toupper( t->info.hashString[i] );
/* prepare a zero-terminated announce message */

View File

@ -1,39 +0,0 @@
--- a/configure
+++ b/configure
@@ -1058,7 +1058,7 @@ LIBGCONF_CFLAGS
LIBGCONF_LIBS
DBUS_GLIB_CFLAGS
DBUS_GLIB_LIBS'
-ac_subdirs_all='third-party/libevent'
+#ac_subdirs_all='third-party/libevent'
# Initialize some variables set by options.
ac_init_help=
@@ -19881,7 +19881,7 @@ fi
-subdirs="$subdirs third-party/libevent"
+#subdirs="$subdirs third-party/libevent"
libevent_source=bundled
{ $as_echo "$as_me:$LINENO: checking for evutil_vsnprintf in -levent" >&5
--- a/third-party/Makefile.am
+++ b/third-party/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = libnatpmp miniupnp libevent dht
+SUBDIRS = libnatpmp miniupnp dht
EXTRA_DIST = \
macosx-libevent-config.h \
--- a/third-party/Makefile.in
+++ b/third-party/Makefile.in
@@ -278,7 +278,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
transmissionlocaledir = @transmissionlocaledir@
-SUBDIRS = libnatpmp miniupnp libevent dht
+SUBDIRS = libnatpmp miniupnp dht
EXTRA_DIST = \
macosx-libevent-config.h \
macosx-libevent-event-config.h