update xsupplicant to latest upstream version and fix a compile error
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4926 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
af83711bfe
commit
460d9017f7
@ -9,9 +9,9 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xsupplicant
|
||||
PKG_VERSION:=1.2.3
|
||||
PKG_VERSION:=1.2.7
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=c9b17b2e1879bac85c583980338fed85
|
||||
PKG_MD5SUM:=f66c49cd6e4f331d05bf83513ed91990
|
||||
|
||||
PKG_SOURCE_URL:=@SF/open1x
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
@ -48,6 +48,7 @@ define Build/Configure
|
||||
-I$(PKG_BUILD_DIR)/lib/libxsupconfig/ \
|
||||
-I$(STAGING_DIR)/usr/include/madwifi" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
CC="$(TARGET_CROSS)gcc" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
@ -77,6 +78,7 @@ define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC="$(TARGET_CC)" \
|
||||
DESTDIR=$(PKG_INSTALL_DIR) \
|
||||
all install
|
||||
endef
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -ruN xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.h xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.h
|
||||
--- xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.h 2005-04-06 04:21:53.000000000 +0200
|
||||
+++ xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.h 2005-10-17 22:03:19.000000000 +0200
|
||||
@@ -21,6 +21,7 @@
|
||||
int cardif_madwifi_driver_set_key(char *, int, unsigned char *, int, int,
|
||||
char *, int, char *, int);
|
||||
int cardif_madwifi_driver_wpa_state(struct interface_data *, char);
|
||||
+void cardif_madwifi_driver_associate(struct interface_data *, char *);
|
||||
int cardif_madwifi_driver_disassociate(struct interface_data *, int);
|
||||
|
||||
#endif // _CARDIF_MADWIFI_DRIVER_H_
|
@ -1,7 +1,7 @@
|
||||
diff -Nur xsupplicant-1.2.2/configure xsupplicant-1.2.2.patched/configure
|
||||
--- xsupplicant-1.2.2/configure 2005-09-14 05:34:54.000000000 +0200
|
||||
+++ xsupplicant-1.2.2.patched/configure 2005-12-23 23:51:47.031541500 +0100
|
||||
@@ -4809,19 +4809,6 @@
|
||||
diff -ur xsupplicant.old/configure xsupplicant.dev/configure
|
||||
--- xsupplicant.old/configure 2006-10-05 14:09:58.019206000 +0200
|
||||
+++ xsupplicant.dev/configure 2006-10-05 14:12:12.466767016 +0200
|
||||
@@ -5449,19 +5449,6 @@
|
||||
FRAMER="generic"
|
||||
fi
|
||||
|
||||
@ -18,6 +18,6 @@ diff -Nur xsupplicant-1.2.2/configure xsupplicant-1.2.2.patched/configure
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
if test "$MADWIFI_PATH" != ""; then
|
||||
echo "$as_me:$LINENO: result: Adding MADWIFI WPA support." >&5
|
||||
echo "${ECHO_T}Adding MADWIFI WPA support." >&6
|
||||
CFLAGS="$GGDBFLAGS $CFLAGS"
|
||||
|
||||
touch Makefile.in
|
12
net/xsupplicant/patches/003-compile_fix.patch
Normal file
12
net/xsupplicant/patches/003-compile_fix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ur xsupplicant.old/lib/libxsupgui/Makefile.in xsupplicant.dev/lib/libxsupgui/Makefile.in
|
||||
--- xsupplicant.old/lib/libxsupgui/Makefile.in 2006-04-16 23:20:42.000000000 +0200
|
||||
+++ xsupplicant.dev/lib/libxsupgui/Makefile.in 2006-10-05 14:15:06.009384528 +0200
|
||||
@@ -170,7 +170,7 @@
|
||||
target_alias = @target_alias@
|
||||
with_openssl_libs = @with_openssl_libs@
|
||||
AUTOMAKE_OPTIONS = foreign no-dependencies
|
||||
-INCLUDES = ${top_srcdir}/src
|
||||
+INCLUDES = -I${top_srcdir}/src
|
||||
include_HEADERS = xsupgui.h
|
||||
lib_LIBRARIES = libxsupgui.a
|
||||
libxsupgui_a_SOURCES = xsupgui.c
|
@ -1,28 +0,0 @@
|
||||
diff -ruN xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.c xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.c
|
||||
--- xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.c 2005-10-13 20:57:28.000000000 +0200
|
||||
+++ xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.c 2005-10-23 19:28:46.000000000 +0200
|
||||
@@ -140,19 +140,19 @@
|
||||
"ioctl[IEEE80211_IOCTL_SETKEY]",
|
||||
"ioctl[IEEE80211_IOCTL_GETKEY]",
|
||||
"ioctl[IEEE80211_IOCTL_DELKEY]",
|
||||
- NULL,
|
||||
+ "ioctl[IEEE80211_IOCTL_SETWMMPARAMS]",
|
||||
"ioctl[IEEE80211_IOCTL_SETMLME]",
|
||||
- NULL,
|
||||
+ "ioctl[IEEE80211_IOCTL_GETCHANINFO]",
|
||||
"ioctl[IEEE80211_IOCTL_SETOPTIE]",
|
||||
"ioctl[IEEE80211_IOCTL_GETOPTIE]",
|
||||
"ioctl[IEEE80211_IOCTL_ADDMAC]",
|
||||
NULL,
|
||||
"ioctl[IEEE80211_IOCTL_DELMAC]",
|
||||
- NULL,
|
||||
- "ioctl[IEEE80211_IOCTL_CHANLIST]",
|
||||
+ "ioctl[IEEE80211_IOCTL_GETCHANLIST]",
|
||||
+ "ioctl[IEEE80211_IOCTL_SETCHANLIST]",
|
||||
};
|
||||
if (IEEE80211_IOCTL_SETPARAM <= op &&
|
||||
- op <= IEEE80211_IOCTL_CHANLIST)
|
||||
+ op <= IEEE80211_IOCTL_SETCHANLIST)
|
||||
debug_printf(DEBUG_NORMAL, "%s\n", opnames[op - SIOCIWFIRSTPRIV]);
|
||||
else
|
||||
debug_printf(DEBUG_NORMAL, "ioctl[unknown???]");
|
Loading…
x
Reference in New Issue
Block a user