[packages] i2c-tools: update to svn r6199

Signed-off-by: Luka Perkov <luka@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@38082 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
luka 2013-09-20 02:00:07 +00:00
parent 41e8061432
commit 4689dc8e06
2 changed files with 36 additions and 26 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007-2011 OpenWrt.org
# Copyright (C) 2007-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,47 +9,56 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=i2c-tools
PKG_VERSION:=3.1.0
PKG_VERSION:=2013-09-19
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://dl.lm-sensors.org/i2c-tools/releases
PKG_MD5SUM:=f15019e559e378c6e9d5d6299a00df21
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_URL:=http://lm-sensors.org/svn/i2c-tools/trunk
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=r6199
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=PACKAGE_python-smbus:python
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
define Package/i2c/Default
URL:=http://lm-sensors.org/wiki/I2CTools
TITLE:=I2C
endef
define Package/libi2c
$(call Package/i2c/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE+=library
endef
define Package/i2c-tools
$(call Package/i2c/Default)
SECTION:=utils
CATEGORY:=Utilities
TITLE:=I2C tools for Linux
URL:=http://www.lm-sensors.org/wiki/I2CTools
TITLE+=tools for Linux
DEPENDS:=+libi2c
endef
define Package/python-smbus
$(call Package/i2c/Default)
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=Python bindings for the SMBUS
URL:=http://www.lm-sensors.org/wiki/I2CTools
DEPENDS:= +PACKAGE_python-smbus:python-mini +i2c-tools
DEPENDS:=+PACKAGE_python-smbus:python-mini +i2c-tools
endef
define Package/i2c-tools/description
This package contains an heterogeneous set of I2C tools for Linux. These tools
were originally part of the lm-sensors package.
Includes:
- i2cdetect
- i2cdump
- i2cget
- i2cset
endef
define Package/python-smbus/description
This package contains an heterogeneous set of I2C tools for Linux.
This package contain the python bindings for Linux SMBus access through i2c-dev.
endef
@ -73,6 +82,16 @@ define Build/Compile
$(Build/Compile/python-smbus)
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libi2c.so* $(1)/usr/lib/
endef
define Package/libi2c/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libi2c.so* $(1)/usr/lib/
endef
define Package/i2c-tools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/i2cdetect $(1)/usr/sbin/
@ -85,6 +104,7 @@ define PyPackage/python-smbus/filespec
+|$(PYTHON_PKG_DIR)/smbus.so
endef
$(eval $(call BuildPackage,libi2c))
$(eval $(call BuildPackage,i2c-tools))
$(eval $(call PyPackage,python-smbus))
$(eval $(call BuildPackage,python-smbus))

View File

@ -1,10 +0,0 @@
--- a/py-smbus/smbusmodule.c
+++ b/py-smbus/smbusmodule.c
@@ -21,6 +21,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <fcntl.h>
+#include <linux/i2c.h>
#include <linux/i2c-dev.h>
/*