Update stunnel to 4.25 (#3657)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11683 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-07-06 11:09:56 +00:00
parent c978dcf2ee
commit 47280b7874
5 changed files with 49 additions and 49 deletions

View File

@ -3,15 +3,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=stunnel
PKG_VERSION:=4.20
PKG_VERSION:=4.25
PKG_RELEASE:=1
PKG_MD5SUM:=cf9940395d3503018f721c962528d2ec
PKG_MD5SUM:=7f00799f43910c0362df0e69c65965aa
PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/stunnel
@ -23,7 +20,11 @@ define Package/stunnel
endef
define Package/stunnel/description
Open source SSL TCP Wrapper
Stunnel is a program that allows you to encrypt arbitrary TCP
connections inside SSL (Secure Sockets Layer) available on both Unix
and Windows. Stunnel can allow you to secure non-SSL aware daemons and
protocols (like POP, IMAP, LDAP, etc) by having Stunnel provide the
encryption, requiring no changes to the daemon's code.
endef
@ -44,12 +45,14 @@ define Build/Compile
endef
define Package/stunnel/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/usr/lib $(1)/usr/stunnel
$(INSTALL_DIR) $(1)/etc/stunnel $(1)/etc/init.d
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/stunnel $(1)/usr/sbin/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libstunnel.so $(1)/usr/sbin/
$(CP) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
$(INSTALL_BIN) ./files/stunnel.init $(1)/etc/init.d/S90stunnel
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stunnel $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/lib/stunnel
$(CP) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
$(INSTALL_DIR) $(1)/etc/stunnel
$(INSTALL_CONF) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/stunnel.init $(1)/etc/init.d/stunnel
endef
$(eval $(call BuildPackage,stunnel))

View File

@ -1,4 +1,7 @@
#!/bin/sh
#!/bin/sh /etc/rc.common
# Copyright (C) 2006-2008 OpenWrt.org
START=90
case "$1" in
start|boot)

View File

@ -1,15 +1,14 @@
diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
--- stunnel-4.16.orig/configure 2006-11-03 16:33:56.000000000 +0100
+++ stunnel-4.16/configure 2006-11-03 16:36:48.000000000 +0100
@@ -20850,56 +20850,56 @@
--- a/configure
+++ b/configure
@@ -20898,56 +20898,56 @@
fi
rm -f conftest*
-
-{ echo "$as_me:$LINENO: **************************************** PTY device files" >&5
-echo "$as_me: **************************************** PTY device files" >&6;}
-echo "$as_me:$LINENO: checking for \"/dev/ptmx\"" >&5
-echo $ECHO_N "checking for \"/dev/ptmx\"... $ECHO_C" >&6
-{ echo "$as_me:$LINENO: checking for \"/dev/ptmx\"" >&5
-echo $ECHO_N "checking for \"/dev/ptmx\"... $ECHO_C" >&6; }
-if test "${ac_cv_file___dev_ptmx_+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
@ -23,14 +22,14 @@ diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
- ac_cv_file___dev_ptmx_=no
-fi
-fi
-echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptmx_" >&5
-echo "${ECHO_T}$ac_cv_file___dev_ptmx_" >&6
-{ echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptmx_" >&5
-echo "${ECHO_T}$ac_cv_file___dev_ptmx_" >&6; }
-if test $ac_cv_file___dev_ptmx_ = yes; then
+#
+#{ echo "$as_me:$LINENO: **************************************** PTY device files" >&5
+#echo "$as_me: **************************************** PTY device files" >&6;}
+#echo "$as_me:$LINENO: checking for \"/dev/ptmx\"" >&5
+#echo $ECHO_N "checking for \"/dev/ptmx\"... $ECHO_C" >&6
+#{ echo "$as_me:$LINENO: checking for \"/dev/ptmx\"" >&5
+#echo $ECHO_N "checking for \"/dev/ptmx\"... $ECHO_C" >&6; }
+#if test "${ac_cv_file___dev_ptmx_+set}" = set; then
+# echo $ECHO_N "(cached) $ECHO_C" >&6
+#else
@ -44,8 +43,8 @@ diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
+# ac_cv_file___dev_ptmx_=no
+#fi
+#fi
+#echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptmx_" >&5
+#echo "${ECHO_T}$ac_cv_file___dev_ptmx_" >&6
+#{ echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptmx_" >&5
+#echo "${ECHO_T}$ac_cv_file___dev_ptmx_" >&6; }
+#if test $ac_cv_file___dev_ptmx_ = yes; then
cat >>confdefs.h <<\_ACEOF
-#define HAVE_DEV_PTMX 1
@ -55,8 +54,8 @@ diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
-fi
+#fi
-echo "$as_me:$LINENO: checking for \"/dev/ptc\"" >&5
-echo $ECHO_N "checking for \"/dev/ptc\"... $ECHO_C" >&6
-{ echo "$as_me:$LINENO: checking for \"/dev/ptc\"" >&5
-echo $ECHO_N "checking for \"/dev/ptc\"... $ECHO_C" >&6; }
-if test "${ac_cv_file___dev_ptc_+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
@ -70,11 +69,11 @@ diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
- ac_cv_file___dev_ptc_=no
-fi
-fi
-echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptc_" >&5
-echo "${ECHO_T}$ac_cv_file___dev_ptc_" >&6
-{ echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptc_" >&5
-echo "${ECHO_T}$ac_cv_file___dev_ptc_" >&6; }
-if test $ac_cv_file___dev_ptc_ = yes; then
+#echo "$as_me:$LINENO: checking for \"/dev/ptc\"" >&5
+#echo $ECHO_N "checking for \"/dev/ptc\"... $ECHO_C" >&6
+#{ echo "$as_me:$LINENO: checking for \"/dev/ptc\"" >&5
+#echo $ECHO_N "checking for \"/dev/ptc\"... $ECHO_C" >&6; }
+#if test "${ac_cv_file___dev_ptc_+set}" = set; then
+# echo $ECHO_N "(cached) $ECHO_C" >&6
+#else
@ -88,8 +87,8 @@ diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
+# ac_cv_file___dev_ptc_=no
+#fi
+#fi
+#echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptc_" >&5
+#echo "${ECHO_T}$ac_cv_file___dev_ptc_" >&6
+#{ echo "$as_me:$LINENO: result: $ac_cv_file___dev_ptc_" >&5
+#echo "${ECHO_T}$ac_cv_file___dev_ptc_" >&6; }
+#if test $ac_cv_file___dev_ptc_ = yes; then
cat >>confdefs.h <<\_ACEOF
-#define HAVE_DEV_PTS_AND_PTC 1
@ -101,17 +100,14 @@ diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
{ echo "$as_me:$LINENO: **************************************** entropy" >&5
diff -baurN stunnel-4.16.orig/configure stunnel-4.16/configure
--- stunnel-4.16.orig/configure 2006-11-03 16:45:32.000000000 +0100
+++ stunnel-4.16/configure 2006-11-03 16:46:42.000000000 +0100
@@ -23157,8 +23157,8 @@
@@ -23394,8 +23394,8 @@
# Add SSL includes and libraries
-CFLAGS="$CFLAGS -I$ssldir/include"
-LIBS="$LIBS -L$ssldir/lib -lssl -lcrypto"
+CFLAGS="$CFLAGS "
+CFLAGS="$CFLAGS"
+LIBS="$LIBS -lssl -lcrypto"
# Check for obsolete RSAref library
echo "$as_me:$LINENO: checking for obsolete RSAref library" >&5
{ echo "$as_me:$LINENO: checking for obsolete RSAref library" >&5

View File

@ -1,7 +1,6 @@
diff -baurN stunnel-4.16.orig/src/ssl.c stunnel-4.16/src/ssl.c
--- stunnel-4.16.orig/src/ssl.c 2006-11-03 16:49:02.000000000 +0100
+++ stunnel-4.16/src/ssl.c 2006-11-03 16:50:16.000000000 +0100
@@ -55,13 +55,16 @@
--- a/src/ssl.c
+++ b/src/ssl.c
@@ -62,13 +62,16 @@
}
void ssl_configure(void) { /* configure global SSL settings */
@ -18,8 +17,8 @@ diff -baurN stunnel-4.16.orig/src/ssl.c stunnel-4.16/src/ssl.c
int id=0;
COMP_METHOD *cm=NULL;
char *name="unknown";
@@ -90,6 +93,7 @@
exit(1);
@@ -97,6 +100,7 @@
die(1);
}
s_log(LOG_INFO, "Compression enabled using %s method", name);
+#endif

View File

@ -1,7 +1,6 @@
diff -baurN stunnel-4.16.orig/src/options.c stunnel-4.16/src/options.c
--- stunnel-4.16.orig/src/options.c 2006-11-03 16:50:59.000000000 +0100
+++ stunnel-4.16/src/options.c 2006-11-03 16:51:47.000000000 +0100
@@ -957,8 +957,10 @@
--- a/src/options.c
+++ b/src/options.c
@@ -1127,8 +1127,10 @@
section->client_method=SSLv23_client_method;
section->server_method=SSLv23_server_method;
} else if(!strcasecmp(arg, "SSLv2")) {