add a patch to use target optimization flags, change to build-dep on libjpeg, Makefile cleanup

git-svn-id: svn://svn.openwrt.org/openwrt/packages@5323 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2006-10-28 20:48:00 +00:00
parent 624f902073
commit 4745b293b9
2 changed files with 36 additions and 10 deletions

View File

@ -11,23 +11,24 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=palantir
PKG_VERSION:=2.6
PKG_RELEASE:=1
PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_BUILDDEP:=libjpeg
define Package/palantir
SECTION:=multimedia
CATEGORY:=Multimedia
DEPENDS:=+libjpeg
TITLE:=A multichannel interactive streaming solution
DESCRIPTION:=Palantir is a Linux-based streaming system designed to transmit live\\\
video, audio and data over a TCP/IP network, as well as to control\\\
remote devices.\\\
DESCRIPTION:=\
Palantir is a Linux-based streaming system designed to transmit live \\\
video, audio and data over a TCP/IP network, as well as to control \\\
remote devices.
URL:=http://www.fastpath.it/products/palantir/
endef
@ -35,21 +36,22 @@ define Package/palantir/conffiles
/etc/palantir.conf
endef
include $(INCLUDE_DIR)/package.mk
export CPPFLAGS=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
export LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
include $(INCLUDE_DIR)/package.mk
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)/usr
$(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
$(TARGET_CONFIGURE_OPTS) \
CCINC="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
COPTS="$(TARGET_CFLAGS)" \
lib/libgsm.a
$(MAKE) -C $(PKG_BUILD_DIR)/server \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="-Wall -D_REENTRANT $(TARGET_CFLAGS)" \
COPTS="$(TARGET_CFLAGS)" \
palantir
endef

View File

@ -0,0 +1,24 @@
diff -ruN palantir-2.6-old/server/Makefile palantir-2.6-new/server/Makefile
--- palantir-2.6-old/server/Makefile 2005-09-02 14:33:50.000000000 +0200
+++ palantir-2.6-new/server/Makefile 2006-10-27 23:53:10.000000000 +0200
@@ -47,7 +47,7 @@
.PHONY : tools man
-CFLAGS= -Wall -D_REENTRANT -O3 -g
+CFLAGS= -Wall -D_REENTRANT $(COPTS)
CC= gcc
libjpeg= -ljpeg
diff -ruN palantir-2.6-old/server/libgsm/Makefile palantir-2.6-new/server/libgsm/Makefile
--- palantir-2.6-old/server/libgsm/Makefile 2005-08-14 00:16:27.000000000 +0200
+++ palantir-2.6-new/server/libgsm/Makefile 2006-10-27 23:53:44.000000000 +0200
@@ -51,7 +51,7 @@
endif
CC += -ansi -pedantic
-CCFLAGS = -c -O2 -DNeedFunctionPrototypes=1
+CCFLAGS = -c $(COPTS) -DNeedFunctionPrototypes=1
LD = $(CC)