update to python 2.5.1, security and bug fixes... clean up the makefile slightly... and refresh the patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8239 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fbd3d415e5
commit
4d56260742
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python
|
||||
PKG_VERSION:=2.5
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=2.5.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.python.org/ftp/python/2.5/
|
||||
PKG_MD5SUM:=ddb7401e711354ca83b7842b733825a3
|
||||
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
|
||||
PKG_MD5SUM:=70084ffa561660f07de466c2c8c4842d
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -ruNb Python-2.5.pris/Makefile.pre.in Python-2.5/Makefile.pre.in
|
||||
--- Python-2.5.pris/Makefile.pre.in 2006-07-30 11:20:10.000000000 -0500
|
||||
+++ Python-2.5/Makefile.pre.in 2007-04-19 17:02:07.078288000 -0500
|
||||
Index: Python-2.5.1/Makefile.pre.in
|
||||
===================================================================
|
||||
--- Python-2.5.1.orig/Makefile.pre.in 2007-07-30 12:55:24.000000000 -0500
|
||||
+++ Python-2.5.1/Makefile.pre.in 2007-07-30 12:55:24.000000000 -0500
|
||||
@@ -170,6 +170,7 @@
|
||||
|
||||
PYTHON= python$(EXE)
|
||||
@ -47,9 +48,10 @@ diff -ruNb Python-2.5.pris/Makefile.pre.in Python-2.5/Makefile.pre.in
|
||||
--prefix=$(prefix) \
|
||||
--install-scripts=$(BINDIR) \
|
||||
--install-platlib=$(DESTSHARED) \
|
||||
diff -ruNb Python-2.5.pris/setup.py Python-2.5/setup.py
|
||||
--- Python-2.5.pris/setup.py 2006-08-09 18:42:18.000000000 -0500
|
||||
+++ Python-2.5/setup.py 2007-04-19 16:58:15.395808750 -0500
|
||||
Index: Python-2.5.1/setup.py
|
||||
===================================================================
|
||||
--- Python-2.5.1.orig/setup.py 2007-07-30 12:55:24.000000000 -0500
|
||||
+++ Python-2.5.1/setup.py 2007-07-30 12:57:10.000000000 -0500
|
||||
@@ -209,6 +209,7 @@
|
||||
try:
|
||||
imp.load_dynamic(ext.name, ext_filename)
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -ruNb Python-2.5.pris/setup.py Python-2.5/setup.py
|
||||
--- Python-2.5.pris/setup.py 2007-04-19 17:06:20.170105250 -0500
|
||||
+++ Python-2.5/setup.py 2007-04-19 17:07:14.257485500 -0500
|
||||
Index: Python-2.5.1/setup.py
|
||||
===================================================================
|
||||
--- Python-2.5.1.orig/setup.py 2007-07-30 12:55:24.000000000 -0500
|
||||
+++ Python-2.5.1/setup.py 2007-07-30 12:57:03.000000000 -0500
|
||||
@@ -244,7 +244,18 @@
|
||||
return sys.platform
|
||||
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -ruNb Python-2.5.pris/setup.py Python-2.5/setup.py
|
||||
--- Python-2.5.pris/setup.py 2007-04-19 17:08:06.740765500 -0500
|
||||
+++ Python-2.5/setup.py 2007-04-19 17:08:23.121789250 -0500
|
||||
Index: Python-2.5.1/setup.py
|
||||
===================================================================
|
||||
--- Python-2.5.1.orig/setup.py 2007-07-30 12:55:24.000000000 -0500
|
||||
+++ Python-2.5.1/setup.py 2007-07-30 12:55:24.000000000 -0500
|
||||
@@ -15,7 +15,14 @@
|
||||
from distutils.command.install_lib import install_lib
|
||||
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -ruNb Python-2.5.pris/Python/import.c Python-2.5/Python/import.c
|
||||
--- Python-2.5.pris/Python/import.c 2006-09-10 23:06:23.000000000 -0500
|
||||
+++ Python-2.5/Python/import.c 2007-04-19 17:09:30.209982000 -0500
|
||||
@@ -853,8 +853,12 @@
|
||||
Index: Python-2.5.1/Python/import.c
|
||||
===================================================================
|
||||
--- Python-2.5.1.orig/Python/import.c 2007-07-30 12:55:23.000000000 -0500
|
||||
+++ Python-2.5.1/Python/import.c 2007-07-30 12:55:24.000000000 -0500
|
||||
@@ -864,8 +864,12 @@
|
||||
write_compiled_module(PyCodeObject *co, char *cpathname, time_t mtime)
|
||||
{
|
||||
FILE *fp;
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
x
Reference in New Issue
Block a user