mysql: update to 5.1.66 and clean up the makefile, fixes #11065
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35122 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
08f566d7c3
commit
4e390f26ac
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/uclibc++.mk
|
||||
|
||||
PKG_NAME:=mysql
|
||||
PKG_VERSION:=5.1.53
|
||||
PKG_VERSION:=5.1.66
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
@ -18,12 +18,12 @@ PKG_SOURCE_URL:=\
|
||||
http://mysql.he.net/Downloads/MySQL-5.1/ \
|
||||
http://www.linorg.usp.br/mysql/Downloads/MySQL-5.1/ \
|
||||
http://mysql.holywar.net/Downloads/MySQL-5.1/
|
||||
PKG_MD5SUM:=e5e7c5b0b5c382489e6a66778703bc46
|
||||
PKG_MD5SUM:=a43ffa58e3611e5a557feb745596aca3
|
||||
|
||||
PKG_BUILD_DEPENDS:=libncurses libreadline
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_FIXUP:=libtool no-autoreconf
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -35,7 +35,7 @@ define Package/libmysqlclient/Default
|
||||
URL:=http://dev.mysql.com/
|
||||
endef
|
||||
|
||||
define Package/mysql-server/Default
|
||||
define Package/mysql-server
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libmysqlclient +libpthread +libncursesw +libreadline
|
||||
@ -44,10 +44,6 @@ define Package/mysql-server/Default
|
||||
SUBMENU:=database
|
||||
endef
|
||||
|
||||
define Package/mysql-server
|
||||
$(call Package/mysql-server/Default)
|
||||
endef
|
||||
|
||||
define Package/libmysqlclient
|
||||
$(call Package/libmysqlclient/Default)
|
||||
endef
|
||||
@ -60,58 +56,41 @@ endef
|
||||
|
||||
TARGET_CXX=g++-uc
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
||||
LDFLAGS="$$$$LDFLAGS" \
|
||||
LIBS="-nodefaultlibs -luClibc++ -lm -lc $(LIBGCC_S)" \
|
||||
CLIENTCLIBS="-nodefaultlibs -luClibc++ -lm -lc $(LIBGCC_S)" \
|
||||
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); touch \
|
||||
configure.in \
|
||||
aclocal.m4 \
|
||||
Makefile.in \
|
||||
config.h.in \
|
||||
configure \
|
||||
);
|
||||
$(CP) files/lex_hash.h $(PKG_BUILD_DIR)/sql/lex_hash.h
|
||||
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--enable-thread-safe-client \
|
||||
--disable-assembler \
|
||||
--with-pthread \
|
||||
--with-server \
|
||||
--without-mysqlmanager \
|
||||
--without-raid \
|
||||
--with-mysqld-user=root \
|
||||
--with-unix-socket-path=/tmp \
|
||||
--without-libwrap \
|
||||
--without-pstack \
|
||||
--with-low-memory \
|
||||
--without-embedded-server \
|
||||
--without-query-cache \
|
||||
--without-mysqlfs \
|
||||
--without-vio \
|
||||
--without-ssl \
|
||||
--without-docs \
|
||||
--without-man \
|
||||
--without-bench \
|
||||
--without-readline \
|
||||
--without-debug \
|
||||
--with-named-thread-libs=-lpthread \
|
||||
, \
|
||||
mysql_cv_compress=yes \
|
||||
mysql_cv_gethostname_style=glibc2 \
|
||||
ac_cv_c_stack_direction=-1 \
|
||||
);
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--enable-thread-safe-client \
|
||||
--disable-assembler \
|
||||
--with-pthread \
|
||||
--with-server \
|
||||
--without-mysqlmanager \
|
||||
--without-raid \
|
||||
--with-mysqld-user=root \
|
||||
--with-unix-socket-path=/tmp \
|
||||
--without-libwrap \
|
||||
--without-pstack \
|
||||
--with-low-memory \
|
||||
--without-embedded-server \
|
||||
--without-query-cache \
|
||||
--without-mysqlfs \
|
||||
--without-vio \
|
||||
--without-ssl \
|
||||
--without-docs \
|
||||
--without-man \
|
||||
--without-bench \
|
||||
--without-readline \
|
||||
--without-debug \
|
||||
--with-named-thread-libs=-lpthread
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
mysql_cv_compress=yes \
|
||||
mysql_cv_gethostname_style=glibc2 \
|
||||
mysql_cv_gcc_atomic_builtins=yes \
|
||||
mysql_cv_gcc_atomic_builtins_pthread_t=yes \
|
||||
ac_cv_c_stack_direction=-1
|
||||
|
||||
define Build/Compile
|
||||
+$(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" \
|
||||
SUBDIRS="include" \
|
||||
@ -121,6 +100,9 @@ define Build/Compile
|
||||
SUBDIRS="include" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install
|
||||
g++ -I $(PKG_BUILD_DIR)/include \
|
||||
-o $(PKG_BUILD_DIR)/sql/gen_lex_hash \
|
||||
$(PKG_BUILD_DIR)/sql/gen_lex_hash.cc
|
||||
+$(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)/libmysql" \
|
||||
CC="g++" \
|
||||
CFLAGS="$(HOST_CFLAGS)" \
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,6 +1,6 @@
|
||||
--- a/scripts/mysql_install_db.sh
|
||||
+++ b/scripts/mysql_install_db.sh
|
||||
@@ -317,7 +317,7 @@ then
|
||||
@@ -322,7 +322,7 @@
|
||||
fi
|
||||
|
||||
# Try to determine the hostname
|
179
libs/mysql/patches/110-cross_compile.patch
Normal file
179
libs/mysql/patches/110-cross_compile.patch
Normal file
@ -0,0 +1,179 @@
|
||||
--- a/storage/innodb_plugin/plug.in
|
||||
+++ b/storage/innodb_plugin/plug.in
|
||||
@@ -56,10 +56,8 @@
|
||||
esac
|
||||
AC_SUBST(INNODB_DYNAMIC_CFLAGS)
|
||||
|
||||
- AC_MSG_CHECKING(whether GCC atomic builtins are available)
|
||||
- # either define HAVE_IB_GCC_ATOMIC_BUILTINS or not
|
||||
- AC_TRY_RUN(
|
||||
- [
|
||||
+ AC_CACHE_CHECK([whether GCC atomic builtins are available],
|
||||
+ [mysql_cv_gcc_atomic_builtins], [AC_TRY_RUN([
|
||||
int main()
|
||||
{
|
||||
long x;
|
||||
@@ -96,21 +94,18 @@
|
||||
|
||||
return(0);
|
||||
}
|
||||
- ],
|
||||
- [
|
||||
- AC_DEFINE([HAVE_IB_GCC_ATOMIC_BUILTINS], [1],
|
||||
- [GCC atomic builtins are available])
|
||||
- AC_MSG_RESULT(yes)
|
||||
- ],
|
||||
- [
|
||||
- AC_MSG_RESULT(no)
|
||||
- ]
|
||||
- )
|
||||
+ ], [mysql_cv_gcc_atomic_builtins=yes],
|
||||
+ [mysql_cv_gcc_atomic_builtins=no],
|
||||
+ [mysql_cv_gcc_atomic_builtins=no])])
|
||||
+
|
||||
+ if test "x$mysql_cv_gcc_atomic_builtins" = xyes; then
|
||||
+ AC_DEFINE(HAVE_IB_GCC_ATOMIC_BUILTINS, 1,
|
||||
+ [Define to 1 if compiler provides atomic builtins.])
|
||||
+ fi
|
||||
|
||||
- AC_MSG_CHECKING(whether pthread_t can be used by GCC atomic builtins)
|
||||
- # either define HAVE_IB_ATOMIC_PTHREAD_T_GCC or not
|
||||
- AC_TRY_RUN(
|
||||
- [
|
||||
+
|
||||
+ AC_CACHE_CHECK([whether pthread_t can be used by GCC atomic builtins],
|
||||
+ [mysql_cv_gcc_atomic_builtins_pthread_t], [AC_TRY_RUN([
|
||||
#include <pthread.h>
|
||||
#include <string.h>
|
||||
|
||||
@@ -127,16 +122,14 @@
|
||||
|
||||
return(0);
|
||||
}
|
||||
- ],
|
||||
- [
|
||||
- AC_DEFINE([HAVE_IB_ATOMIC_PTHREAD_T_GCC], [1],
|
||||
- [pthread_t can be used by GCC atomic builtins])
|
||||
- AC_MSG_RESULT(yes)
|
||||
- ],
|
||||
- [
|
||||
- AC_MSG_RESULT(no)
|
||||
- ]
|
||||
- )
|
||||
+ ], [mysql_cv_gcc_atomic_builtins_pthread_t=yes],
|
||||
+ [mysql_cv_gcc_atomic_builtins_pthread_t=no],
|
||||
+ [mysql_cv_gcc_atomic_builtins_pthread_t=no])])
|
||||
+
|
||||
+ if test "x$mysql_cv_gcc_atomic_builtins_pthread_t" = xyes; then
|
||||
+ AC_DEFINE(HAVE_IB_ATOMIC_PTHREAD_T_GCC, 1,
|
||||
+ [Define to 1 if pthread_t can be used by GCC atomic builtins])
|
||||
+ fi
|
||||
|
||||
AC_MSG_CHECKING(whether Solaris libc atomic functions are available)
|
||||
# Define HAVE_IB_SOLARIS_ATOMICS if _all_ of the following
|
||||
@@ -156,7 +149,6 @@
|
||||
AC_DEFINE([HAVE_IB_SOLARIS_ATOMICS], [1],
|
||||
[Define to 1 if Solaris libc atomic functions are available]
|
||||
)
|
||||
- fi
|
||||
|
||||
AC_MSG_CHECKING(whether pthread_t can be used by Solaris libc atomic functions)
|
||||
# either define HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS or not
|
||||
@@ -230,6 +222,8 @@
|
||||
AC_MSG_RESULT(no)
|
||||
]
|
||||
)
|
||||
+ fi
|
||||
+
|
||||
])
|
||||
|
||||
# vim: set ft=config:
|
||||
--- a/sql/gen_lex_hash.cc
|
||||
+++ b/sql/gen_lex_hash.cc
|
||||
@@ -344,55 +344,6 @@
|
||||
}
|
||||
|
||||
|
||||
-static void usage(int version)
|
||||
-{
|
||||
- printf("%s Ver 3.6 Distrib %s, for %s (%s)\n",
|
||||
- my_progname, MYSQL_SERVER_VERSION, SYSTEM_TYPE, MACHINE_TYPE);
|
||||
- if (version)
|
||||
- return;
|
||||
- puts(ORACLE_WELCOME_COPYRIGHT_NOTICE("2000"));
|
||||
- puts("This program generates a perfect hashing function for the sql_lex.cc");
|
||||
- printf("Usage: %s [OPTIONS]\n\n", my_progname);
|
||||
- my_print_help(my_long_options);
|
||||
-}
|
||||
-
|
||||
-
|
||||
-extern "C" my_bool
|
||||
-get_one_option(int optid, const struct my_option *opt __attribute__((unused)),
|
||||
- char *argument __attribute__((unused)))
|
||||
-{
|
||||
- switch(optid) {
|
||||
- case 'V':
|
||||
- usage(1);
|
||||
- exit(0);
|
||||
- case 'I':
|
||||
- case '?':
|
||||
- usage(0);
|
||||
- exit(0);
|
||||
- case '#':
|
||||
- DBUG_PUSH(argument ? argument : default_dbug_option);
|
||||
- break;
|
||||
- }
|
||||
- return 0;
|
||||
-}
|
||||
-
|
||||
-
|
||||
-static int get_options(int argc, char **argv)
|
||||
-{
|
||||
- int ho_error;
|
||||
-
|
||||
- if ((ho_error= handle_options(&argc, &argv, my_long_options, get_one_option)))
|
||||
- exit(ho_error);
|
||||
-
|
||||
- if (argc >= 1)
|
||||
- {
|
||||
- usage(0);
|
||||
- exit(1);
|
||||
- }
|
||||
- return(0);
|
||||
-}
|
||||
-
|
||||
-
|
||||
int check_dup_symbols(SYMBOL *s1, SYMBOL *s2)
|
||||
{
|
||||
if (s1->length!=s2->length || strncmp(s1->name,s2->name,s1->length))
|
||||
@@ -443,12 +394,6 @@
|
||||
|
||||
int main(int argc,char **argv)
|
||||
{
|
||||
- MY_INIT(argv[0]);
|
||||
- DBUG_PROCESS(argv[0]);
|
||||
-
|
||||
- if (get_options(argc,(char **) argv))
|
||||
- exit(1);
|
||||
-
|
||||
/* Broken up to indicate that it's not advice to you, gentle reader. */
|
||||
printf("/*\n\n Do " "not " "edit " "this " "file " "directly!\n\n*/\n");
|
||||
|
||||
@@ -549,7 +494,6 @@
|
||||
}\n\
|
||||
}\n"
|
||||
);
|
||||
- my_end(0);
|
||||
exit(0);
|
||||
}
|
||||
|
||||
--- a/sql/Makefile.am
|
||||
+++ b/sql/Makefile.am
|
||||
@@ -26,7 +26,6 @@
|
||||
WRAPLIBS= @WRAPLIBS@
|
||||
SUBDIRS = share
|
||||
libexec_PROGRAMS = mysqld
|
||||
-EXTRA_PROGRAMS = gen_lex_hash
|
||||
bin_PROGRAMS = mysql_tzinfo_to_sql
|
||||
|
||||
noinst_LTLIBRARIES= libndb.la \
|
File diff suppressed because it is too large
Load Diff
@ -1,117 +0,0 @@
|
||||
--- a/sql/Makefile.am
|
||||
+++ b/sql/Makefile.am
|
||||
@@ -41,7 +41,6 @@ mysqld_DEPENDENCIES= @mysql_plugin_libs@
|
||||
LDADD = $(SUPPORTING_LIBS) @ZLIB_LIBS@ @NDB_SCI_LIBS@
|
||||
mysqld_LDADD = libndb.la \
|
||||
@MYSQLD_EXTRA_LDFLAGS@ \
|
||||
- @pstack_libs@ \
|
||||
@mysql_plugin_libs@ \
|
||||
$(LDADD) $(CXXLDFLAGS) $(WRAPLIBS) @LIBDL@ \
|
||||
$(yassl_libs) $(openssl_libs) @MYSQLD_EXTRA_LIBS@
|
||||
@@ -174,10 +173,10 @@ link_sources:
|
||||
# This generates lex_hash.h
|
||||
# NOTE Built sources should depend on their sources not the tool
|
||||
# this avoid the rebuild of the built files in a source dist
|
||||
-lex_hash.h: gen_lex_hash.cc lex.h
|
||||
- $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
|
||||
- ./gen_lex_hash$(EXEEXT) > $@-t
|
||||
- $(MV) $@-t $@
|
||||
+#lex_hash.h: gen_lex_hash.cc lex.h
|
||||
+# $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
|
||||
+# ./gen_lex_hash$(EXEEXT) > $@-t
|
||||
+# $(MV) $@-t $@
|
||||
|
||||
# For testing of udf_example.so
|
||||
udf_example_la_SOURCES= udf_example.c
|
||||
--- a/sql/Makefile.in
|
||||
+++ b/sql/Makefile.in
|
||||
@@ -486,8 +486,6 @@ plugin_partition_static_target = @plugin
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
psdir = @psdir@
|
||||
-pstack_dir = @pstack_dir@
|
||||
-pstack_libs = @pstack_libs@
|
||||
readline_basedir = @readline_basedir@
|
||||
readline_dir = @readline_dir@
|
||||
readline_h_ln_cmd = @readline_h_ln_cmd@
|
||||
@@ -541,7 +539,6 @@ mysqld_DEPENDENCIES = @mysql_plugin_libs
|
||||
LDADD = $(SUPPORTING_LIBS) @ZLIB_LIBS@ @NDB_SCI_LIBS@
|
||||
mysqld_LDADD = libndb.la \
|
||||
@MYSQLD_EXTRA_LDFLAGS@ \
|
||||
- @pstack_libs@ \
|
||||
@mysql_plugin_libs@ \
|
||||
$(LDADD) $(CXXLDFLAGS) $(WRAPLIBS) @LIBDL@ \
|
||||
$(yassl_libs) $(openssl_libs) @MYSQLD_EXTRA_LIBS@
|
||||
@@ -1308,10 +1305,10 @@ link_sources:
|
||||
# This generates lex_hash.h
|
||||
# NOTE Built sources should depend on their sources not the tool
|
||||
# this avoid the rebuild of the built files in a source dist
|
||||
-lex_hash.h: gen_lex_hash.cc lex.h
|
||||
- $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
|
||||
- ./gen_lex_hash$(EXEEXT) > $@-t
|
||||
- $(MV) $@-t $@
|
||||
+#lex_hash.h: gen_lex_hash.cc lex.h
|
||||
+# $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
|
||||
+# ./gen_lex_hash$(EXEEXT) > $@-t
|
||||
+# $(MV) $@-t $@
|
||||
|
||||
# We might have some stuff not built in this build, but that we want to install
|
||||
install-exec-hook:
|
||||
--- a/extra/Makefile.am
|
||||
+++ b/extra/Makefile.am
|
||||
@@ -29,16 +29,16 @@ DIST_SUBDIRS = yassl
|
||||
# This will build mysqld_error.h, mysqld_ername.h and sql_state.h
|
||||
# NOTE Built files should depend on their sources to avoid
|
||||
# the built files being rebuilt in source dist
|
||||
-$(top_builddir)/include/mysqld_error.h: comp_err.c \
|
||||
- $(top_srcdir)/sql/share/errmsg.txt
|
||||
- $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
|
||||
- $(top_builddir)/extra/comp_err$(EXEEXT) \
|
||||
- --charset=$(top_srcdir)/sql/share/charsets \
|
||||
- --out-dir=$(top_builddir)/sql/share/ \
|
||||
- --header_file=$(top_builddir)/include/mysqld_error.h \
|
||||
- --name_file=$(top_builddir)/include/mysqld_ername.h \
|
||||
- --state_file=$(top_builddir)/include/sql_state.h \
|
||||
- --in_file=$(top_srcdir)/sql/share/errmsg.txt
|
||||
+#$(top_builddir)/include/mysqld_error.h: comp_err.c \
|
||||
+# $(top_srcdir)/sql/share/errmsg.txt
|
||||
+# $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
|
||||
+# $(top_builddir)/extra/comp_err$(EXEEXT) \
|
||||
+# --charset=$(top_srcdir)/sql/share/charsets \
|
||||
+# --out-dir=$(top_builddir)/sql/share/ \
|
||||
+# --header_file=$(top_builddir)/include/mysqld_error.h \
|
||||
+# --name_file=$(top_builddir)/include/mysqld_ername.h \
|
||||
+# --state_file=$(top_builddir)/include/sql_state.h \
|
||||
+# --in_file=$(top_srcdir)/sql/share/errmsg.txt
|
||||
$(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
|
||||
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h
|
||||
|
||||
--- a/extra/Makefile.in
|
||||
+++ b/extra/Makefile.in
|
||||
@@ -938,16 +938,16 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
# This will build mysqld_error.h, mysqld_ername.h and sql_state.h
|
||||
# NOTE Built files should depend on their sources to avoid
|
||||
# the built files being rebuilt in source dist
|
||||
-$(top_builddir)/include/mysqld_error.h: comp_err.c \
|
||||
- $(top_srcdir)/sql/share/errmsg.txt
|
||||
- $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
|
||||
- $(top_builddir)/extra/comp_err$(EXEEXT) \
|
||||
- --charset=$(top_srcdir)/sql/share/charsets \
|
||||
- --out-dir=$(top_builddir)/sql/share/ \
|
||||
- --header_file=$(top_builddir)/include/mysqld_error.h \
|
||||
- --name_file=$(top_builddir)/include/mysqld_ername.h \
|
||||
- --state_file=$(top_builddir)/include/sql_state.h \
|
||||
- --in_file=$(top_srcdir)/sql/share/errmsg.txt
|
||||
+#$(top_builddir)/include/mysqld_error.h: comp_err.c \
|
||||
+# $(top_srcdir)/sql/share/errmsg.txt
|
||||
+# $(MAKE) $(AM_MAKEFLAGS) comp_err$(EXEEXT)
|
||||
+# $(top_builddir)/extra/comp_err$(EXEEXT) \
|
||||
+# --charset=$(top_srcdir)/sql/share/charsets \
|
||||
+# --out-dir=$(top_builddir)/sql/share/ \
|
||||
+# --header_file=$(top_builddir)/include/mysqld_error.h \
|
||||
+# --name_file=$(top_builddir)/include/mysqld_ername.h \
|
||||
+# --state_file=$(top_builddir)/include/sql_state.h \
|
||||
+# --in_file=$(top_srcdir)/sql/share/errmsg.txt
|
||||
$(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
|
||||
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h
|
||||
|
Loading…
x
Reference in New Issue
Block a user