[packages] git: update to 1.7.3.4, refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24863 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2011-01-01 09:42:17 +00:00
parent 26094befa9
commit 4fe1850038
2 changed files with 49 additions and 64 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2009 OpenWrt.org
# Copyright (C) 2009-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=git
PKG_VERSION:=1.7.3.2
PKG_VERSION:=1.7.3.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@KERNEL/software/scm/git
PKG_MD5SUM:=902f7f07a789fedc0d2ac03656b85969
PKG_MD5SUM:=3a2602016f98c529cda7b9fad1a6e216
PKG_INSTALL:=1

View File

@ -1,37 +1,30 @@
diff -Nur git-1.7.3.2-orig/builtin/daemon.c git-1.7.3.2/builtin/daemon.c
--- git-1.7.3.2-orig/builtin/daemon.c 1970-01-01 01:00:00.000000000 +0100
+++ git-1.7.3.2/builtin/daemon.c 2010-11-17 12:30:47.977921001 +0100
--- /dev/null
+++ b/builtin/daemon.c
@@ -0,0 +1 @@
+#include "../daemon.c"
diff -Nur git-1.7.3.2-orig/builtin/fast-import.c git-1.7.3.2/builtin/fast-import.c
--- git-1.7.3.2-orig/builtin/fast-import.c 1970-01-01 01:00:00.000000000 +0100
+++ git-1.7.3.2/builtin/fast-import.c 2010-11-17 12:30:47.977921001 +0100
--- /dev/null
+++ b/builtin/fast-import.c
@@ -0,0 +1 @@
+#include "../fast-import.c"
diff -Nur git-1.7.3.2-orig/builtin/http-backend.c git-1.7.3.2/builtin/http-backend.c
--- git-1.7.3.2-orig/builtin/http-backend.c 1970-01-01 01:00:00.000000000 +0100
+++ git-1.7.3.2/builtin/http-backend.c 2010-11-17 12:30:47.977921001 +0100
--- /dev/null
+++ b/builtin/http-backend.c
@@ -0,0 +1 @@
+#include "../http-backend.c"
diff -Nur git-1.7.3.2-orig/builtin/imap-send.c git-1.7.3.2/builtin/imap-send.c
--- git-1.7.3.2-orig/builtin/imap-send.c 1970-01-01 01:00:00.000000000 +0100
+++ git-1.7.3.2/builtin/imap-send.c 2010-11-17 12:30:47.977921001 +0100
--- /dev/null
+++ b/builtin/imap-send.c
@@ -0,0 +1 @@
+#include "../imap-send.c"
diff -Nur git-1.7.3.2-orig/builtin/shell.c git-1.7.3.2/builtin/shell.c
--- git-1.7.3.2-orig/builtin/shell.c 1970-01-01 01:00:00.000000000 +0100
+++ git-1.7.3.2/builtin/shell.c 2010-11-17 12:30:47.977921001 +0100
--- /dev/null
+++ b/builtin/shell.c
@@ -0,0 +1 @@
+#include "../shell.c"
diff -Nur git-1.7.3.2-orig/builtin/upload-pack.c git-1.7.3.2/builtin/upload-pack.c
--- git-1.7.3.2-orig/builtin/upload-pack.c 1970-01-01 01:00:00.000000000 +0100
+++ git-1.7.3.2/builtin/upload-pack.c 2010-11-17 12:30:47.977921001 +0100
--- /dev/null
+++ b/builtin/upload-pack.c
@@ -0,0 +1 @@
+#include "../upload-pack.c"
diff -Nur git-1.7.3.2-orig/builtin.h git-1.7.3.2/builtin.h
--- git-1.7.3.2-orig/builtin.h 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/builtin.h 2010-11-17 12:30:47.977921001 +0100
@@ -139,5 +139,11 @@
--- a/builtin.h
+++ b/builtin.h
@@ -139,5 +139,11 @@ extern int cmd_verify_pack(int argc, con
extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
extern int cmd_replace(int argc, const char **argv, const char *prefix);
@ -43,10 +36,9 @@ diff -Nur git-1.7.3.2-orig/builtin.h git-1.7.3.2/builtin.h
+extern int cmd_fast_import(int argc, const char **argv, const char *prefix);
#endif
diff -Nur git-1.7.3.2-orig/daemon.c git-1.7.3.2/daemon.c
--- git-1.7.3.2-orig/daemon.c 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/daemon.c 2010-11-17 12:30:47.977921001 +0100
@@ -963,7 +963,7 @@
--- a/daemon.c
+++ b/daemon.c
@@ -963,7 +963,7 @@ static int serve(char *listen_addr, int
return service_loop(socknum, socklist);
}
@ -55,10 +47,9 @@ diff -Nur git-1.7.3.2-orig/daemon.c git-1.7.3.2/daemon.c
{
int listen_port = 0;
char *listen_addr = NULL;
diff -Nur git-1.7.3.2-orig/fast-import.c git-1.7.3.2/fast-import.c
--- git-1.7.3.2-orig/fast-import.c 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/fast-import.c 2010-11-17 12:30:47.977921001 +0100
@@ -2912,7 +2912,7 @@
--- a/fast-import.c
+++ b/fast-import.c
@@ -2912,7 +2912,7 @@ static void parse_argv(void)
read_marks();
}
@ -67,10 +58,9 @@ diff -Nur git-1.7.3.2-orig/fast-import.c git-1.7.3.2/fast-import.c
{
unsigned int i;
diff -Nur git-1.7.3.2-orig/git.c git-1.7.3.2/git.c
--- git-1.7.3.2-orig/git.c 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/git.c 2010-11-17 12:30:47.977921001 +0100
@@ -240,11 +240,11 @@
--- a/git.c
+++ b/git.c
@@ -240,11 +240,11 @@ const char git_version_string[] = GIT_VE
struct cmd_struct {
const char *cmd;
@ -84,7 +74,7 @@ diff -Nur git-1.7.3.2-orig/git.c git-1.7.3.2/git.c
{
int status, help;
struct stat st;
@@ -293,7 +293,7 @@
@@ -293,7 +293,7 @@ static int run_builtin(struct cmd_struct
return 0;
}
@ -93,7 +83,7 @@ diff -Nur git-1.7.3.2-orig/git.c git-1.7.3.2/git.c
{
const char *cmd = argv[0];
static struct cmd_struct commands[] = {
@@ -405,6 +405,12 @@
@@ -405,6 +405,12 @@ static void handle_internal_command(int
{ "verify-pack", cmd_verify_pack },
{ "show-ref", cmd_show_ref, RUN_SETUP },
{ "pack-refs", cmd_pack_refs, RUN_SETUP },
@ -106,10 +96,9 @@ diff -Nur git-1.7.3.2-orig/git.c git-1.7.3.2/git.c
};
int i;
static const char ext[] = STRIP_EXTENSION;
diff -Nur git-1.7.3.2-orig/http-backend.c git-1.7.3.2/http-backend.c
--- git-1.7.3.2-orig/http-backend.c 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/http-backend.c 2010-11-17 12:30:47.977921001 +0100
@@ -542,7 +542,7 @@
--- a/http-backend.c
+++ b/http-backend.c
@@ -540,7 +540,7 @@ static struct service_cmd {
{"POST", "/git-receive-pack$", service_rpc}
};
@ -118,10 +107,9 @@ diff -Nur git-1.7.3.2-orig/http-backend.c git-1.7.3.2/http-backend.c
{
char *method = getenv("REQUEST_METHOD");
char *dir;
diff -Nur git-1.7.3.2-orig/imap-send.c git-1.7.3.2/imap-send.c
--- git-1.7.3.2-orig/imap-send.c 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/imap-send.c 2010-11-17 12:30:47.977921001 +0100
@@ -1528,7 +1528,7 @@
--- a/imap-send.c
+++ b/imap-send.c
@@ -1528,7 +1528,7 @@ static int git_imap_config(const char *k
return 0;
}
@ -130,10 +118,9 @@ diff -Nur git-1.7.3.2-orig/imap-send.c git-1.7.3.2/imap-send.c
{
struct msg_data all_msgs, msg;
struct store *ctx = NULL;
diff -Nur git-1.7.3.2-orig/Makefile git-1.7.3.2/Makefile
--- git-1.7.3.2-orig/Makefile 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/Makefile 2010-11-17 12:46:11.309922603 +0100
@@ -398,12 +398,7 @@
--- a/Makefile
+++ b/Makefile
@@ -398,12 +398,7 @@ EXTRA_PROGRAMS =
# ... and all the rest that could be moved out of bindir to gitexecdir
PROGRAMS += $(EXTRA_PROGRAMS)
@ -146,7 +133,7 @@ diff -Nur git-1.7.3.2-orig/Makefile git-1.7.3.2/Makefile
PROGRAMS += $(patsubst %.o,git-%$X,$(PROGRAM_OBJS))
@@ -750,6 +745,12 @@
@@ -750,6 +745,12 @@ BUILTIN_OBJS += builtin/var.o
BUILTIN_OBJS += builtin/verify-pack.o
BUILTIN_OBJS += builtin/verify-tag.o
BUILTIN_OBJS += builtin/write-tree.o
@ -159,7 +146,7 @@ diff -Nur git-1.7.3.2-orig/Makefile git-1.7.3.2/Makefile
GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
EXTLIBS =
@@ -1244,10 +1245,9 @@
@@ -1244,10 +1245,9 @@ endif
EXTLIBS += -lz
ifndef NO_POSIX_ONLY_PROGRAMS
@ -171,18 +158,18 @@ diff -Nur git-1.7.3.2-orig/Makefile git-1.7.3.2/Makefile
ifdef OPENSSLDIR
BASIC_CFLAGS += -I$(OPENSSLDIR)/include
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
@@ -1919,10 +1919,6 @@
@@ -1923,10 +1923,6 @@ endif
git-%$X: %.o $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
-git-imap-send$X: imap-send.o $(GITLIBS)
- $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
- $(LIBS) $(OPENSSL_LINK) $(OPENSSL_LIBSSL)
- $(LIBS) $(OPENSSL_LINK) $(OPENSSL_LIBSSL) $(LIB_4_CRYPTO)
-
git-http-fetch$X: revision.o http.o http-walker.o http-fetch.o $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
$(LIBS) $(CURL_LIBCURL)
@@ -2120,23 +2116,22 @@
@@ -2124,23 +2120,22 @@ endif
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
@ -209,10 +196,9 @@ diff -Nur git-1.7.3.2-orig/Makefile git-1.7.3.2/Makefile
ln -s "git$X" "$$execdir/$$p" 2>/dev/null || \
cp "$$execdir/git$X" "$$execdir/$$p" || exit; \
done && \
diff -Nur git-1.7.3.2-orig/shell.c git-1.7.3.2/shell.c
--- git-1.7.3.2-orig/shell.c 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/shell.c 2010-11-17 12:30:47.981921001 +0100
@@ -45,7 +45,7 @@
--- a/shell.c
+++ b/shell.c
@@ -45,7 +45,7 @@ static struct commands {
{ NULL },
};
@ -221,10 +207,9 @@ diff -Nur git-1.7.3.2-orig/shell.c git-1.7.3.2/shell.c
{
char *prog;
struct commands *cmd;
diff -Nur git-1.7.3.2-orig/upload-pack.c git-1.7.3.2/upload-pack.c
--- git-1.7.3.2-orig/upload-pack.c 2010-10-22 05:49:16.000000000 +0200
+++ git-1.7.3.2/upload-pack.c 2010-11-17 12:30:47.981921001 +0100
@@ -676,7 +676,7 @@
--- a/upload-pack.c
+++ b/upload-pack.c
@@ -676,7 +676,7 @@ static void upload_pack(void)
}
}