update xl2tpd to 1.1.11, fix opt flags, rename ppp related config files, cleanup

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8676 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-09-07 19:27:03 +00:00
parent 1e0af590d9
commit 564b16d4fc
5 changed files with 39 additions and 30 deletions

View File

@ -9,15 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xl2tpd
PKG_VERSION:=1.1.09
PKG_RELEASE:=1.0
PKG_VERSION:=1.1.11
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.xelerance.com/software/xl2tpd
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MD5SUM:=ab5656eb5a3d1973f7f69b039675332e
include $(INCLUDE_DIR)/package.mk
@ -25,36 +22,36 @@ define Package/xl2tpd
SECTION:=net
CATEGORY:=Network
TITLE:=An L2TP (Layer 2 Tunneling Protocol) daemon
DESCRIPTION:=\
l2tpd is the open source implementation of the L2TP tunneling \\\
protocol (RFC2661). It does implement both LAC and LNS role \\\
in a L2TP networking architecture. The main goal of this protocol is \\\
to tunnel PPP frame trough an ip network.
URL:=http://www.xelerance.com/software/xl2tpd
endef
define Package/xl2tpd/conffiles
/etc/xl2tpd/xl2tpd.conf
define Package/xl2tpd/description
l2tpd is the open source implementation of the L2TP tunneling protocol
(RFC2661). It does implement both LAC and LNS role in a L2TP networking
architecture. The main goal of this protocol is to tunnel PPP frame trough
an ip network.
endef
define Build/Compile
$(call Build/Compile/Default, \
CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION" \
)
# XXX: CFLAGS are already set by Build/Compile/Default
MAKE_FLAGS+= \
OFLAGS=""
define Package/xl2tpd/conffiles
/etc/xl2tpd/ppp.options
/etc/xl2tpd/ppp.secrets
/etc/xl2tpd/xl2tpd.conf
endef
define Package/xl2tpd/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/xl2tpd
$(INSTALL_DATA) ./files/xl2tpd.conf $(1)/etc/xl2tpd/
$(INSTALL_DATA) ./files/l2tp-secrets $(1)/etc/xl2tpd/
$(INSTALL_DATA) ./files/options.l2tp $(1)/etc/xl2tpd/
# $(INSTALL_DIR) $(1)/etc/ppp
# $(INSTALL_DATA) ./files/options.l2tpd $(1)/etc/ppp/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/xl2tpd $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/xl2tpd.init $(1)/etc/init.d/xl2tpd
$(INSTALL_DIR) $(1)/etc/xl2tpd
$(INSTALL_DATA) ./files/ppp.options $(1)/etc/xl2tpd/
$(INSTALL_DATA) ./files/ppp.secrets $(1)/etc/xl2tpd/
$(INSTALL_DATA) ./files/xl2tpd.conf $(1)/etc/xl2tpd/
chmod 0600 $(1)/etc/xl2tpd/ppp.secrets
endef
$(eval $(call BuildPackage,xl2tpd))

View File

@ -5,7 +5,7 @@ noauth
debug
dump
logfd 2
logfile /var/log/l2tpd.log
logfile /var/log/xl2tpd.log
noccp
novj
novjccomp

View File

@ -1,6 +1,6 @@
[global]
port = 1701
auth file = /etc/xl2tpd/l2tp-secrets
auth file = /etc/xl2tpd/ppp.secrets
access control = no
; rand source = dev
@ -19,7 +19,7 @@ refuse authentication = yes
;unix authentication = no
name = VersaLink
ppp debug = yes
pppoptfile = /etc/xl2tpd/options.l2tp
pppoptfile = /etc/xl2tpd/ppp.options
; call rws = 10
; tunnel rws = 4
; flow bit = yes
@ -44,8 +44,7 @@ refuse authentication = yes
; require authentication = yes
name = VersaLink
ppp debug = yes
; pppoptfile = /etc/ppp/options
pppoptfile = /etc/xl2tpd/options.l2tp
pppoptfile = /etc/xl2tpd/ppp.options
; call rws = 10
; tunnel rws = 4
; flow bit = yes

View File

@ -0,0 +1,13 @@
diff -ruN xl2tpd-1.1.11-old/Makefile xl2tpd-1.1.11-new/Makefile
--- xl2tpd-1.1.11-old/Makefile 2007-06-26 19:53:07.000000000 +0200
+++ xl2tpd-1.1.11-new/Makefile 2007-09-04 21:55:56.000000000 +0200
@@ -67,7 +67,8 @@
FFLAGS= -DIP_ALLOCATION
-CFLAGS+= $(DFLAGS) -O2 -fno-builtin -Wall -DSANITY $(OSFLAGS) $(FFLAGS)
+OFLAGS=-O2
+CFLAGS+= $(DFLAGS) $(OFLAGS) -fno-builtin -Wall -DSANITY $(OSFLAGS) $(FFLAGS)
HDRS=l2tp.h avp.h misc.h control.h call.h scheduler.h file.h aaa.h md5.h
OBJS=xl2tpd.o pty.o misc.o control.o avp.o call.o network.o avpsend.o scheduler.o file.o aaa.o md5.o
SRCS=${OBJS:.o=.c} ${HDRS}