[packages] php5: add PECL dio extension

git-svn-id: svn://svn.openwrt.org/openwrt/packages@27802 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mhei 2011-07-27 22:18:29 +00:00
parent 1d93b641b5
commit 57b99a087c
4 changed files with 7784 additions and 3913 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=5.3.6
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.php.net/distributions/
@ -22,7 +22,7 @@ PHP5_MODULES = \
apc \
ctype curl \
fileinfo \
dom \
dio dom \
exif \
ftp \
gettext gd gmp \
@ -194,6 +194,12 @@ else
CONFIGURE_ARGS+= --without-gettext
endif
ifneq ($(CONFIG_PACKAGE_php5-mod-dio),)
CONFIGURE_ARGS+= --enable-dio=shared
else
CONFIGURE_ARGS+= --disable-dio
endif
ifneq ($(CONFIG_PACKAGE_php5-mod-dom),)
CONFIGURE_ARGS+= --enable-dom=shared
else
@ -481,6 +487,7 @@ $(eval $(call BuildModule,apc,APC,+librt))
$(eval $(call BuildModule,ctype,Ctype))
$(eval $(call BuildModule,curl,cURL,+libcurl))
$(eval $(call BuildModule,fileinfo,Fileinfo,+libmagic))
$(eval $(call BuildModule,dio,Direct IO))
$(eval $(call BuildModule,dom,DOM,@PHP5_LIBXML +libxml2))
$(eval $(call BuildModule,exif,EXIF))
$(eval $(call BuildModule,ftp,FTP))

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,29 @@
--- a/ext/dio/dio.c
+++ b/ext/dio/dio.c
@@ -442,6 +442,26 @@ PHP_FUNCTION(dio_tcsetattr)
/* assign to correct values... */
switch (Baud_Rate) {
+#ifdef B460800
+ case 460800:
+ BAUD = B460800;
+ break;
+#endif
+#ifdef B230400
+ case 230400:
+ BAUD = B230400;
+ break;
+#endif
+#ifdef B115200
+ case 115200:
+ BAUD = B115200;
+ break;
+#endif
+#ifdef B57600
+ case 57600:
+ BAUD = B57600;
+ break;
+#endif
case 38400:
BAUD = B38400;
break;

File diff suppressed because it is too large Load Diff