[packages] ipset: fix compilations against Linux v3.3 and newer (ipv6_addr_copy() got removed in favor to a direct structure copy) (#11310)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31383 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7fa0a3500a
commit
5adfd6001c
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=ipset
|
||||
PKG_VERSION:=6.11
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://ipset.netfilter.org
|
||||
|
22
net/ipset/patches/200-remove-ipv6_addr_copy.patch
Normal file
22
net/ipset/patches/200-remove-ipv6_addr_copy.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- a/kernel/net/netfilter/ipset/ip_set_hash_ip.c
|
||||
+++ b/kernel/net/netfilter/ipset/ip_set_hash_ip.c
|
||||
@@ -241,7 +241,7 @@ hash_ip6_data_isnull(const struct hash_i
|
||||
static inline void
|
||||
hash_ip6_data_copy(struct hash_ip6_elem *dst, const struct hash_ip6_elem *src)
|
||||
{
|
||||
- ipv6_addr_copy(&dst->ip.in6, &src->ip.in6);
|
||||
+ dst->ip.in6 = src->ip.in6;
|
||||
}
|
||||
|
||||
static inline void
|
||||
--- a/kernel/net/netfilter/ipset/ip_set_hash_net.c
|
||||
+++ b/kernel/net/netfilter/ipset/ip_set_hash_net.c
|
||||
@@ -295,7 +295,7 @@ static inline void
|
||||
hash_net6_data_copy(struct hash_net6_elem *dst,
|
||||
const struct hash_net6_elem *src)
|
||||
{
|
||||
- ipv6_addr_copy(&dst->ip.in6, &src->ip.in6);
|
||||
+ dst->ip.in6 = src->ip.in6;
|
||||
dst->cidr = src->cidr;
|
||||
dst->nomatch = src->nomatch;
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user