update patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26937 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
07d6af9e22
commit
5aeb131464
20
net/freeswitch/patches/001-Makefile.am.patch
Normal file
20
net/freeswitch/patches/001-Makefile.am.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -292,7 +292,7 @@ endif
|
||||
##
|
||||
fs_encode_SOURCES = src/fs_encode.c
|
||||
fs_encode_CFLAGS = $(AM_CFLAGS)
|
||||
-fs_encode_LDFLAGS = $(AM_LDFLAGS) $(CORE_LIBS)
|
||||
+fs_encode_LDFLAGS = $(AM_LDFLAGS) -lpthread $(CORE_LIBS)
|
||||
fs_encode_LDADD = libfreeswitch.la
|
||||
|
||||
##
|
||||
@@ -300,7 +300,7 @@ fs_encode_LDADD = libfreeswitch.la
|
||||
##
|
||||
tone2wav_SOURCES = src/tone2wav.c
|
||||
tone2wav_CFLAGS = $(AM_CFLAGS)
|
||||
-tone2wav_LDFLAGS = $(AM_LDFLAGS) $(CORE_LIBS)
|
||||
+tone2wav_LDFLAGS = $(AM_LDFLAGS) -lpthread $(CORE_LIBS)
|
||||
tone2wav_LDADD = libfreeswitch.la
|
||||
|
||||
##
|
22
net/freeswitch/patches/002-libs-esl-Makefile.patch
Normal file
22
net/freeswitch/patches/002-libs-esl-Makefile.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- a/libs/esl/Makefile
|
||||
+++ b/libs/esl/Makefile
|
||||
@@ -7,7 +7,7 @@ PICKY=-O2 -ffast-math -Wall -Werror -Wun
|
||||
CFLAGS=$(BASE_FLAGS) $(PICKY)
|
||||
CXXFLAGS=$(BASE_FLAGS) -Wall -Werror -Wno-unused-variable
|
||||
MYLIB=libesl.a
|
||||
-LIBS=-lncurses -lpthread -lesl -lm
|
||||
+LIBS=-L$(STAGING_DIR)/usr/lib -lncurses -lpthread -lesl -lm
|
||||
LDFLAGS=-L.
|
||||
OBJS=src/esl.o src/esl_event.o src/esl_threadmutex.o src/esl_config.o src/esl_json.o src/esl_buffer.o
|
||||
SRC=src/esl.c src/esl_json.c src/esl_event.c src/esl_threadmutex.c src/esl_config.c src/esl_oop.cpp src/esl_json.c src/esl_buffer.c
|
||||
@@ -19,8 +19,8 @@ OBJS += src/esl_oop.o
|
||||
all: $(MYLIB) fs_cli testclient testserver ivrd
|
||||
|
||||
$(MYLIB): $(OBJS) $(HEADERS) $(SRC)
|
||||
- ar rcs $(MYLIB) $(OBJS)
|
||||
- ranlib $(MYLIB)
|
||||
+ $(AR) rcs $(MYLIB) $(OBJS)
|
||||
+ $(RANLIB) $(MYLIB)
|
||||
|
||||
testserver: $(MYLIB) testserver.c
|
||||
$(CC) $(CC_CFLAGS) $(CFLAGS) testserver.c -o testserver $(LDFLAGS) $(LIBS)
|
Loading…
x
Reference in New Issue
Block a user