git-svn-id: svn://svn.openwrt.org/openwrt/packages@7039 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
ryd 2007-04-23 21:33:40 +00:00
parent 3de098fdc9
commit 5af39f2d38
2 changed files with 111 additions and 0 deletions

48
admin/htop/Makefile Normal file
View File

@ -0,0 +1,48 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: $
include $(TOPDIR)/rules.mk
PKG_NAME:=htop
PKG_VERSION:=0.6.5
PKG_RELEASE:=1
PKG_MD5SUM:=180aa7c9db7106ed1197b1e408660a0e
PKG_SOURCE_URL:=@SF/htop
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/htop
SECTION:=admin
CATEGORY:=Administration
TITLE:=process viewer
DEPENDS:=+libncurses
DESCRIPTION:=\
An interactive process viewer with colors \\\
tree mode and other features.
URL:=http://htop.sourceforge.net/
endef
define Build/Compile
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Package/htop/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin
endef
$(eval $(call BuildPackage,htop))

View File

@ -0,0 +1,63 @@
diff -purN htop-0.6.5_org/configure htop-0.6.5/configure
--- htop-0.6.5_org/configure 2007-04-18 15:38:08.000000000 -0400
+++ htop-0.6.5/configure 2007-04-18 17:53:18.000000000 -0400
@@ -5286,59 +5286,6 @@ _ACEOF
fi;
-as_ac_File=`echo "ac_cv_file_$PROCDIR/stat" | $as_tr_sh`
-echo "$as_me:$LINENO: checking for $PROCDIR/stat" >&5
-echo $ECHO_N "checking for $PROCDIR/stat... $ECHO_C" >&6
-if eval "test \"\${$as_ac_File+set}\" = set"; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
-if test -r "$PROCDIR/stat"; then
- eval "$as_ac_File=yes"
-else
- eval "$as_ac_File=no"
-fi
-fi
-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
-echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
-if test `eval echo '${'$as_ac_File'}'` = yes; then
- :
-else
- { { echo "$as_me:$LINENO: error: Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&5
-echo "$as_me: error: Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&2;}
- { (exit 1); exit 1; }; }
-fi
-
-as_ac_File=`echo "ac_cv_file_$PROCDIR/meminfo" | $as_tr_sh`
-echo "$as_me:$LINENO: checking for $PROCDIR/meminfo" >&5
-echo $ECHO_N "checking for $PROCDIR/meminfo... $ECHO_C" >&6
-if eval "test \"\${$as_ac_File+set}\" = set"; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
-if test -r "$PROCDIR/meminfo"; then
- eval "$as_ac_File=yes"
-else
- eval "$as_ac_File=no"
-fi
-fi
-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
-echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
-if test `eval echo '${'$as_ac_File'}'` = yes; then
- :
-else
- { { echo "$as_me:$LINENO: error: Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&5
-echo "$as_me: error: Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&2;}
- { (exit 1); exit 1; }; }
-fi
-
-
ac_config_files="$ac_config_files Makefile"
cat >confcache <<\_ACEOF