adding paroli - an integrated phone application written in python

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13868 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2009-01-05 08:00:36 +00:00
parent 6eb8fc0eb4
commit 5e8bf7f2c5
2 changed files with 79 additions and 0 deletions

58
phone/paroli/Makefile Normal file
View File

@ -0,0 +1,58 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=paroli
PKG_VERSION:=20090104
PKG_REV:=39c30cb16cc04c478f79cd34fec7719c730469f7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=git://git.openmoko.org/git/paroli.git
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_BUILD_DEPENDS:=python
include $(INCLUDE_DIR)/package.mk
-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
define Package/paroli
SECTION:=phone
CATEGORY:=Phone
TITLE:=integrated phone application
DEPENDS:=python-core +fso
URL:=http://wiki.openmoko.org/wiki/Paroli
endef
define Package/paroli/description
Paroli is an integrated phone application written in Python which uses the FSO (freesmartphone.org) DBus API
endef
define Build/Compile
$(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
endef
define Package/paroli/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR) $(1)/usr/bin $(1)/etc $(1)/usr/share/applications/paroli
$(CP) \
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
$(1)$(PYTHON_PKG_DIR)
$(CP) \
$(PKG_INSTALL_DIR)/usr/bin/* \
$(1)/usr/bin/
$(CP) \
$(PKG_INSTALL_DIR)/usr/applications/* \
$(1)/usr/share/applications/paroli/
$(CP) \
$(PKG_INSTALL_DIR)/etc/* \
$(1)/etc/
endef
$(eval $(call BuildPackage,paroli))

View File

@ -0,0 +1,21 @@
diff -ruN paroli-20090104.orig/setup.py paroli-20090104/setup.py
--- paroli-20090104.orig/setup.py 2009-01-05 08:38:30.000000000 +0100
+++ paroli-20090104/setup.py 2009-01-05 08:45:09.000000000 +0100
@@ -74,7 +74,7 @@
dbus_data = [
(os.path.join(sys.prefix, 'share/dbus-1/system-services/'),
['data/dbus/org.tichy.launcher.service']),
- ('../../etc/dbus-1/system.d/',
+ ('../etc/dbus-1/system.d/',
['data/dbus/tichy.conf'])]
setup(name='Paroli',
@@ -94,7 +94,7 @@
'data/paroli-dialer.desktop']),
(os.path.join(sys.prefix, 'share/pixmaps/'),
['data/tichy']),
- ('../../etc/paroli/', ['data/paroli.cfg'])] \
+ ('../etc/paroli/', ['data/paroli.cfg'])] \
+ plugins_files('paroli-services', 'paroli/services') \
+ plugins_files('paroli-applications', 'paroli/applications') \
+ dbus_data,