net/mtr: update to mtr-0.79 & fix compile issues
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22014 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9a0c03bca4
commit
5f4dc2b243
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mtr
|
||||
PKG_VERSION:=0.75
|
||||
PKG_VERSION:=0.79
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
|
||||
PKG_MD5SUM:=23baca52d0922c2ecba7eba05317868c
|
||||
PKG_MD5SUM:=f7c1f873e68e7176f60ae9fbb2ca20f4
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -urN mtr-0.75/configure mtr-0.75.new/configure
|
||||
--- mtr-0.75/configure 2008-09-19 11:38:58.000000000 +0200
|
||||
+++ mtr-0.75.new/configure 2009-06-26 22:41:26.000000000 +0200
|
||||
@@ -7956,7 +7956,7 @@
|
||||
echo $ECHO_N "checking for C flags to get more warnings... $ECHO_C" >&6; }
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
if test "x$ac_cv_c_compiler_gnu" = "xyes" ; then
|
||||
- warning_CFLAGS="-Wall -Wno-pointer-sign"
|
||||
+ warning_CFLAGS="-Wall"
|
||||
else
|
||||
case "$host_os" in
|
||||
irix*)
|
||||
diff -urN mtr-0.75/configure.in mtr-0.75.new/configure.in
|
||||
--- mtr-0.75/configure.in 2008-09-08 09:40:54.000000000 +0200
|
||||
+++ mtr-0.75.new/configure.in 2009-06-26 22:41:21.000000000 +0200
|
||||
@@ -108,7 +108,7 @@
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
if test "x$ac_cv_c_compiler_gnu" = "xyes" ; then
|
||||
dnl gcc is the easiest C compiler
|
||||
- warning_CFLAGS="-Wall -Wno-pointer-sign"
|
||||
+ warning_CFLAGS="-Wall"
|
||||
else
|
||||
dnl Vendor supplied C compilers are a bit tricky
|
||||
case "$host_os" in
|
45
net/mtr/patches/502-fix-res_ninit.patch
Normal file
45
net/mtr/patches/502-fix-res_ninit.patch
Normal file
@ -0,0 +1,45 @@
|
||||
--- a/dns.c
|
||||
+++ b/dns.c
|
||||
@@ -309,17 +309,17 @@ char nullstring[] = "";
|
||||
|
||||
int use_dns = 1;
|
||||
|
||||
-#ifdef res_ninit
|
||||
-#define RES_INIT() res_ninit(&myres);
|
||||
-#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
||||
- res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
|
||||
-struct __res_state myres;
|
||||
-#else
|
||||
+//#ifdef res_ninit
|
||||
+//#define RES_INIT() res_ninit(&myres);
|
||||
+//#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
||||
+// res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
|
||||
+//struct __res_state myres;
|
||||
+//#else
|
||||
#define RES_INIT() res_init();
|
||||
#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
|
||||
res_mkquery(a, b, c, d, e, f, g, h, i)
|
||||
#define myres _res
|
||||
-#endif
|
||||
+//#endif
|
||||
|
||||
/* Code */
|
||||
#ifdef CorruptCheck
|
||||
@@ -1274,7 +1274,7 @@ res_nmkquery(res_state statp,
|
||||
#if 0
|
||||
hp->id = htons(++statp->id);
|
||||
#else
|
||||
- hp->id = htons(statp->id);
|
||||
+// hp->id = htons(statp->id);
|
||||
int randombits;
|
||||
do
|
||||
{
|
||||
@@ -1287,7 +1287,7 @@ res_nmkquery(res_state statp,
|
||||
#endif
|
||||
}
|
||||
while ((randombits & 0xffff) == 0);
|
||||
- statp->id = (statp->id + randombits) & 0xffff;
|
||||
+// statp->id = (statp->id + randombits) & 0xffff;
|
||||
#endif
|
||||
hp->opcode = op;
|
||||
hp->rd = (statp->options & RES_RECURSE) != 0;
|
Loading…
x
Reference in New Issue
Block a user