net/iputils: fix ipv6 compile errors (thanks florian)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22011 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
4ffa724b7a
commit
9a0c03bca4
@ -62,6 +62,7 @@ define Package/iputils-ping6
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - ping6
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
DEPENDS += @IPV6
|
||||
endef
|
||||
|
||||
define Package/iputils-ping6/description
|
||||
@ -98,6 +99,7 @@ define Package/iputils-tracepath6
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - tracepath6
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
DEPENDS += @IPV6
|
||||
endef
|
||||
|
||||
define Package/iputils-tracepath6/description
|
||||
@ -110,6 +112,7 @@ define Package/iputils-traceroute6
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - traceroute6
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
DEPENDS += @IPV6
|
||||
endef
|
||||
|
||||
define Package/iputils-traceroute6/description
|
||||
@ -163,8 +166,10 @@ endef
|
||||
$(eval $(call BuildPackage,iputils-arping))
|
||||
$(eval $(call BuildPackage,iputils-clockdiff))
|
||||
$(eval $(call BuildPackage,iputils-ping))
|
||||
$(eval $(call BuildPackage,iputils-ping6))
|
||||
$(eval $(call BuildPackage,iputils-tftpd))
|
||||
$(eval $(call BuildPackage,iputils-tracepath))
|
||||
$(eval $(call BuildPackage,iputils-tracepath6))
|
||||
$(eval $(call BuildPackage,iputils-traceroute6))
|
||||
ifeq ($(CONFIG_IPV6),y)
|
||||
$(eval $(call BuildPackage,iputils-ping6))
|
||||
$(eval $(call BuildPackage,iputils-tracepath6))
|
||||
$(eval $(call BuildPackage,iputils-traceroute6))
|
||||
endif
|
||||
|
23
net/iputils/patches/002-fix-ipv6.patch
Normal file
23
net/iputils/patches/002-fix-ipv6.patch
Normal file
@ -0,0 +1,23 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -18,7 +18,10 @@ CFLAGS=$(CCOPT) $(GLIBCFIX) $(DEFINES)
|
||||
|
||||
IPV4_TARGETS=tracepath ping clockdiff arping tftpd
|
||||
IPV6_TARGETS=tracepath6 traceroute6 ping6
|
||||
-TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
||||
+TARGETS=$(IPV4_TARGETS)
|
||||
+ifeq ($(CONFIG_IPV6),y)
|
||||
+ TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
||||
+endif
|
||||
|
||||
LASTTAG:=`git-describe HEAD | sed -e 's/-.*//'`
|
||||
TAG:=`date +s%Y%m%d`
|
||||
@@ -29,7 +32,7 @@ all: $(TARGETS)
|
||||
tftpd: tftpd.o tftpsubs.o
|
||||
ping: ping.o ping_common.o
|
||||
ping6: ping6.o ping_common.o
|
||||
-ping.o ping6.o ping_common.o: ping_common.h
|
||||
+ping.o ping_common.o: ping_common.h
|
||||
tftpd.o tftpsubs.o: tftp.h
|
||||
|
||||
rdisc_srv: rdisc_srv.o
|
Loading…
x
Reference in New Issue
Block a user