port opencdk to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4219 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
59afb3e300
commit
6023eacc9f
111
libs/opencdk/Makefile
Normal file
111
libs/opencdk/Makefile
Normal file
@ -0,0 +1,111 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=opencdk
|
||||
PKG_VERSION:=0.5.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
|
||||
ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/ \
|
||||
http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
|
||||
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
|
||||
http://josefsson.org/gnutls/releases/opencdk/
|
||||
PKG_MD5SUM:=aaff60107f0153873192ffda00699a96
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libopencdk
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libgcrypt
|
||||
TITLE:=The Open Crypto Development Kit library
|
||||
DESCRIPTION:=The Open Crypto Development Kit library.\\\
|
||||
This library provides basic parts of the OpenPGP message format.\\\
|
||||
For reference, please read the rfc2440.txt in the doc/ directory.\\\
|
||||
Due to some possible security problems, the library also implements \\\
|
||||
parts of draft-ietf-openpgp-rfc2440bis-08.txt. If you want to exchange \\\
|
||||
messages with earlier PGP version < 7, you should use the compat mode.
|
||||
URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
touch configure.ac ; \
|
||||
touch acinclude.m4 ; \
|
||||
touch aclocal.m4 ; \
|
||||
touch Makefile.in ; \
|
||||
touch config.h.in ; \
|
||||
touch configure ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/libopencdk/install
|
||||
install -m0755 -d $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/opencdk-config $(STAGING_DIR)/usr/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/opencdk.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/bin/opencdk-config \
|
||||
$(STAGING_DIR)/usr/include/opencdk.h \
|
||||
$(STAGING_DIR)/usr/lib/libopencdk.{a,so*}
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libopencdk))
|
28
libs/opencdk/patches/500-cross-compile.patch
Normal file
28
libs/opencdk/patches/500-cross-compile.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -ruN opencdk-0.5.5-orig/configure opencdk-0.5.5-1/configure
|
||||
--- opencdk-0.5.5-orig/configure 2004-06-20 15:54:29.000000000 +0200
|
||||
+++ opencdk-0.5.5-1/configure 2005-03-15 22:36:53.000000000 +0100
|
||||
@@ -19788,8 +19788,8 @@
|
||||
|
||||
|
||||
|
||||
-LIBOPENCDK_LIBS="$LIBS -L${libdir} -lopencdk $LIBGCRYPT_LIBS"
|
||||
-LIBOPENCDK_CFLAGS="$LIBGCRYPT_CFLAGS -I${includedir}"
|
||||
+LIBOPENCDK_LIBS="$LIBS -lopencdk $LIBGCRYPT_LIBS"
|
||||
+LIBOPENCDK_CFLAGS="$LIBGCRYPT_CFLAGS"
|
||||
|
||||
|
||||
|
||||
diff -ruN opencdk-0.5.5-orig/configure.ac opencdk-0.5.5-1/configure.ac
|
||||
--- opencdk-0.5.5-orig/configure.ac 2004-06-05 19:46:31.000000000 +0200
|
||||
+++ opencdk-0.5.5-1/configure.ac 2005-03-15 22:36:26.000000000 +0100
|
||||
@@ -96,8 +96,8 @@
|
||||
***
|
||||
]]))
|
||||
|
||||
-LIBOPENCDK_LIBS="$LIBS -L${libdir} -lopencdk $LIBGCRYPT_LIBS"
|
||||
-LIBOPENCDK_CFLAGS="$LIBGCRYPT_CFLAGS -I${includedir}"
|
||||
+LIBOPENCDK_LIBS="$LIBS -lopencdk $LIBGCRYPT_LIBS"
|
||||
+LIBOPENCDK_CFLAGS="$LIBGCRYPT_CFLAGS"
|
||||
AC_SUBST(LIBOPENCDK_LIBS)
|
||||
AC_SUBST(LIBOPENCDK_CFLAGS)
|
||||
|
Loading…
x
Reference in New Issue
Block a user