update monit to 4.9 from 4.6

git-svn-id: svn://svn.openwrt.org/openwrt/packages@6494 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
pavlov 2007-03-04 02:27:48 +00:00
parent 0b03a5cb57
commit 60f9ba80bb
2 changed files with 7 additions and 9 deletions

View File

@ -9,9 +9,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=monit
PKG_VERSION:=4.6
PKG_VERSION:=4.9
PKG_RELEASE:=1
PKG_MD5SUM:=4e53aa44e4ca264e61c7c401cee4e697
PKG_MD5SUM:=bcbaab776a54d1e34e3a057c925de9ca
PKG_SOURCE_URL:=http://www.tildeslash.com/monit/dist/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -1,16 +1,14 @@
diff -ruN monit-4.6-old/ssl.c monit-4.6-new/ssl.c
--- monit-4.6-old/ssl.c 2005-08-07 22:26:47.000000000 +0200
+++ monit-4.6-new/ssl.c 2006-12-18 11:18:46.000000000 +0100
@@ -1367,10 +1367,12 @@
--- monit-4.9/ssl.c.orig 2007-01-13 06:00:08.000000000 -0600
+++ monit-4.9/ssl.c 2007-03-03 20:18:16.000000000 -0600
@@ -663,9 +663,11 @@
ssl->method = SSLv23_client_method();
break;
+#ifndef OPENSSL_NO_SSL2
+#ifndef OPENSSL_NO_SSLV2
case SSL_VERSION_SSLV2:
ssl->method = SSLv2_client_method();
break;
+#endif
case SSL_VERSION_SSLV3:
ssl->method = SSLv3_client_method();