[packages] srelay: add a patch to fix auth accepting any passwords (closes: #6781)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19954 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
82ec6f6075
commit
62ab0da953
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2008 OpenWrt.org
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=srelay
|
||||
PKG_VERSION:=0.4.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/socks-relay
|
||||
|
17
net/srelay/patches/005-fix_auth_accept_any_password.patch
Normal file
17
net/srelay/patches/005-fix_auth_accept_any_password.patch
Normal file
@ -0,0 +1,17 @@
|
||||
Without this patch, authentication will accept any password!
|
||||
|
||||
--- a/auth-pwd.c
|
||||
+++ b/auth-pwd.c
|
||||
@@ -251,12 +251,9 @@ int checkpasswd(char *user, char *pass)
|
||||
memset(spwd->sp_pwdp, 0, strlen(spwd->sp_pwdp));
|
||||
#endif
|
||||
|
||||
-#if defined(FREEBSD) || defined(SOLARIS)
|
||||
if (matched) {
|
||||
return(0);
|
||||
} else {
|
||||
return(-1);
|
||||
}
|
||||
-#endif
|
||||
- return(0);
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user