[packages] tinyproxy: update to v1.6.5, set default timeout to 600 (closes: #5951), cleanup

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17874 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2009-10-05 12:30:25 +00:00
parent 312c696dfd
commit 62b26ed020
3 changed files with 12 additions and 15 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,18 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tinyproxy
PKG_VERSION:=1.6.4
PKG_VERSION:=1.6.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.6/
PKG_MD5SUM:=3157b9159a8d005f4248cf4d4d6c65e2
PKG_MD5SUM:=2b2862ba33d2939e4572688d442ba415
include $(INCLUDE_DIR)/package.mk
define Package/tinyproxy
SECTION:=net
CATEGORY:=Network
SUBMENU:=Proxy Servers
TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
URL:=http://tinyproxy.sourceforge.net/
endef
@ -28,12 +29,9 @@ define Package/tinyproxy/conffiles
/etc/config/tinyproxy
endef
define Build/Configure
$(call Build/Configure/Default,\
--enable-filter \
--enable-transparent-proxy \
)
endef
CONFIGURE_ARGS+= \
--enable-filter \
--enable-transparent-proxy \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
@ -47,7 +45,7 @@ define Package/tinyproxy/install
$(INSTALL_DIR) $(1)/usr/share/tinyproxy
$(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
$(INSTALL_DIR) $(1)/etc/config
$(CP) ./files/tinyproxy.config $(1)/etc/config/tinyproxy
$(INSTALL_CONF) ./files/tinyproxy.config $(1)/etc/config/tinyproxy
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
endef

View File

@ -33,7 +33,7 @@ option Port 8888
# Timeout: The number of seconds of inactivity a connection is allowed to
# have before it closed by tinyproxy.
#
#option Timeout 600
option Timeout 600
#
# ErrorFile: Defines the HTML file to send when a given HTTP error

View File

@ -1,7 +1,6 @@
diff -urN tinyproxy-1.6.3/src/reqs.c tinyproxy-1.6.3.new/src/reqs.c
--- tinyproxy-1.6.3/src/reqs.c 2004-08-06 18:56:55.000000000 +0200
+++ tinyproxy-1.6.3.new/src/reqs.c 2007-08-30 16:50:31.000000000 +0200
@@ -726,7 +726,7 @@
--- a/src/reqs.c
+++ b/src/reqs.c
@@ -726,7 +726,7 @@ process_request(struct conn_s *connptr,
request->host);
indicate_http_error(connptr, 403, "Filtered",