Update nagios-plugins to 1.4.12 (#3635)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11698 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
401a63ff75
commit
650f4912b6
@ -9,14 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nagios-plugins
|
||||
PKG_VERSION:=1.4.11
|
||||
PKG_VERSION:=1.4.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/nagiosplug
|
||||
PKG_MD5SUM:=042783a2180a6987e0b403870b3d01f7
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_MD5SUM:=af68d00bbe2c39de02803d23e5eecca3
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -urN nagios-plugins-1.4.11/configure nagios-plugins-1.4.11.new/configure
|
||||
--- nagios-plugins-1.4.11/configure 2007-12-13 23:42:38.000000000 +0100
|
||||
+++ nagios-plugins-1.4.11.new/configure 2008-02-11 07:56:02.000000000 +0100
|
||||
@@ -27226,7 +27226,7 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -27981,7 +27981,7 @@
|
||||
|
||||
if test "$ac_cv_have_decl_swapctl" = "yes";
|
||||
then
|
||||
@ -10,7 +9,7 @@ diff -urN nagios-plugins-1.4.11/configure nagios-plugins-1.4.11.new/configure
|
||||
{ echo "$as_me:$LINENO: checking for 2-arg (SVR4) swapctl" >&5
|
||||
echo $ECHO_N "checking for 2-arg (SVR4) swapctl... $ECHO_C" >&6; }
|
||||
if test "$ac_cv_type_swaptbl_t" = "yes" -a \
|
||||
@@ -27365,7 +27365,7 @@
|
||||
@@ -28120,7 +28120,7 @@
|
||||
#define HAVE_SWAP 1
|
||||
_ACEOF
|
||||
|
||||
@ -19,7 +18,7 @@ diff -urN nagios-plugins-1.4.11/configure nagios-plugins-1.4.11.new/configure
|
||||
fi
|
||||
if test "x$ac_cv_swap_command" != "x"
|
||||
then
|
||||
@@ -27417,7 +27417,7 @@
|
||||
@@ -28172,7 +28172,7 @@
|
||||
#define PROC_MEMINFO "$ac_cv_proc_meminfo"
|
||||
_ACEOF
|
||||
|
||||
@ -28,10 +27,9 @@ diff -urN nagios-plugins-1.4.11/configure nagios-plugins-1.4.11.new/configure
|
||||
fi
|
||||
|
||||
# Extract the first word of "dig", so it can be a program name with args.
|
||||
diff -urN nagios-plugins-1.4.11/plugins/Makefile.am nagios-plugins-1.4.11.new/plugins/Makefile.am
|
||||
--- nagios-plugins-1.4.11/plugins/Makefile.am 2007-12-12 02:27:48.000000000 +0100
|
||||
+++ nagios-plugins-1.4.11.new/plugins/Makefile.am 2008-02-11 08:08:14.000000000 +0100
|
||||
@@ -22,8 +22,8 @@
|
||||
--- a/plugins/Makefile.am
|
||||
+++ b/plugins/Makefile.am
|
||||
@@ -23,8 +23,8 @@
|
||||
check_tcp_programs = check_ftp check_imap check_nntp check_pop \
|
||||
check_udp check_clamd @check_tcp_ssl@
|
||||
|
||||
@ -42,9 +40,8 @@ diff -urN nagios-plugins-1.4.11/plugins/Makefile.am nagios-plugins-1.4.11.new/pl
|
||||
check_nagios check_by_ssh check_dns check_nt check_ide_smart \
|
||||
check_procs check_mysql_query check_apt
|
||||
|
||||
diff -urN nagios-plugins-1.4.11/plugins/Makefile.in nagios-plugins-1.4.11.new/plugins/Makefile.in
|
||||
--- nagios-plugins-1.4.11/plugins/Makefile.in 2007-12-13 23:42:36.000000000 +0100
|
||||
+++ nagios-plugins-1.4.11.new/plugins/Makefile.in 2008-02-11 08:08:22.000000000 +0100
|
||||
--- a/plugins/Makefile.in
|
||||
+++ b/plugins/Makefile.in
|
||||
@@ -35,7 +35,7 @@
|
||||
build_triplet = @build@
|
||||
host_triplet = @host@
|
||||
@ -65,11 +62,11 @@ diff -urN nagios-plugins-1.4.11/plugins/Makefile.in nagios-plugins-1.4.11.new/pl
|
||||
check_game$(EXEEXT) check_dig$(EXEEXT) check_nagios$(EXEEXT) \
|
||||
check_by_ssh$(EXEEXT) check_dns$(EXEEXT) check_nt$(EXEEXT) \
|
||||
check_ide_smart$(EXEEXT) check_procs$(EXEEXT) \
|
||||
--- nagios-plugins-1.4.11/plugins/check_pgsql.c 2007-01-28 22:46:41.000000000 +0100
|
||||
+++ nagios-plugins-1.4.11.new/plugins/check_pgsql.c 2008-02-13 15:47:11.000000000 +0100
|
||||
@@ -45,6 +45,7 @@
|
||||
#include "netutils.h"
|
||||
--- a/plugins/check_pgsql.c
|
||||
+++ b/plugins/check_pgsql.c
|
||||
@@ -43,6 +43,7 @@
|
||||
#include <libpq-fe.h>
|
||||
#include <pg_config_manual.h>
|
||||
|
||||
+#define NAMEDATALEN 64
|
||||
#define DEFAULT_DB "template1"
|
||||
|
Loading…
x
Reference in New Issue
Block a user