[packages] gst-plugins-good: update to 0.10.23, rework Makefile:
* rename gst-plugins-good-* plugins to gst-mod-* * add a gst-plugins-good meta-package * remove unneeded extra CFLAGS & LDFLAGS git-svn-id: svn://svn.openwrt.org/openwrt/packages@22069 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c70a1e765f
commit
69abd88d39
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2009 OpenWrt.org
|
||||
# Copyright (C) 2009-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,94 +8,167 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gst-plugins-good
|
||||
PKG_VERSION:=0.10.17
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.10.23
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-good/
|
||||
PKG_MD5SUM:=833546cd2b8bbf86b8ed083b00897918
|
||||
PKG_MD5SUM:=9cddbb0e7e90677f0cc05c23feffef5c
|
||||
|
||||
PKG_BUILD_DEPENDS:= gstreamer gst-plugins-base liboil
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
export PATH:=$(PKG_BUILD_DIR)/bin:$(TARGET_PATH)
|
||||
|
||||
PKG_INSTALL=1
|
||||
|
||||
EXTRA_CFLAGS+= \
|
||||
-I$(STAGING_DIR)/usr/lib/libintl/include \
|
||||
-I$(STAGING_DIR)/usr/lib/libiconv/include \
|
||||
-I$(STAGING_DIR)/usr/include/gtk-2.0/gdk \
|
||||
-I$(STAGING_DIR)/usr/include/gstreamer-0.10
|
||||
|
||||
EXTRA_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libintl/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libiconv/lib
|
||||
|
||||
define Package/gst-plugins-good/Default
|
||||
SECTION:=multimedia
|
||||
define Package/gstreamer/Default
|
||||
CATEGORY:=Multimedia
|
||||
DEPENDS:=+gstreamer +gst-plugins-base-libgsttag +gst-plugins-base-libgstpbutils
|
||||
TITLE:=gst-plugins-good
|
||||
SECTION:=multimedia
|
||||
TITLE:=GStreamer
|
||||
URL:=http://gstreamer.freedesktop.org/
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-good-flac
|
||||
$(call Package/gst-plugins-good/Default)
|
||||
TITLE+= (flac)
|
||||
DEPENDS += +libflac
|
||||
define Package/gstreamer/description/Default
|
||||
GStreamer open source multimedia framework
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-good-flac/description
|
||||
gstreamer FLAC plugins
|
||||
|
||||
define Package/gst-plugins-good
|
||||
$(call Package/gstreamer/Default)
|
||||
TITLE+= plugins collection (good)
|
||||
DEPENDS+= $(GST_DEPENDS)
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-good-id3demux
|
||||
$(call Package/gst-plugins-good/Default)
|
||||
TITLE+= (id3demux)
|
||||
DEPENDS += +libid3tag
|
||||
define Package/gts-plugins-good/description
|
||||
$(call Package/gstreamer/description/Default)
|
||||
.
|
||||
This meta package contains only dependencies to the other plugins from
|
||||
the good plugins collection.
|
||||
endef
|
||||
|
||||
define Package/gst-plugins-good-id3demux/description
|
||||
gstreamer FLAC plugins
|
||||
|
||||
GST_VERSION:=0.10
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-debug \
|
||||
--disable-examples \
|
||||
\
|
||||
--disable-aalib \
|
||||
--disable-alpha \
|
||||
--disable-annodex \
|
||||
--disable-apetag \
|
||||
--disable-auparse \
|
||||
--disable-avi \
|
||||
--disable-bz2 \
|
||||
--disable-cairo \
|
||||
--disable-directsound \
|
||||
--disable-dv1394 \
|
||||
--disable-effectv \
|
||||
--disable-esd \
|
||||
--disable-flac \
|
||||
--disable-flv \
|
||||
--disable-flx \
|
||||
--disable-gconf \
|
||||
--disable-gconftool \
|
||||
--disable-gdk_pixbuf \
|
||||
--disable-goom \
|
||||
--disable-goom2k1 \
|
||||
--disable-gst_v4l2 \
|
||||
--disable-icydemux \
|
||||
--disable-hal \
|
||||
--disable-jpeg \
|
||||
--disable-law \
|
||||
--disable-libcaca \
|
||||
--disable-libdv \
|
||||
--disable-libpng \
|
||||
--disable-matroska \
|
||||
--disable-monoscope \
|
||||
--disable-osx_audio \
|
||||
--disable-osx_video \
|
||||
--disable-pulse \
|
||||
--disable-qtdemux \
|
||||
--disable-rtspmanager \
|
||||
--disable-smpte \
|
||||
--disable-shout2 \
|
||||
--disable-soup \
|
||||
--disable-speex \
|
||||
--disable-sunaudio \
|
||||
--disable-taglib \
|
||||
--disable-videobox \
|
||||
--disable-videocrop \
|
||||
--disable-videofilter \
|
||||
--disable-videomixer \
|
||||
--disable-wavpack \
|
||||
--disable-x \
|
||||
--disable-xshm \
|
||||
--disable-xvideo \
|
||||
--disable-y4m \
|
||||
--disable-zlib \
|
||||
\
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--without-x \
|
||||
|
||||
EXTRA_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
|
||||
|
||||
define Package/gst-plugins-good/install
|
||||
/bin/true
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--disable-examples \
|
||||
--disable-esd \
|
||||
--disable-gconf \
|
||||
--disable-gconftool \
|
||||
--disable-shout2 \
|
||||
--disable-aalib \
|
||||
--disable-oss \
|
||||
--disable-hal \
|
||||
--disable-dv \
|
||||
--disable-pulse \
|
||||
--disable-dv1394 \
|
||||
--disable-soup \
|
||||
--disable-osx_audio \
|
||||
--disable-osx_video \
|
||||
--disable-directdraw \
|
||||
--disable-directshow \
|
||||
--disable-sunaudio \
|
||||
--without-x \
|
||||
)
|
||||
$(INSTALL_DIR) $(PKG_BUILD_DIR)/bin
|
||||
touch $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
|
||||
chmod +x $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
|
||||
endef
|
||||
|
||||
define BuildPlugin
|
||||
define Package/gst-plugins-good-$(1)/install
|
||||
$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-0.10
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgst$(1).so \
|
||||
$$(1)/usr/lib/gstreamer-0.10
|
||||
# 1: short name
|
||||
# 2: description
|
||||
# 3: dependencies on other gstreamer libraries (short name)
|
||||
# 4: dependencies on other gstreamer plugins (short name)
|
||||
# 5: dependencies on other packages
|
||||
define GstBuildPlugin
|
||||
|
||||
GST_DEPENDS += +gst-mod-$(1)
|
||||
|
||||
define Package/gst-mod-$(1)
|
||||
$(call Package/gstreamer/Default)
|
||||
TITLE+= $(2) plugin (good)
|
||||
DEPENDS+= +libgstreamer $$(foreach p,$(3),+libgst$$(p)) $$(foreach p,$(4),+gst-mod-$$(p)) $(5)
|
||||
endef
|
||||
|
||||
$$(eval $$(call BuildPackage,gst-plugins-good-$(1)))
|
||||
define Package/gst-mod-$(1)/description
|
||||
$(call Package/gstreamer/description/Default)
|
||||
.
|
||||
This package contains the GStreamer $(2) plugin.
|
||||
endef
|
||||
|
||||
define Package/gst-mod-$(1)/install
|
||||
$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION)
|
||||
( cd $(PKG_INSTALL_DIR); $(CP) \
|
||||
./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \
|
||||
$$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
|
||||
)
|
||||
endef
|
||||
|
||||
$$(eval $$(call BuildPackage,gst-mod-$(1)))
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPlugin,id3demux))
|
||||
$(eval $(call GstBuildPlugin,audiofx,audio effects,audio controller,,))
|
||||
$(eval $(call GstBuildPlugin,autodetect,format auto-detection,,,))
|
||||
$(eval $(call GstBuildPlugin,cutter,audio cutter,audio,,))
|
||||
$(eval $(call GstBuildPlugin,debug,debugging,,,))
|
||||
$(eval $(call GstBuildPlugin,equalizer,audio equalizer,audio controller,,))
|
||||
#$(eval $(call GstBuildPlugin,flac,FLAC codec,pbutils tag,,+libflac @BROKEN))
|
||||
$(eval $(call GstBuildPlugin,id3demux,ID3v1/v2 demuxer,pbutils tag,,))
|
||||
$(eval $(call GstBuildPlugin,interleave,audio interleave,audio,,))
|
||||
$(eval $(call GstBuildPlugin,level,audio level,audio,,))
|
||||
$(eval $(call GstBuildPlugin,multifile,multiple files access,,,))
|
||||
$(eval $(call GstBuildPlugin,multipart,multipart stream handling,,,))
|
||||
$(eval $(call GstBuildPlugin,ossaudio,OSS audio support,audio,,))
|
||||
$(eval $(call GstBuildPlugin,replaygain,volume normalization,pbutils,,))
|
||||
$(eval $(call GstBuildPlugin,rtp,RTP,audio rtp tag,,))
|
||||
$(eval $(call GstBuildPlugin,rtsp,RTSP,interfaces rtp rtsp sdp,,))
|
||||
$(eval $(call GstBuildPlugin,spectrum,spectrum data output,audio fft,,))
|
||||
$(eval $(call GstBuildPlugin,udp,UDP,netbuffer,,))
|
||||
$(eval $(call GstBuildPlugin,wavenc,Wav encoder,,,))
|
||||
$(eval $(call GstBuildPlugin,wavparse,Wav parser,audio riff tag,,))
|
||||
|
||||
$(eval $(call BuildPackage,gst-plugins-good))
|
||||
|
20
multimedia/gst-plugins-good/patches/001-no_docs.patch
Normal file
20
multimedia/gst-plugins-good/patches/001-no_docs.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -9,7 +9,6 @@ endif
|
||||
ALWAYS_SUBDIRS = \
|
||||
gst sys ext \
|
||||
tests \
|
||||
- docs \
|
||||
po \
|
||||
common \
|
||||
m4 \
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -476,7 +476,6 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk
|
||||
ALWAYS_SUBDIRS = \
|
||||
gst sys ext \
|
||||
tests \
|
||||
- docs \
|
||||
po \
|
||||
common \
|
||||
m4 \
|
20
multimedia/gst-plugins-good/patches/002-no_tests.patch
Normal file
20
multimedia/gst-plugins-good/patches/002-no_tests.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -8,7 +8,6 @@ endif
|
||||
|
||||
ALWAYS_SUBDIRS = \
|
||||
gst sys ext \
|
||||
- tests \
|
||||
po \
|
||||
common \
|
||||
m4 \
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -475,7 +475,6 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk
|
||||
@USE_GCONFTOOL_TRUE@GCONF_DIR = gconf
|
||||
ALWAYS_SUBDIRS = \
|
||||
gst sys ext \
|
||||
- tests \
|
||||
po \
|
||||
common \
|
||||
m4 \
|
@ -1,15 +0,0 @@
|
||||
diff -u --recursive gst-plugins-good-0.10.17-vanilla/common/shave-libtool.in gst-plugins-good-0.10.17/common/shave-libtool.in
|
||||
--- gst-plugins-good-0.10.17-vanilla/common/shave-libtool.in 2009-12-05 18:23:04.701431715 -0500
|
||||
+++ gst-plugins-good-0.10.17/common/shave-libtool.in 2009-12-05 18:23:28.413387776 -0500
|
||||
@@ -42,11 +42,9 @@
|
||||
case "$mode" in
|
||||
compile)
|
||||
# shave will be called and print the actual CC/CXX/LINK line
|
||||
- preserved_args="$preserved_args --shave-mode=$mode"
|
||||
pass_though=1
|
||||
;;
|
||||
link)
|
||||
- preserved_args="$preserved_args --shave-mode=$mode"
|
||||
Q=" LINK "
|
||||
;;
|
||||
*)
|
Loading…
x
Reference in New Issue
Block a user