[packages] gst-plugins-base: update to 0.10.29, rework Makefile:

* rename gst-plugins-base-libgst* libraries to libgst*
 * rename gst-plugins-base-* plugins to gst-mod-*
 * add a gst-plugins-base meta-package
 * remove unneeded extra CFLAGS & LDFLAGS



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22068 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2010-07-05 01:47:30 +00:00
parent ee84687da6
commit c70a1e765f
6 changed files with 242 additions and 376 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2008-2009 OpenWrt.org
# Copyright (C) 2008-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,333 +8,201 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gst-plugins-base
PKG_VERSION:=0.10.25
PKG_VERSION:=0.10.29
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
PKG_MD5SUM:=d29669dd79276c5cd94e1613c03cd9ab
PKG_MD5SUM:=d07e251152cccbaa81807c14cf0fd8c0
PKG_BUILD_DEPENDS:= gstreamer liboil
PKG_FIXUP:=libtool
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
export PATH:=$(PKG_BUILD_DIR)/bin:$(TARGET_PATH)
define Package/gstreamer/Default
CATEGORY:=Multimedia
SECTION:=multimedia
TITLE:=GStreamer
URL:=http://gstreamer.freedesktop.org/
endef
PKG_INSTALL=1
define Package/gstreamer/description/Default
GStreamer open source multimedia framework
endef
EXTRA_CFLAGS+= \
-I$(STAGING_DIR)/usr/lib/libintl/include \
-I$(STAGING_DIR)/usr/lib/libiconv/include \
-I$(STAGING_DIR)/usr/include/gtk-2.0/gdk \
-I$(STAGING_DIR)/usr/include/gstreamer-0.10
define Package/gst-plugins-base
$(call Package/gstreamer/Default)
TITLE+= plugins collection (base)
DEPENDS+= $(GST_DEPENDS)
endef
define Package/gts-plugins-base/description
$(call Package/gstreamer/description/Default)
.
This meta package contains only dependencies to the other libraries and
plugins from the base plugins collection.
endef
GST_VERSION:=0.10
CONFIGURE_ARGS += \
--disable-debug \
--disable-examples \
\
--disable-cdparanoia \
--disable-ffmpegcolorspace \
--disable-freetypetest \
--disable-gnome_vfs \
--disable-gst_v4l \
--disable-libvisual \
--disable-oggtest \
--disable-pango \
--disable-subparse \
--disable-videorate \
--disable-videoscale \
--disable-vorbistest \
--disable-x \
--disable-xshm \
--disable-xvideo \
\
--without-libiconv-prefix \
--without-libintl-prefix \
--without-x \
\
--with-audioresample-format=int \
EXTRA_LDFLAGS+= \
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-L$(STAGING_DIR)/usr/lib/libintl/lib \
-L$(STAGING_DIR)/usr/lib/libiconv/lib
define Package/gst-plugins-base/Default
TITLE:=gst-plugins-base
URL:=http://gstreamer.freedesktop.org/
SECTION:=multimedia
CATEGORY:=Multimedia
DEPENDS:=+gstreamer +libogg
endef
define Package/gst-plugins-base-libgstapp
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstapp)
endef
define Package/gst-plugins-base-libgstapp/description
gstreamer libgstapp
endef
define Package/gst-plugins-base-libgstaudio
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstaudio)
endef
define Package/gst-plugins-base-libgstaudio/description
gstreamer libgstaudio
endef
define Package/gst-plugins-base-libgstinterfaces
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstinterfaces)
endef
define Package/gst-plugins-base-libgstinterfaces/description
gstreamer libgstinterfaces
endef
define Package/gst-plugins-base-libgstpbutils
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstpbutils)
endef
define Package/gst-plugins-base-libgstpbutils/description
gstreamer libgstpbutils
endef
define Package/gst-plugins-base-libgsttag
$(call Package/gst-plugins-base/Default)
TITLE+= (libgsttag)
endef
define Package/gst-plugins-base-libgsttag/description
gstreamer libgsttag
endef
define Package/gst-plugins-base-libgstriff
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstriff)
endef
define Package/gst-plugins-base-libgstriff/description
gstreamer libgstriff
endef
define Package/gst-plugins-base-libgstcdda
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstcdda)
endef
define Package/gst-plugins-base-libgstcdda/description
gstreamer libgstcdda
endef
define Package/gst-plugins-base-libgstfft
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstfft)
endef
define Package/gst-plugins-base-libgstfft/description
gstreamer libgstfft
endef
define Package/gst-plugins-base-libgstnetbuffer
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstnetbuffer)
endef
define Package/gst-plugins-base-libgstnetbuffer/description
gstreamer libgstnetbuffer
endef
define Package/gst-plugins-base-libgstrtp
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstrtp)
endef
define Package/gst-plugins-base-libgstrtp/description
gstreamer libgstrtp
endef
define Package/gst-plugins-base-libgstvideo
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstvideo)
endef
define Package/gst-plugins-base-libgstvideo/description
gstreamer libgstvideo
endef
define Package/gst-plugins-base-libgstvideo
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstvideo)
endef
define Package/gst-plugins-base-libgstvideo/description
gstreamer libgstvideo
endef
define Package/gst-plugins-base-libgstrtsp
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstrtsp)
endef
define Package/gst-plugins-base-libgstrtsp/description
gstreamer libgstrtsp
endef
define Package/gst-plugins-base-libgstsdp
$(call Package/gst-plugins-base/Default)
TITLE+= (libgstsdp)
endef
define Package/gst-plugins-base-libgstsdp/description
gstreamer libgstsdp
endef
define Package/gst-plugins-base-ogg
$(call Package/gst-plugins-base/Default)
TITLE+= (ogg)
DEPENDS += +liboil +gst-plugins-base-libgstriff +gst-plugins-base-libgsttag +gst-plugins-base-libgstaudio +gst-plugins-base-libgstinterfaces
endef
define Package/gst-plugins-base-ogg/description
gstreamer OGG plugins
endef
define Package/gst-plugins-base-vorbis
$(call Package/gst-plugins-base/Default)
TITLE+= (vorbis)
DEPENDS += +libvorbis +gst-plugins-base-ogg +gst-plugins-base-libgsttag +gst-plugins-base-libgstaudio +gst-plugins-base-libgstinterfaces
endef
define Package/gst-plugins-base-vorbis/description
gstreamer Vorbis plugins
endef
define Package/gst-plugins-base-theora
$(call Package/gst-plugins-base/Default)
TITLE+= (theora)
DEPENDS += +libogg +libtheora +gst-plugins-base-ogg
endef
define Package/gst-plugins-base-theora/description
gstreamer Theora plugins
endef
define Package/gst-plugins-base-alsa
$(call Package/gst-plugins-base/Default)
TITLE+= (alsa)
DEPENDS += +liboil
endef
define Package/gst-plugins-base-alsa/description
gstreamer ALSA plugins
endef
define Package/gst-plugins-base-app
$(call Package/gst-plugins-base/Default)
TITLE+= (app)
DEPENDS += +liboil +gst-plugins-base-libgstapp
endef
define Package/gst-plugins-base-app/description
gstreamer app plugins
endef
define Package/gst-plugins-base-audioconvert
$(call Package/gst-plugins-base/Default)
TITLE+= (audioconvert)
DEPENDS += +liboil +gst-plugins-base-libgstaudio +gst-plugins-base-libgstinterfaces
endef
define Package/gst-plugins-base-audioconvert/description
gstreamer audioconvert plugins
endef
define Package/gst-plugins-base-gio
$(call Package/gst-plugins-base/Default)
DEPENDS += +liboil +glib2
endef
define Package/gst-plugins-base-gio/description
gstreamer GIO plugins
endef
define Package/gst-plugins-base-typefindfunctions
$(call Package/gst-plugins-base/Default)
TITLE+= (typefind)
DEPENDS += +liboil
endef
define Package/gst-plugins-base-typefindfunctions/description
gstreamer typefind plugins
endef
define Package/gst-plugins-base-decodebin
$(call Package/gst-plugins-base/Default)
TITLE+= (decodebin)
DEPENDS += +liboil +gst-plugins-base-libgstpbutils
endef
define Package/gst-plugins-base-decodebin/description
gstreamer decodebin plugins
endef
define Build/Configure
$(call Build/Configure/Default, \
--disable-pango \
--disable-gnome_vfs \
--disable-examples \
--disable-cdparanoia \
--disable-libvisual \
--disable-oggtest \
--disable-vorbistest \
--disable-freetypetest \
--without-x \
)
mkdir -p $(PKG_BUILD_DIR)/bin
touch $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
chmod +x $(PKG_BUILD_DIR)/bin/gtkdoc-rebase
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/gstreamer-0.10/gst/
$(CP) \
$(PKG_INSTALL_DIR)/usr/include/* \
$(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib/
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} \
$(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/*.{so*,la} \
$(1)/usr/lib/gstreamer-0.10/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
$(1)/usr/lib/pkgconfig/
$(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
( cd $(PKG_INSTALL_DIR); $(CP) \
./usr/include/gstreamer-$(GST_VERSION)/* \
$(1)/usr/include/gstreamer-$(GST_VERSION)/ \
)
$(INSTALL_DIR) $(1)/usr/lib
( cd $(PKG_INSTALL_DIR); $(CP) \
./usr/lib/libgst*-$(GST_VERSION).{a,la,so*} \
$(1)/usr/lib/ \
)
$(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)
( cd $(PKG_INSTALL_DIR); $(CP) \
./usr/lib/gstreamer-$(GST_VERSION)/libgst*.{la,so} \
$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
)
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
( cd $(PKG_INSTALL_DIR); $(CP) \
./usr/lib/pkgconfig/gstreamer*-$(GST_VERSION).pc \
$(1)/usr/lib/pkgconfig/ \
)
endef
define BuildPlugin
define Package/gst-plugins-base-$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-0.10
$(CP) $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgst$(1).so \
$$(1)/usr/lib/gstreamer-0.10/
define Package/gst-plugins-base/install
/bin/true
endef
# 1: short name
# 2: description
# 3: dependencies on other gstreamer libraries (short name)
# 4: dependencies on other packages
define GstBuildLibrary
GST_DEPENDS += +libgst$(1)
define Package/libgst$(1)
$(call Package/gstreamer/Default)
TITLE+= $(2) library (base)
DEPENDS+= +libgstreamer $$(foreach p,$(3),+libgst$$(p)) $(4)
endef
$$(eval $$(call BuildPackage,gst-plugins-base-$(1)))
endef
define Package/libgst$(1)/description
$(call Package/gstreamer/description/Default)
.
This package contains the GStreamer $(2) library.
endef
define BuildLib
define Package/gst-plugins-base-libgst$(1)/install
define Package/libgst$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgst$(1)*.so* \
$$(1)/usr/lib/
( cd $(PKG_INSTALL_DIR); $(CP) \
./usr/lib/libgst$(1)-$(GST_VERSION).so.* \
$$(1)/usr/lib/ \
)
endef
$$(eval $$(call BuildPackage,gst-plugins-base-libgst$(1)))
$$(eval $$(call BuildPackage,libgst$(1)))
endef
$(eval $(call BuildLib,app))
$(eval $(call BuildLib,audio))
$(eval $(call BuildLib,interfaces))
$(eval $(call BuildLib,pbutils))
$(eval $(call BuildLib,tag))
$(eval $(call BuildLib,riff))
$(eval $(call BuildLib,cdda))
$(eval $(call BuildLib,fft))
$(eval $(call BuildLib,netbuffer))
$(eval $(call BuildLib,rtp))
$(eval $(call BuildLib,video))
$(eval $(call BuildLib,rtsp))
$(eval $(call BuildLib,sdp))
$(eval $(call GstBuildLibrary,app,app,,))
$(eval $(call GstBuildLibrary,audio,audio,interfaces,))
$(eval $(call GstBuildLibrary,cdda,CDDA,,))
$(eval $(call GstBuildLibrary,fft,FFT,,))
$(eval $(call GstBuildLibrary,interfaces,interfaces,))
$(eval $(call GstBuildLibrary,netbuffer,network buffer,,))
$(eval $(call GstBuildLibrary,pbutils,utils,,))
$(eval $(call GstBuildLibrary,riff,RIFF media,audio tag,,))
$(eval $(call GstBuildLibrary,rtp,RTP,,))
$(eval $(call GstBuildLibrary,rtsp,RTSP,,))
$(eval $(call GstBuildLibrary,sdp,SDP,,))
$(eval $(call GstBuildLibrary,tag,tag support,,))
$(eval $(call GstBuildLibrary,video,video,,))
$(eval $(call BuildPlugin,ogg))
$(eval $(call BuildPlugin,vorbis))
$(eval $(call BuildPlugin,theora))
$(eval $(call BuildPlugin,alsa))
$(eval $(call BuildPlugin,app))
$(eval $(call BuildPlugin,audioconvert))
$(eval $(call BuildPlugin,gio))
$(eval $(call BuildPlugin,typefindfunctions))
$(eval $(call BuildPlugin,decodebin))
# 1: short name
# 2: description
# 3: dependencies on other gstreamer libraries (short name)
# 4: dependencies on other gstreamer plugins (short name)
# 5: dependencies on other packages
define GstBuildPlugin
GST_DEPENDS += +gst-mod-$(1)
define Package/gst-mod-$(1)
$(call Package/gstreamer/Default)
TITLE+= $(2) plugin (base)
DEPENDS+= +libgstreamer $$(foreach p,$(3),+libgst$$(p)) $$(foreach p,$(4),+gst-mod-$$(p)) $(5)
endef
define Package/gst-mod-$(1)/description
$(call Package/gstreamer/description/Default)
.
This package contains the GStreamer $(2) plugin.
endef
define Package/gst-mod-$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION)
( cd $(PKG_INSTALL_DIR); $(CP) \
./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \
$$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
)
endef
$$(eval $$(call BuildPackage,gst-mod-$(1)))
endef
$(eval $(call GstBuildPlugin,alsa,ALSA,audio,,+alsa-lib))
$(eval $(call GstBuildPlugin,app,app,app,,))
$(eval $(call GstBuildPlugin,audioconvert,audio format conversion,audio,,))
$(eval $(call GstBuildPlugin,audiorate,audio rate adjusting,,,))
$(eval $(call GstBuildPlugin,audioresample,audio resampling,,,))
$(eval $(call GstBuildPlugin,audiotestsrc,audio test,controller,,))
$(eval $(call GstBuildPlugin,decodebin,media decoder,pbutils,,))
$(eval $(call GstBuildPlugin,decodebin2,media decoder (v2),pbutils,,))
$(eval $(call GstBuildPlugin,gio,GIO,,,))
$(eval $(call GstBuildPlugin,ogg,Ogg,riff tag,,+libogg))
$(eval $(call GstBuildPlugin,playbin,playback,interfaces pbutils,,))
$(eval $(call GstBuildPlugin,tcp,TCP,dataprotocol,,))
$(eval $(call GstBuildPlugin,theora,Theora,tag,ogg,+libtheora))
$(eval $(call GstBuildPlugin,typefindfunctions,'typefind' functions,,,))
$(eval $(call GstBuildPlugin,videotestsrc,video test,,,+liboil))
$(eval $(call GstBuildPlugin,volume,volume,audio controller,,+liboil))
$(eval $(call GstBuildPlugin,vorbis,Vorbis,audio tag,ogg,+libvorbis))
$(eval $(call BuildPackage,gst-plugins-base))

View File

@ -0,0 +1,34 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,14 +12,12 @@ SUBDIRS = \
gst sys $(SUBDIRS_EXT) \
tools \
tests \
- docs \
po \
common \
m4
DIST_SUBDIRS = \
pkgconfig \
- docs \
gst-libs \
gst sys ext \
tools \
--- a/Makefile.in
+++ b/Makefile.in
@@ -446,14 +446,12 @@ SUBDIRS = \
gst sys $(SUBDIRS_EXT) \
tools \
tests \
- docs \
po \
common \
m4
DIST_SUBDIRS = \
pkgconfig \
- docs \
gst-libs \
gst sys ext \
tools \

View File

@ -0,0 +1,36 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,6 @@ SUBDIRS = \
gst-libs \
gst sys $(SUBDIRS_EXT) \
tools \
- tests \
po \
common \
m4
@@ -21,7 +20,6 @@ DIST_SUBDIRS = \
gst-libs \
gst sys ext \
tools \
- tests \
po \
common \
m4
--- a/Makefile.in
+++ b/Makefile.in
@@ -445,7 +445,6 @@ SUBDIRS = \
gst-libs \
gst sys $(SUBDIRS_EXT) \
tools \
- tests \
po \
common \
m4
@@ -455,7 +454,6 @@ DIST_SUBDIRS = \
gst-libs \
gst sys ext \
tools \
- tests \
po \
common \
m4

View File

@ -1,19 +0,0 @@
diff -u --recursive gst-plugins-base-0.10.25-vanilla/Makefile.in gst-plugins-base-0.10.25/Makefile.in
--- gst-plugins-base-0.10.25-vanilla/Makefile.in 2009-11-14 22:55:44.146292714 -0500
+++ gst-plugins-base-0.10.25/Makefile.in 2009-11-14 22:56:11.830296238 -0500
@@ -397,7 +397,6 @@
gst-libs \
gst sys $(SUBDIRS_EXT) \
tools \
- tests \
docs \
po \
common \
@@ -409,7 +408,6 @@
gst-libs \
gst sys ext \
tools \
- tests \
po \
common \
m4

View File

@ -1,37 +0,0 @@
diff -u --recursive gst-plugins-base-0.10.25-vanilla/Makefile.am gst-plugins-base-0.10.25/Makefile.am
--- gst-plugins-base-0.10.25-vanilla/Makefile.am 2009-11-14 22:55:44.260292712 -0500
+++ gst-plugins-base-0.10.25/Makefile.am 2009-11-14 22:57:07.407292800 -0500
@@ -12,14 +12,12 @@
gst sys $(SUBDIRS_EXT) \
tools \
tests \
- docs \
po \
common \
m4
DIST_SUBDIRS = \
pkgconfig \
- docs \
gst-libs \
gst sys ext \
tools \
diff -u --recursive gst-plugins-base-0.10.25-vanilla/Makefile.in gst-plugins-base-0.10.25/Makefile.in
--- gst-plugins-base-0.10.25-vanilla/Makefile.in 2009-11-14 23:01:05.051383435 -0500
+++ gst-plugins-base-0.10.25/Makefile.in 2009-11-14 23:00:35.186350079 -0500
@@ -397,14 +397,12 @@
gst-libs \
gst sys $(SUBDIRS_EXT) \
tools \
- docs \
po \
common \
m4
DIST_SUBDIRS = \
pkgconfig \
- docs \
gst-libs \
gst sys ext \
tools \
Only in gst-plugins-base-0.10.25/: Makefile.in.orig

View File

@ -1,16 +0,0 @@
diff -u --recursive gst-plugins-base-0.10.25-vanilla/common/shave-libtool.in gst-plugins-base-0.10.25/common/shave-libtool.in
--- gst-plugins-base-0.10.25-vanilla/common/shave-libtool.in 2009-11-15 07:25:57.034292287 -0500
+++ gst-plugins-base-0.10.25/common/shave-libtool.in 2009-11-15 07:26:23.829341026 -0500
@@ -41,12 +41,9 @@
case "$mode" in
compile)
- # shave will be called and print the actual CC/CXX/LINK line
- preserved_args="$preserved_args --shave-mode=$mode"
pass_though=1
;;
link)
- preserved_args="$preserved_args --shave-mode=$mode"
Q=" LINK "
;;
*)