[packages] transmision: fixup configure, fuzz
while at it remove patch fuzz by refreshing patches fixes build warning: configure: WARNING: unrecognized options: --disable-gtk Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39199 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
aeed132f50
commit
6a59e46bea
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=transmission
|
||||
PKG_VERSION:=2.82
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
|
||||
@ -81,7 +81,7 @@ CONFIGURE_VARS += \
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-daemon \
|
||||
--enable-cli \
|
||||
--disable-gtk \
|
||||
--without-gtk \
|
||||
--enable-largefile \
|
||||
--enable-lightweight
|
||||
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -Naur transmission-2.61/libtransmission/fdlimit.c transmission-2.61-new/libtransmission/fdlimit.c
|
||||
--- transmission-2.61/libtransmission/fdlimit.c 2012-07-24 04:59:03.429474697 +0300
|
||||
+++ transmission-2.61-new/libtransmission/fdlimit.c 2012-07-31 14:40:23.999860054 +0300
|
||||
--- a/libtransmission/fdlimit.c
|
||||
+++ b/libtransmission/fdlimit.c
|
||||
@@ -25,7 +25,8 @@
|
||||
#include <fcntl.h>
|
||||
#endif
|
||||
@ -9,5 +8,5 @@ diff -Naur transmission-2.61/libtransmission/fdlimit.c transmission-2.61-new/lib
|
||||
+/* no need to define fallocate64 in glibc/eglibc case */
|
||||
+#if defined(__UCLIBC__) && (HAVE_FALLOCATE64)
|
||||
/* FIXME can't find the right #include voodoo to pick up the declaration.. */
|
||||
extern int fallocate64( int fd, int mode, uint64_t offset, uint64_t len );
|
||||
extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
|
||||
#endif
|
||||
|
Loading…
x
Reference in New Issue
Block a user