tmux: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41187 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
dd396224a6
commit
6ac63e917c
@ -1,43 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2009-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tmux
|
||||
PKG_VERSION:=1.6
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/tmux
|
||||
PKG_MD5SUM:=3e37db24aa596bf108a0442a81c845b3
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/tmux
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Terminal multiplexer
|
||||
DEPENDS:=+libncurses +libevent2 +libpthread +librt
|
||||
URL:=http://tmux.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/tmux/description
|
||||
tmux is a modern, BSD-licensed alternative to GNU screen.
|
||||
endef
|
||||
|
||||
MAKE_FLAGS += \
|
||||
PREFIX="/usr" \
|
||||
PLATFORM="linux"
|
||||
|
||||
define Package/tmux/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tmux $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,tmux))
|
@ -1,41 +0,0 @@
|
||||
Index: tmux-1.6/compat.h
|
||||
===================================================================
|
||||
--- tmux-1.6.orig/compat.h
|
||||
+++ tmux-1.6/compat.h
|
||||
@@ -198,7 +198,9 @@ int daemon(int, int);
|
||||
|
||||
#ifndef HAVE_B64_NTOP
|
||||
/* b64_ntop.c */
|
||||
-int b64_ntop(const char *, size_t, char *, size_t);
|
||||
+int local_b64_ntop(const char *, size_t, char *, size_t);
|
||||
+#else
|
||||
+#define local_b64_ntop b64_ntop
|
||||
#endif
|
||||
|
||||
#ifndef HAVE_FORKPTY
|
||||
Index: tmux-1.6/compat/b64_ntop.c
|
||||
===================================================================
|
||||
--- tmux-1.6.orig/compat/b64_ntop.c
|
||||
+++ tmux-1.6/compat/b64_ntop.c
|
||||
@@ -122,7 +122,7 @@ static const char Pad64 = '=';
|
||||
*/
|
||||
|
||||
int
|
||||
-b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
|
||||
+local_b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
|
||||
size_t datalength = 0;
|
||||
uint8_t input[3];
|
||||
uint8_t output[4];
|
||||
Index: tmux-1.6/tty.c
|
||||
===================================================================
|
||||
--- tmux-1.6.orig/tty.c
|
||||
+++ tmux-1.6/tty.c
|
||||
@@ -1006,7 +1006,7 @@ tty_cmd_setselection(struct tty *tty, co
|
||||
off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
|
||||
buf = xmalloc(off);
|
||||
|
||||
- b64_ntop(ctx->ptr, ctx->num, buf, off);
|
||||
+ local_b64_ntop(ctx->ptr, ctx->num, buf, off);
|
||||
tty_putcode_ptr2(tty, TTYC_MS, "", buf);
|
||||
|
||||
xfree(buf);
|
Loading…
x
Reference in New Issue
Block a user