batman-adv: update package to lastest bugfix release (2011.3.1)
Signed-off-by: Marek Lindner <lindner_marek@yahoo.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@28490 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3406488bb1
commit
6afaef31c0
@ -10,15 +10,16 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=batman-adv
|
||||
|
||||
PKG_VERSION:=2011.3.0
|
||||
PKG_MD5SUM:=0ba4b63f7fe9d2a561662cdc0378caa5
|
||||
PKG_VERSION:=2011.3.1
|
||||
BATCTL_VERSION:=2011.3.0
|
||||
PKG_MD5SUM:=54a5caff56a8380f3070111ce84bbfc4
|
||||
BATCTL_MD5SUM:=8eb197896049bb04a6beef56015a16b6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_TOOL_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/batctl-$(PKG_VERSION)
|
||||
PKG_TOOL_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/batctl-$(BATCTL_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
@ -67,13 +68,13 @@ MAKE_BATCTL_ARGS += \
|
||||
|
||||
ifneq ($(DEVELOPER)$(CONFIG_KMOD_BATMAN_ADV_BATCTL),)
|
||||
define Download/batctl
|
||||
FILE:=batctl-$(PKG_VERSION).tar.gz
|
||||
FILE:=batctl-$(BATCTL_VERSION).tar.gz
|
||||
URL:=$(PKG_SOURCE_URL)
|
||||
MD5SUM:=$(BATCTL_MD5SUM)
|
||||
endef
|
||||
$(eval $(call Download,batctl))
|
||||
|
||||
EXTRACT_BATCTL = tar xzf "$(DL_DIR)/batctl-$(PKG_VERSION).tar.gz" -C "$(BUILD_DIR)/$(PKG_NAME)"
|
||||
EXTRACT_BATCTL = tar xzf "$(DL_DIR)/batctl-$(BATCTL_VERSION).tar.gz" -C "$(BUILD_DIR)/$(PKG_NAME)"
|
||||
PATCH_BATCTL = $(call Build/DoPatch,"$(PKG_BATCTL_BUILD_DIR)","$(PATCH_DIR)","*batctl*")
|
||||
BUILD_BATCTL = $(MAKE) -C $(PKG_TOOL_BUILD_DIR) $(MAKE_BATCTL_ARGS)
|
||||
endif
|
||||
|
@ -1,36 +0,0 @@
|
||||
From: Antonio Quartulli <ordex@autistici.org>
|
||||
|
||||
In the TT_RESPONSE packet, the number of carried entries is not correctly set.
|
||||
This leads to a wrong interpretation of the packet payload on the receiver side
|
||||
causing random entries to be added to the global translation table. Therefore
|
||||
the latter gets always corrupted, triggering a table recovery all the time.
|
||||
|
||||
Signed-off-by: Antonio Quartulli <ordex@autistici.org>
|
||||
---
|
||||
translation-table.c | 5 ++++-
|
||||
1 files changed, 4 insertions(+), 1 deletions(-)
|
||||
|
||||
--- a/translation-table.c
|
||||
+++ b/translation-table.c
|
||||
@@ -1054,7 +1054,6 @@ static struct sk_buff *tt_response_fill_table(uint16_t tt_len, uint8_t ttvn,
|
||||
tt_response = (struct tt_query_packet *)skb_put(skb,
|
||||
tt_query_size + tt_len);
|
||||
tt_response->ttvn = ttvn;
|
||||
- tt_response->tt_data = htons(tt_tot);
|
||||
|
||||
tt_change = (struct tt_change *)(skb->data + tt_query_size);
|
||||
tt_count = 0;
|
||||
@@ -1080,6 +1079,10 @@ static struct sk_buff *tt_response_fill_table(uint16_t tt_len, uint8_t ttvn,
|
||||
}
|
||||
rcu_read_unlock();
|
||||
|
||||
+ /* store in the message the number of entries we have successfully
|
||||
+ * copied */
|
||||
+ tt_response->tt_data = htons(tt_count);
|
||||
+
|
||||
out:
|
||||
return skb;
|
||||
}
|
||||
--
|
||||
1.7.3.4
|
||||
|
@ -1,49 +0,0 @@
|
||||
From: Antonio Quartulli <ordex@autistici.org>
|
||||
|
||||
corrects a critical bug of the GW feature. This bug made all the unicast
|
||||
packets destined to a GW to be sent as broadcast. This bug is present even if
|
||||
the sender GW feature is configured as OFF. It's an urgent bug fix and should
|
||||
be committed as soon as possible.
|
||||
|
||||
This was a regression introduced by 43676ab590c3f8686fd047d34c3e33803eef71f0
|
||||
|
||||
Signed-off-by: Antonio Quartulli <ordex@autistici.org>
|
||||
Signed-off-by: Marek Lindner <lindner_marek@yahoo.de>
|
||||
---
|
||||
soft-interface.c | 10 +++++-----
|
||||
1 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
--- a/soft-interface.c
|
||||
+++ b/soft-interface.c
|
||||
@@ -565,7 +565,7 @@ static int interface_tx(struct sk_buff *skb, struct net_device *soft_iface)
|
||||
struct orig_node *orig_node = NULL;
|
||||
int data_len = skb->len, ret;
|
||||
short vid = -1;
|
||||
- bool do_bcast = false;
|
||||
+ bool do_bcast;
|
||||
|
||||
if (atomic_read(&bat_priv->mesh_state) != MESH_ACTIVE)
|
||||
goto dropped;
|
||||
@@ -598,15 +598,15 @@ static int interface_tx(struct sk_buff *skb, struct net_device *soft_iface)
|
||||
tt_local_add(soft_iface, ethhdr->h_source);
|
||||
|
||||
orig_node = transtable_search(bat_priv, ethhdr->h_dest);
|
||||
- if (is_multicast_ether_addr(ethhdr->h_dest) ||
|
||||
- (orig_node && orig_node->gw_flags)) {
|
||||
+ do_bcast = is_multicast_ether_addr(ethhdr->h_dest);
|
||||
+ if (do_bcast || (orig_node && orig_node->gw_flags)) {
|
||||
ret = gw_is_target(bat_priv, skb, orig_node);
|
||||
|
||||
if (ret < 0)
|
||||
goto dropped;
|
||||
|
||||
- if (ret == 0)
|
||||
- do_bcast = true;
|
||||
+ if (ret)
|
||||
+ do_bcast = false;
|
||||
}
|
||||
|
||||
/* ethernet packet should be broadcasted */
|
||||
--
|
||||
1.7.5.4
|
||||
|
@ -1,29 +0,0 @@
|
||||
From: Antonio Quartulli <ordex@autistici.org>
|
||||
|
||||
Currently the counter of tt_local_entry structures (tt_local_num) is incremented
|
||||
each time the tt_local_reset_flags() is invoked causing the node to send wrong
|
||||
TT_REPONSE packets containing a copy of non-initialised memory thus corrupting
|
||||
other nodes global translation table and making higher level communication
|
||||
impossible.
|
||||
|
||||
Reported-by: Junkeun Song <jun361@gmail.com>
|
||||
Signed-off-by: Antonio Quartulli <ordex@autistici.org>
|
||||
Acked-by: Junkeun Song <jun361@gmail.com>
|
||||
---
|
||||
translation-table.c | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
--- a/translation-table.c
|
||||
+++ b/translation-table.c
|
||||
@@ -1727,6 +1727,8 @@ static void tt_local_reset_flags(struct bat_priv *bat_priv, uint16_t flags)
|
||||
rcu_read_lock();
|
||||
hlist_for_each_entry_rcu(tt_local_entry, node,
|
||||
head, hash_entry) {
|
||||
+ if (!(tt_local_entry->flags & flags))
|
||||
+ continue;
|
||||
tt_local_entry->flags &= ~flags;
|
||||
atomic_inc(&bat_priv->num_local_tt);
|
||||
}
|
||||
--
|
||||
1.7.3.4
|
||||
|
Loading…
x
Reference in New Issue
Block a user