net/click: update to today's git, add a fix patch.
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23550 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
dc853615cc
commit
6db6a4345b
@ -8,16 +8,16 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=click
|
||||
PKG_VERSION:=20101002
|
||||
PKG_VERSION:=20101020
|
||||
PKG_RELEASE:=1
|
||||
PKG_REV:=04f9a6ea146793881caa6b1721872a92d8c2ddcf
|
||||
PKG_REV:=8f521a2dcd58ea8205b3b6070be605a21fb9154b
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=git://read.cs.ucla.edu/git/click
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_MD5SUM:=e2f144265b5b61804b0634bf567bee5b
|
||||
PKG_MD5SUM:=c3cba1c923d0a034cc518720b5ba7b40
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -39,18 +39,11 @@ TARGET_CXXFLAGS += "-static -O2 -MD"
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
rm -rf config.{cache,status} ; \
|
||||
"./configure \
|
||||
--prefix=/usr \
|
||||
--enable-userlevel \
|
||||
--enable-wifi \
|
||||
--enable-fixincludes \
|
||||
--disable-linuxmodule" ; \
|
||||
rm -rf config.{cache,status} ; \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--host=$(GNU_HOST_NAME) \
|
||||
--build=$(GNU_BUILD_NAME) \
|
||||
--enable-tools=mixed \
|
||||
--enable-userlevel \
|
||||
--enable-wifi \
|
||||
|
12
net/click/patches/110-multithread_fix.patch
Normal file
12
net/click/patches/110-multithread_fix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/lib/master.cc
|
||||
+++ b/lib/master.cc
|
||||
@@ -409,7 +409,9 @@ Master::process_pending(RouterThread *th
|
||||
while (Task *t = Task::pending_to_task(my_pending)) {
|
||||
my_pending = t->_pending_nextptr;
|
||||
t->_pending_nextptr = 0;
|
||||
+# if HAVE_MULTITHREAD
|
||||
click_master_mb();
|
||||
+# endif
|
||||
t->process_pending(thread);
|
||||
}
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user