packages: libdaemon: prevent an erroneous error message
Signed-off-by: Michael Heimpold <mhei@heimpold.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39418 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6469bc1c61
commit
7597bb13da
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libdaemon
|
||||
PKG_VERSION:=0.14
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://0pointer.de/lennart/projects/libdaemon/
|
||||
|
30
libs/libdaemon/patches/001-daemon_set_verbosity.patch
Normal file
30
libs/libdaemon/patches/001-daemon_set_verbosity.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 013963ba35e8fe8897211c0acf5ee98f9a871fc1 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Heimpold <mhei@heimpold.de>
|
||||
Date: Fri, 10 Jan 2014 19:38:51 +0100
|
||||
Subject: [PATCH] daemon_set_verbosity: fix erroneous error message
|
||||
|
||||
When calling this function with a value other than LOG_DEBUG
|
||||
the error message was triggered erroneously.
|
||||
|
||||
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
|
||||
---
|
||||
|
||||
libdaemon/dlog.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libdaemon/dlog.c b/libdaemon/dlog.c
|
||||
index 1cc0566..cc2b918 100644
|
||||
--- a/libdaemon/dlog.c
|
||||
+++ b/libdaemon/dlog.c
|
||||
@@ -42,7 +42,7 @@ static int daemon_verbosity_level = LOG_INFO;
|
||||
void daemon_set_verbosity(int verbosity_prio) {
|
||||
|
||||
/* Allow using negative verbosity levels to hide _all_ messages */
|
||||
- if (verbosity_prio > 0 && (verbosity_prio & LOG_PRIMASK) != LOG_PRIMASK)
|
||||
+ if (verbosity_prio > 0 && (verbosity_prio & LOG_PRIMASK) != verbosity_prio)
|
||||
daemon_log(LOG_ERR, "The value %d is not a valid priority value", verbosity_prio);
|
||||
|
||||
daemon_verbosity_level = verbosity_prio & LOG_PRIMASK;
|
||||
--
|
||||
1.7.10.4
|
||||
|
Loading…
x
Reference in New Issue
Block a user