libdbi: update libdbi to 0.9.0

Signed-off-by: Gerald Matzka <mgerald21@yahoo.de>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@40602 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2014-04-29 21:58:47 +00:00
parent 0b54272ef4
commit 75afd389eb
3 changed files with 8 additions and 72 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libdbi
PKG_VERSION:=0.8.3
PKG_RELEASE:=3
PKG_VERSION:=0.9.0
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/libdbi
PKG_MD5SUM:=ca66db78d479cbfa727cf3245b5864ae
PKG_MD5SUM:=05e2ceeac4bc85fbe40de8b4b22d9ab3
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@ -32,6 +32,11 @@ define Package/libdbi/description
libdbi implements a database-independent abstraction layer in C.
endef
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-docs
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/dbi $(1)/usr/include/

View File

@ -1,24 +0,0 @@
diff -urN libdbi-0.8.3/Makefile.am libdbi-0.8.3.new/Makefile.am
--- libdbi-0.8.3/Makefile.am 2006-05-18 22:27:50.000000000 +0200
+++ libdbi-0.8.3.new/Makefile.am 2009-01-09 00:06:34.000000000 +0100
@@ -2,7 +2,7 @@
AUTOMAKE_OPTIONS = foreign dist-zip
-SUBDIRS = src include @docs_subdirs@
+SUBDIRS = src include
EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README README.win32 README.osx TODO NEWS libdbi.spec.in config.h.in Makefile.w32 autogen.sh drivers/example/AUTHORS drivers/example/Makefile.am drivers/example/README drivers/example/TODO drivers/example/.cvsignore drivers/example/dbd_example.c drivers/example/dbd_example.h drivers/example/dbd_example.sgml
diff -urN libdbi-0.8.3/Makefile.in libdbi-0.8.3.new/Makefile.in
--- libdbi-0.8.3/Makefile.in 2008-02-06 20:40:10.000000000 +0100
+++ libdbi-0.8.3.new/Makefile.in 2009-01-09 00:06:28.000000000 +0100
@@ -180,7 +180,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
AUTOMAKE_OPTIONS = foreign dist-zip
-SUBDIRS = src include @docs_subdirs@
+SUBDIRS = src include
EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README README.win32 README.osx TODO NEWS libdbi.spec.in config.h.in Makefile.w32 autogen.sh drivers/example/AUTHORS drivers/example/Makefile.am drivers/example/README drivers/example/TODO drivers/example/.cvsignore drivers/example/dbd_example.c drivers/example/dbd_example.h drivers/example/dbd_example.sgml
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive

View File

@ -1,45 +0,0 @@
--- libdbi-0.8.3/configure.in 2014-03-06 14:04:14.708630767 -0800
+++ libdbi-0.8.3/configure.in 2014-03-06 14:04:53.229096958 -0800
@@ -32,42 +32,6 @@
dnl Set some general compile options
dnl ====================================
-if test -z "$GCC"; then
- case $host in
- *-*-irix*)
- if test -z "$CC"; then
- CC=cc
- fi
- DEBUG="-g -signed"
- CFLAGS="-O2 -w -signed"
- PROFILE="-p -g3 -O2 -signed" ;;
- sparc-sun-solaris*)
- DEBUG="-v -g"
- CFLAGS="-xO4 -fast -w -fsimple -native -xcg92"
- PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
- *)
- DEBUG="-g"
- CFLAGS="-O"
- PROFILE="-g -p" ;;
- esac
-else
-
- case $host in
- *-*-linux*)
- DEBUG="-g -Wall -D_REENTRANT -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
- CFLAGS="-O20 -ffast-math -D_REENTRANT -fsigned-char -std=gnu99"
- PROFILE="-pg -g -O20 -ffast-math -D_REENTRANT -fsigned-char -std=gnu99";;
- sparc-sun-*)
- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99"
- CFLAGS="-O20 -ffast-math -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99"
- PROFILE="-pg -g -O20 -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99" ;;
- *)
- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char -std=gnu99" ;;
- esac
-fi
-
AC_SUBST(DEBUG)
AC_SUBST(PROFILE)