[package] update vsftpd to 2.1.0 (#4694)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@15148 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-04-08 10:14:02 +00:00
parent aa10cb0781
commit 75e83ca7d2
4 changed files with 13 additions and 54 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=vsftpd
PKG_VERSION:=2.0.6
PKG_RELEASE:=2
PKG_VERSION:=2.1.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
PKG_MD5SUM:=f7a742690d7f86e356fb66d3840079c7
PKG_MD5SUM:=7890b54e7ffa6106ffbdfda53f47fa41
include $(INCLUDE_DIR)/package.mk

View File

@ -1,13 +1,13 @@
Index: vsftpd-2.0.6/tunables.c
===================================================================
--- vsftpd-2.0.6.orig/tunables.c 2008-04-13 11:41:08.000000000 +0200
+++ vsftpd-2.0.6/tunables.c 2008-04-13 11:41:09.000000000 +0200
@@ -100,7 +100,7 @@
/* -rw------- */
unsigned int tunable_chown_upload_mode = 0600;
--- vsftpd-2.1.0.orig/tunables.c 2008-04-13 11:41:08.000000000 +0200
+++ vsftpd-2.1.0/tunables.c 2008-04-13 11:41:09.000000000 +0200
@@ -242,7 +242,7 @@
/* -rw------- */
tunable_chown_upload_mode = 0600;
-const char* tunable_secure_chroot_dir = "/usr/share/empty";
+const char* tunable_secure_chroot_dir = "/var/run/vsftpd";
const char* tunable_ftp_username = "ftp";
const char* tunable_chown_username = "root";
const char* tunable_xferlog_file = "/var/log/xferlog";
- install_str_setting("/usr/share/empty", &tunable_secure_chroot_dir);
+ install_str_setting("/var/run/vsftpd", &tunable_secure_chroot_dir);
install_str_setting("ftp", &tunable_ftp_username);
install_str_setting("root", &tunable_chown_username);
install_str_setting("/var/log/xferlog", &tunable_xferlog_file);

View File

@ -1,12 +0,0 @@
Index: vsftpd-2.0.6/sysdeputil.c
===================================================================
--- vsftpd-2.0.6.orig/sysdeputil.c 2008-04-13 11:41:08.000000000 +0200
+++ vsftpd-2.0.6/sysdeputil.c 2008-04-13 11:41:09.000000000 +0200
@@ -159,7 +159,6 @@
#include <linux/capability.h>
#include <errno.h>
#include <syscall.h>
-_syscall2(int, capset, cap_user_header_t, header, const cap_user_data_t, data)
/* Gross HACK to avoid warnings - linux headers overlap glibc headers */
#undef __NFDBITS
#undef __FDMASK

View File

@ -1,29 +0,0 @@
Fix errors below when built with gcc-4.1.2
sysutil.c: In function 'vsf_sysutil_wait_exited_normally':
sysutil.c:604: error: assignment of read-only member '__in'
sysutil.c: In function 'vsf_sysutil_wait_get_exitcode':
sysutil.c:614: error: assignment of read-only member '__in'
Index: vsftpd-2.0.6/sysutil.c
===================================================================
--- vsftpd-2.0.6.orig/sysutil.c 2008-04-13 11:41:08.000000000 +0200
+++ vsftpd-2.0.6/sysutil.c 2008-04-13 11:41:09.000000000 +0200
@@ -601,7 +601,7 @@
vsf_sysutil_wait_exited_normally(
const struct vsf_sysutil_wait_retval* p_waitret)
{
- return WIFEXITED(p_waitret->exit_status);
+ return WIFEXITED(((struct vsf_sysutil_wait_retval *)p_waitret)->exit_status);
}
int
@@ -611,7 +611,7 @@
{
bug("not a normal exit in vsf_sysutil_wait_get_exitcode");
}
- return WEXITSTATUS(p_waitret->exit_status);
+ return WEXITSTATUS(((struct vsf_sysutil_wait_retval *)p_waitret)->exit_status);
}
void