[package] dbus: update to 1.4.14
This bumps dbus in the packages repository to 1.4.14. It also requires librt now due to clock function usage. It also supports systemd and launchd now. Signed-off-by: Daniel Mierswa <impulze@impulze.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@28015 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
93fb9e05b0
commit
76a99e5612
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
# Make sure to also update the dbus-x package
|
# Make sure to also update the dbus-x package
|
||||||
PKG_NAME:=dbus
|
PKG_NAME:=dbus
|
||||||
PKG_VERSION:=1.2.4.6permissive
|
PKG_VERSION:=1.4.14
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
|
PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
|
||||||
PKG_MD5SUM:=1a158fe326b078d1377a977121888496
|
PKG_MD5SUM:=ae6de2562a57516cfabaf56903375ba9
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
@ -54,7 +54,7 @@ endef
|
|||||||
define Package/dbus
|
define Package/dbus
|
||||||
$(call Package/dbus/Default)
|
$(call Package/dbus/Default)
|
||||||
TITLE+= (daemon)
|
TITLE+= (daemon)
|
||||||
DEPENDS:= +libexpat +libdbus
|
DEPENDS:= +libexpat +libdbus +librt
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dbus/Description
|
define Package/dbus/Description
|
||||||
@ -87,7 +87,7 @@ CONFIGURE_ARGS += \
|
|||||||
--disable-asserts \
|
--disable-asserts \
|
||||||
--disable-console-owner-file \
|
--disable-console-owner-file \
|
||||||
--disable-doxygen-docs \
|
--disable-doxygen-docs \
|
||||||
--disable-gcov \
|
--disable-compiler_coverage \
|
||||||
--disable-selinux \
|
--disable-selinux \
|
||||||
--disable-tests \
|
--disable-tests \
|
||||||
--disable-verbose-mode \
|
--disable-verbose-mode \
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -urN dbus-1.2.4.6permissive/configure dbus-1.2.4.6permissive.new/configure
|
|
||||||
--- dbus-1.2.4.6permissive/configure 2009-05-06 19:35:38.000000000 +0200
|
|
||||||
+++ dbus-1.2.4.6permissive.new/configure 2010-03-26 17:40:13.000000000 +0100
|
|
||||||
@@ -20958,7 +20958,7 @@
|
|
||||||
esac
|
|
||||||
case " $CFLAGS " in
|
|
||||||
*[\ \ ]-Wno-pointer-sign[\ \ ]*) ;;
|
|
||||||
- *) CFLAGS="$CFLAGS -Wno-pointer-sign" ;;
|
|
||||||
+ *) CFLAGS="$CFLAGS" ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
# http://bugs.freedesktop.org/show_bug.cgi?id=19195
|
|
@ -1,22 +0,0 @@
|
|||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -20927,19 +20927,6 @@ if test "x$GCC" = "xyes"; then
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
- case " $CFLAGS " in
|
|
||||||
- *[\ \ ]-fPIE[\ \ ]*) ;;
|
|
||||||
- *) if cc_supports_flag -fPIE; then
|
|
||||||
- PIE_CFLAGS="-fPIE"
|
|
||||||
- if ld_supports_flag -z,relro; then
|
|
||||||
- PIE_LDFLAGS="-pie -Wl,-z,relro"
|
|
||||||
- else
|
|
||||||
- PIE_LDFLAGS="-pie"
|
|
||||||
- fi
|
|
||||||
- fi
|
|
||||||
- ;;
|
|
||||||
- esac
|
|
||||||
-
|
|
||||||
### Disabled warnings, and compiler flag overrides
|
|
||||||
|
|
||||||
# Let's just ignore unused for now
|
|
Loading…
x
Reference in New Issue
Block a user