[package] bind: update to 9.8.0-P4
Signed-off-by: Alexey I. Froloff <raorn@altlinux.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@28014 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7f60b73795
commit
93fb9e05b0
@ -8,14 +8,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bind
|
||||
PKG_VERSION:=9.7.2-P3
|
||||
PKG_VERSION:=9.8.0-P4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= \
|
||||
ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
||||
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=b4537cbae38b2daef36775bf49f33db9
|
||||
PKG_MD5SUM:=13e36e3f28dc1ce7675b45a4192e8389
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
|
13
net/bind/patches/100-configure-GOST.patch
Normal file
13
net/bind/patches/100-configure-GOST.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- a/configure.in 2011-06-29 19:14:25.053420788 +0400
|
||||
+++ b/configure.in 2011-06-29 19:26:34.860280457 +0400
|
||||
@@ -699,7 +699,9 @@
|
||||
[AC_MSG_RESULT(yes)
|
||||
have_gost="yes"],
|
||||
[AC_MSG_RESULT(no)
|
||||
- have_gost="no"])
|
||||
+ have_gost="no"],
|
||||
+ [AC_MSG_RESULT(assuming target platform has no GOST support)
|
||||
+ have_gost="no"])
|
||||
case $have_gost in
|
||||
yes)
|
||||
OPENSSL_GOST="yes"
|
@ -1,96 +0,0 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -22418,8 +22418,7 @@ $as_echo_n "checking epoll support... "
|
||||
{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
See \`config.log' for more details." >&5
|
||||
$as_echo "$as_me: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+See \`config.log' for more details." >&2;} }
|
||||
else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
@@ -24275,8 +24274,7 @@ if { as_var=$as_ac_File; eval "test \"\$
|
||||
else
|
||||
test "$cross_compiling" = yes &&
|
||||
{ { $as_echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-$as_echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+$as_echo "$as_me: error: cannot check for file existence when cross compiling" >&2;} }
|
||||
if test -r "$devrandom"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -27949,73 +27947,6 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
# which provides some (all?) of the desired functions.
|
||||
#
|
||||
|
||||
-{ $as_echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
|
||||
-$as_echo_n "checking for inet_ntop with IPv6 support... " >&6; }
|
||||
-if test "$cross_compiling" = yes; then
|
||||
- { $as_echo "$as_me:$LINENO: result: assuming inet_ntop needed" >&5
|
||||
-$as_echo "assuming inet_ntop needed" >&6; }
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||
-else
|
||||
- cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
-cat >>conftest.$ac_ext <<_ACEOF
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-#include <sys/types.h>
|
||||
-#include <sys/socket.h>
|
||||
-#include <netinet/in.h>
|
||||
-#include <arpa/inet.h>
|
||||
-main() {
|
||||
-char a[16],b[64]; return(inet_ntop(AF_INET6, a, b, sizeof(b)) == (char*)0);}
|
||||
-_ACEOF
|
||||
-rm -f conftest$ac_exeext
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo") >&5
|
||||
- (eval "$ac_link") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
||||
- { (case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo") >&5
|
||||
- (eval "$ac_try") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
- { $as_echo "$as_me:$LINENO: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
|
||||
-else
|
||||
- $as_echo "$as_me: program exited with status $ac_status" >&5
|
||||
-$as_echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-( exit $ac_status )
|
||||
-{ $as_echo "$as_me:$LINENO: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||
-fi
|
||||
-rm -rf conftest.dSYM
|
||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
# On NetBSD 1.4.2 and maybe others, inet_pton() incorrectly accepts
|
||||
# addresses with less than four octets, like "1.2.3". Also leading
|
||||
# zeros should also be rejected.
|
Loading…
x
Reference in New Issue
Block a user