[package] zaptel: Package for wcusb and wctdm driver
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21786 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
2ac3ae13af
commit
76e267a9ef
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=zaptel
|
||||
PKG_VERSION:=1.4.12.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/zaptel/releases/ \
|
||||
@ -24,13 +24,18 @@ define Package/zaptel14/Default
|
||||
URL:=http://ftp.digium.com/pub/zaptel/releases
|
||||
endef
|
||||
|
||||
define KernelPackage/zaptel14
|
||||
$(call Package/zaptel14/Default)
|
||||
define KernelPackage/zaptel14/Default
|
||||
TITLE:=Zaptel (kernel module)
|
||||
SUBMENU:=Other modules
|
||||
TITLE+= (kernel module)
|
||||
endef
|
||||
|
||||
define KernelPackage/zaptel14
|
||||
$(call KernelPackage/zaptel14/Default)
|
||||
KCONFIG:=CONFIG_FTRACE=y \
|
||||
CONFIG_TRACING \
|
||||
CONFIG_KMEMTRACE
|
||||
CONFIG_TRACING=y \
|
||||
CONFIG_KMEMTRACE=y \
|
||||
BRANCH_PROFILE_NONE=y \
|
||||
RING_BUFFER_BENCHMARK=n \
|
||||
FILES:=$(PKG_BUILD_DIR)/kernel/zaptel.$(LINUX_KMOD_SUFFIX) \
|
||||
$(PKG_BUILD_DIR)/kernel/ztdummy.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,70,zaptel ztdummy)
|
||||
@ -40,6 +45,28 @@ define KernelPackage/zaptel14/description
|
||||
This package contains the Zaptel core module and ztdummy driver.
|
||||
endef
|
||||
|
||||
define KernelPackage/zaptel14-wcusb
|
||||
$(call KernelPackage/zaptel14/Default)
|
||||
DEPENDS += +kmod-zaptel14
|
||||
FILES:=$(PKG_BUILD_DIR)/kernel/wcusb.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,71,wcusb)
|
||||
endef
|
||||
|
||||
define KernelPackage/zaptel14-wcusb/description
|
||||
This package contains the Zaptel S100U usb driver.
|
||||
endef
|
||||
|
||||
define KernelPackage/zaptel14-wctdm
|
||||
$(call KernelPackage/zaptel14/Default)
|
||||
DEPENDS += +kmod-zaptel14
|
||||
FILES:=$(PKG_BUILD_DIR)/kernel/wctdm.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,71,wctdm)
|
||||
endef
|
||||
|
||||
define KernelPackage/zaptel14-wctdm/description
|
||||
This package contains the Zaptel wctdm driver.
|
||||
endef
|
||||
|
||||
define Package/zaptel14-util
|
||||
$(call Package/zaptel14/Default)
|
||||
SECTION:=utils
|
||||
@ -49,7 +76,7 @@ define Package/zaptel14-util
|
||||
endef
|
||||
|
||||
define Package/zaptel14-util/description
|
||||
This package contains the zttest program
|
||||
This package contains the zaptel utils.
|
||||
endef
|
||||
|
||||
define Package/zaptel14-libtonezone
|
||||
@ -71,7 +98,7 @@ MAKE_FLAGS:= \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
KVERS="$(LINUX_VERSION)" \
|
||||
KSRC="$(LINUX_DIR)" \
|
||||
TOPDIR_MODULES="zaptel ztdummy" \
|
||||
TOPDIR_MODULES="zaptel ztdummy wcusb wctdm" \
|
||||
SUBDIR_MODULES=""
|
||||
|
||||
define Build/Compile/kmod
|
||||
@ -110,5 +137,7 @@ define Package/zaptel14-libtonezone/install
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,zaptel14))
|
||||
$(eval $(call KernelPackage,zaptel14-wcusb))
|
||||
$(eval $(call KernelPackage,zaptel14-wctdm))
|
||||
$(eval $(call BuildPackage,zaptel14-util))
|
||||
$(eval $(call BuildPackage,zaptel14-libtonezone))
|
||||
|
@ -11,16 +11,4 @@ Index: zaptel-1.4.12.1/kernel/zconfig.h
|
||||
#else
|
||||
#include <linux/autoconf.h>
|
||||
#endif
|
||||
Index: zaptel-1.4.12.1/kernel/ztdummy.c
|
||||
===================================================================
|
||||
--- zaptel-1.4.12.1.orig/kernel/ztdummy.c 2010-06-13 08:58:02.000000000 +0200
|
||||
+++ zaptel-1.4.12.1/kernel/ztdummy.c 2010-06-13 08:58:23.000000000 +0200
|
||||
@@ -38,6 +38,7 @@
|
||||
*/
|
||||
|
||||
#include <linux/version.h>
|
||||
+#include <linux/slab.h>
|
||||
|
||||
#ifndef VERSION_CODE
|
||||
# define VERSION_CODE(vers,rel,seq) ( ((vers)<<16) | ((rel)<<8) | (seq) )
|
||||
|
||||
|
38
libs/zaptel-1.4.x/patches/360-slab.patch
Normal file
38
libs/zaptel-1.4.x/patches/360-slab.patch
Normal file
@ -0,0 +1,38 @@
|
||||
Index: zaptel-1.4.12.1/kernel/wctdm.c
|
||||
===================================================================
|
||||
--- zaptel-1.4.12.1.orig/kernel/wctdm.c 2010-06-13 12:11:26.000000000 +0200
|
||||
+++ zaptel-1.4.12.1/kernel/wctdm.c 2010-06-13 12:17:47.000000000 +0200
|
||||
@@ -30,6 +30,8 @@
|
||||
#include <linux/errno.h>
|
||||
#include <linux/pci.h>
|
||||
#include <linux/interrupt.h>
|
||||
+#include <linux/slab.h>
|
||||
+#include <linux/sched.h>
|
||||
#include <asm/io.h>
|
||||
#include "proslic.h"
|
||||
#include "wctdm.h"
|
||||
Index: zaptel-1.4.12.1/kernel/wcusb.c
|
||||
===================================================================
|
||||
--- zaptel-1.4.12.1.orig/kernel/wcusb.c 2010-06-13 12:10:07.000000000 +0200
|
||||
+++ zaptel-1.4.12.1/kernel/wcusb.c 2010-06-13 12:10:13.000000000 +0200
|
||||
@@ -37,6 +37,7 @@
|
||||
#include <linux/init.h>
|
||||
#include <linux/usb.h>
|
||||
#include <linux/errno.h>
|
||||
+#include <linux/slab.h>
|
||||
|
||||
#include <linux/version.h>
|
||||
#if LINUX_VERSION_CODE > KERNEL_VERSION(2,4,19)
|
||||
Index: zaptel-1.4.12.1/kernel/ztdummy.c
|
||||
===================================================================
|
||||
--- zaptel-1.4.12.1.orig/kernel/ztdummy.c 2010-06-13 08:58:02.000000000 +0200
|
||||
+++ zaptel-1.4.12.1/kernel/ztdummy.c 2010-06-13 08:58:23.000000000 +0200
|
||||
@@ -38,6 +38,7 @@
|
||||
*/
|
||||
|
||||
#include <linux/version.h>
|
||||
+#include <linux/slab.h>
|
||||
|
||||
#ifndef VERSION_CODE
|
||||
# define VERSION_CODE(vers,rel,seq) ( ((vers)<<16) | ((rel)<<8) | (seq) )
|
||||
|
Loading…
x
Reference in New Issue
Block a user