Update Bemusedlinuxserver to latest version. Signed-off-by: Michael Vogt <michu at neophob.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11066 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a931d77737
commit
777f023a66
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bemused-mpd
|
||||
PKG_VERSION:=r047
|
||||
PKG_VERSION:=r059
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/382
|
||||
PKG_MD5SUM:=f40715812d59d2ab1bd93f96c5e8818b
|
||||
PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/512
|
||||
PKG_MD5SUM:=76cb208842cce784fd65ec4d392fd6cb
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/bemusedlinuxserver
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp
|
||||
DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp +libiconv
|
||||
TITLE:=Bemused linux server
|
||||
URL:=http://bemused-lnx-mpdhack.origo.ethz.ch/
|
||||
endef
|
||||
@ -42,8 +42,8 @@ define Build/Compile
|
||||
CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS) " \
|
||||
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
||||
INCL="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include" \
|
||||
MYLIBS="-lbluetooth -lglib"
|
||||
INCL="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include -I$(STAGING_DIR)/usr/lib/libiconv/include" \
|
||||
MYLIBS="-lbluetooth -lglib -L$(STAGING_DIR)/usr/lib/libiconv/lib -liconv"
|
||||
$(STRIP) $(PKG_BUILD_DIR)/bemusedlinuxserver
|
||||
endef
|
||||
|
||||
|
@ -3,10 +3,9 @@
|
||||
# You only need to set up options which have no default and which ware not optinal
|
||||
|
||||
# this is a mpd-hack version by michu@neophob.com
|
||||
# just for information: "xmms" means "mpd"!
|
||||
|
||||
# Path to mpd (if mpd is in path only mpd) (default is mpd)
|
||||
xmmsdir=/usr/local/bin/mpd
|
||||
mpddir=/usr/local/bin/mpd
|
||||
|
||||
# channel for what the serial port service is registered (with sdptool look in README) (default 10)
|
||||
# example:
|
||||
@ -31,10 +30,6 @@ channel=3
|
||||
# point this directory to the mpd music directory!
|
||||
mp3dir=/
|
||||
|
||||
# whether to autostart mpd when the server is started (0 (no) or 1 (yes)) (default=1)
|
||||
# THIS OPTION IS NOT SUPPORTED!
|
||||
# autostartxmms=0
|
||||
|
||||
# bookmarks file for URLs of net radio stations (optional)
|
||||
bookmarkfile=/etc/bemused-bookmarks
|
||||
|
||||
|
13
utils/bemused/patches/100-iconv.patch
Normal file
13
utils/bemused/patches/100-iconv.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- bemused-mpd-r059/mpdctrl.orig 2008-04-23 11:53:58.000000000 +0200
|
||||
+++ bemused-mpd-r059/mpdctrl.c 2008-04-23 14:36:34.000000000 +0200
|
||||
@@ -160,8 +160,8 @@
|
||||
}
|
||||
|
||||
/* OpenWRT needs a type cast */
|
||||
- /* iconv_value = iconv(i, (const char **)&p1, &fromlen, &p2, &tolen); */
|
||||
- iconv_value = iconv(i, &p1, &fromlen, &p2, &tolen);
|
||||
+ iconv_value = iconv(i, (const char **)&p1, &fromlen, &p2, &tolen);
|
||||
+ /* iconv_value = iconv(i, &p1, &fromlen, &p2, &tolen); */
|
||||
if (iconv_value == (size_t) -1) {
|
||||
error ("ICONV ERROR3: failed to convert string, error: %d\n", errno);
|
||||
return "ICONV ERROR3";
|
Loading…
x
Reference in New Issue
Block a user