mini_snmpd: fix the size argument to memset (#13764)

Building with gcc-4.8 spotted this memset size argument misuse, fix this.

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39901 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2014-03-12 21:32:58 +00:00
parent d6272ec527
commit 787e4e15a2
2 changed files with 13 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2009-2012 OpenWrt.org
# Copyright (C) 2009-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mini_snmpd
PKG_VERSION:=1.2b
PKG_RELEASE:=7
PKG_RELEASE:=8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://members.aon.at/linuxfreak/linux/

View File

@ -0,0 +1,11 @@
--- a/mini_snmpd.c
+++ b/mini_snmpd.c
@@ -443,7 +443,7 @@ int main(int argc, char *argv[])
/* Store the starting time since we need it for MIB updates */
if (gettimeofday(&tv_last, NULL) == -1) {
memset(&tv_last, 0, sizeof (tv_last));
- memset(&tv_sleep, 0, sizeof (&tv_sleep));
+ memset(&tv_sleep, 0, sizeof (tv_sleep));
} else {
tv_sleep.tv_sec = g_timeout / 100;
tv_sleep.tv_usec = (g_timeout % 100) * 10000;