fix jamvm compile on mips (#1031)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@5725 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2006-12-08 16:30:37 +00:00
parent 5902d43647
commit 7a0ea3cbfc

View File

@ -68,7 +68,7 @@ diff -urN jamvm-1.4.0-orig/src/arch/Makefile.in jamvm-1.4.0/src/arch/Makefile.in
diff -urN jamvm-1.4.0-orig/src/arch/mips.h jamvm-1.4.0/src/arch/mips.h
--- jamvm-1.4.0-orig/src/arch/mips.h 1970-01-01 01:00:00.000000000 +0100
+++ jamvm-1.4.0/src/arch/mips.h 2005-11-29 22:31:08.000000000 +0100
@@ -0,0 +1,70 @@
@@ -0,0 +1,69 @@
+/*
+ * Copyright (C) 2003, 2004, 2005 Robert Lougher <rob@lougher.demon.co.uk>.
+ *
@ -92,7 +92,6 @@ diff -urN jamvm-1.4.0-orig/src/arch/mips.h jamvm-1.4.0/src/arch/mips.h
+#define OS_ARCH "mips"
+
+#include <bits/atomicity.h>
+#include <asm/atomic.h>
+
+/* Override default min and max heap sizes. mips machines are
+ usually embedded, and the standard defaults are too large. */