[packages] triggerhappy: fix determination of input.h, remove explicit override (#8990)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@25890 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-03-06 17:26:48 +00:00
parent 13e3cf24bc
commit 7a75faf30a
2 changed files with 11 additions and 1 deletions

View File

@ -32,7 +32,6 @@ define Package/triggerhappy/description
endef
MAKE_FLAGS += \
LINUX_INPUT_H=$(TOOLCHAIN_DIR)/usr/include/linux/input.h \
$(TARGET_CONFIGURE_OPTS) \
$(1)

View File

@ -0,0 +1,11 @@
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ THCMD_COMPS := th-cmd cmdsocket
MAKEDEPEND = $(CC) -M -MG $(CPPFLAGS) -o $*.d $<
-LINUX_INPUT_H := $(shell echo '\#include <linux/input.h>' | $(CC) $(CPPFLAGS) -M -E - | awk 'NR==1 {print $$2}')
+LINUX_INPUT_H := $(shell for i in `echo | $(CC) $(CPPFLAGS) -M -E -include 'linux/input.h' -`; do test -f "$$i" && echo "$$i" && break; done)
all: thd th-cmd man